1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

[Update 12/5/11]Full root for Nook Tablet. [11/20/11]


  1. Indirect

    Indirect Member

    NOTE: Anyone who is having problems with drivers, http://forum.xda-developers.com/showthread.php?t=1363652 <-- That explains the two most common problems.


    Step by step video from my friend Albert to gain root access:
    http://www.youtube.com/watch?v=1zbT1Fj38nE

    This also includes a gApps install section in it incase you decide you want to run that. :)

    You may NOT use the included script in your work without atleast asking me as of now, this may change in the future but I dont want to have to hop from thread to thread just to offer support when I can keep the answers organized for all to find. So please just ask first.
    Thanks.

    Information:
    I have gotten zergRush to work on the nook tablet as well as created a batch script for you to run to allow you to root your tablet. This does NOT unlock the bootloader software/hardware checks this is just so you can remove whatever unnecessary crap you wish to get the **** off your device.

    Needed files for root:
    You need drivers first:
    http://dl.dropbox.com/u/15069134/usbdrivers.zip

    here is an app to pull up usb debugging menu
    http://li362-167.members.linode.com/gapps/non_google/tgps_launcher.apk
    Code (Text):

    <robertely> Also note, that while that box will remain checked, the setting is not persistant.
    <robertely> So you have to flick the top 'Usb Development' box twice to get it working.
     
    Download Link for rooting script:
    http://dl.dropbox.com/u/15069134/Nook&Zergy.zip

    How to get adb debugging enabled:
    Download the apk provided in the second download link to be able to access the menu *if you're just installing an app the first time, it will pull up the menu anyway but this is more for AFTER you have root as a convienance to access usb debugging and whatnot. Just try to install the apk *or open it if you already set unknown sources* and you will get a prompt to allow non-market apps. Click settings then you should be able to see "Unknown sources" check that followed by going into "Development" and check the 2 "Usb Debugging" boxes and uncheck "auto mount" then your nook tablet is ready to be used in debugging mode.


    Instructions to root:

    1. Download the "usbdrivers" zip
    2. Download the "Nook&Zergy.zip"
    3. Extract both to a folder C:\ntroot\
    4. Now you should see the following files and folders inside c:\ntroot:
    5. Run "runmefirst.bat" and follow the instructions.

    6a. When the batch file opens the device manager, If you don't see a broken device icon next to "NOOK Tablet" then you may have some other generic drivers taking over. Not sure how to remove them so you will have to move to another PC that has never had a tablet hooked up and start over.

    6b. If you do see NOOK Tablet with a broken device icon.. then right click and choose "update driver". Choose "Let me specify where the driver is" and browse to the c:\ntroot\usbdriver folder and hit ok. It should install and you can click "OK" to the warning about unsigned drivers.

    7. Run "NookandZergy.bat" and follow the instructions
    7a. If you see a long string of numbers/letters it's your device
    Now you should have root.





    How to Unroot: Check out this thread:



    Code (Text):

    Changelog:
    4.0: Included de-bloater and launcher install (you get to choose!)
    3.5: Updated to check for proper USB Vendor ID as well as check for root.
    3.0: Updated to include system app  replacements (Keyboard, Email, Gallery) As well as adding live wallpapers for other launchers. You need to choose to run this part of the script same as gApps.
    2.7: Updated Gapps to latest [9/30/2011]
    2.5: Fixed a few minor typo's/bugs with the script
    v2.1: Added usb vendor id addition to adb_usb.ini
    v2.0: Rewritten script to allow for more user choices; added Gapps installer (thanks anlog); Added busybox installer apk and debug menu puller (allows you to access debugging menu)
    v1.1 Updated superuser apk
    v1.0: Official release
    v.75: Updated to install SU and superuser.apk
    v.5: Initial release
     
    Code (Text):

    Credits:
    Gojimi for his HomeCatcher.apk
    Developers of ADW launcher for their APK
    Developers of Go launcher for their APK
    Syndicate Apps for their Honeycomb Launcher
    anlog for finding out how to get nook color drivers to work and general testing
    Team Revolutionary for their exploit
    B&N for using android like good little sheep
    suicideclown for bearing with me while I tried to get it to work on his computer until anlog found the driver fix.
    Dsstrainer for the simplified instructions.
     
    How to do it manually instead of running the Nook&Zergy.bat file (for linux or mac users or someone who wants to do it all manually)

    Install drivers and follow instructions up until running the batch file then do the following commands in order:
    Code (Text):

    adb push zergrush /data/local/zergy
    adb shell "chmod 755 /data/local/zergy;cd /data/local/;./zergy"
    adb wait-for-device install Superuser.apk
    adb remount
    adb push su /data/local/tmp/
    adb shell cd /data/local/tmp;chmod 777 su;cd /;mount -o remount,rw -t rootfs rootfs /;
    adb push su /system/bin/su
    adb shell chmod 4755 /system/bin/su
     

    Wanna buy me a coffee or something pretty for christmas?
    [​IMG]

    Unroot method can be found here


    Rooted nook tablet using my method
    Taken from inside of barnes and noble;
    [​IMG]

    Advertisement
    :
  2. colchiro

    colchiro Well-Known Member

  3. colchiro

    colchiro Well-Known Member

  4. Indirect

    Indirect Member

    Updated to version 4.0
  5. Indirect

    Indirect Member

    Don't use this until about 4 and a half hours from this post.
  6. scootmcdoot

    scootmcdoot Well-Known Member

    Its been 4 1/2 hrs. I'm not sure what you mean.
  7. Indirect

    Indirect Member

    I had to rewrite the script as I needed to have it properly recognize the launcher. Basically what happened, was that it needed the apk to be found but I forgot to add something to a variable and it caused it to not be found meaning, no home screen for the user which = bad. It works fine now.
  8. scootmcdoot

    scootmcdoot Well-Known Member

    Wow. I just watched Alberts video and I want my tablets now. I am ready to root away (will almost). Great work Indirect.:)
  9. radtechy

    radtechy Well-Known Member

    I'm ready to buy one also!!! Anyone have problems with the rooting process
  10. NightAngel79

    NightAngel79 Lv 60 Bounty Hunter Moderator

    NO idea what this means. DL'd the apk but dont know how to install in on nook, keeps saying 'not supported' or something like that.....

    Can anyone dumb it down for me?
  11. NightAngel79

    NightAngel79 Lv 60 Bounty Hunter Moderator


    Ignore that dude^ he's an idiot :D
  12. Hrethgir

    Hrethgir Well-Known Member

    I did the Zergy root and got that done, but it didn't do everything that the video showed, so I ran it again, it said I was already rooted, then asked if I wanted to make the N button go straight home and add a Menu button to the status bar. I said yes, and now the N button takes me straight home, but the menu button it added to the status bar doesn't do anything. How do I fix this? I can't even get online now because I can't access the menu to pick Web! And that's one of the main things I want this thing for!
  13. Hrethgir

    Hrethgir Well-Known Member

    OK, used the acclaim_update.zip to restore back to stock 1.4.0, then redid the whole thing, rocking GO Launcher and everything works like it should! Unless I'm supposed to have the Android Market, I don't have that. I do have the Amazon Appstore though, so I'm not totally SOL there.
  14. NightAngel79

    NightAngel79 Lv 60 Bounty Hunter Moderator


    You should of had the option to add gapps, it didn't ask you that?
  15. aceofspades626

    aceofspades626 Well-Known Member

    Bah! This worked great. Had everything working beautifully, but I must have missed something because I woke up this morning to find that my tablet updated to 1.4.1. :confused:
  16. NightAngel79

    NightAngel79 Lv 60 Bounty Hunter Moderator

    Did you do the separate fix to block OTA's? He linked to it in the XDA thread. (and maybe this one?)
  17. pastafarian

    pastafarian P√Ętes avec votre foie Moderator

    I had that issue the first time I ran the root process. It seemed to complete, but never asked if I wanted GAPP's or to debloat which means it didn't finish. I noticed this, did a hard reset and re did the process, which worked as advertised. Took an additional 10 min or so if IIRC.
  18. Hrethgir

    Hrethgir Well-Known Member

    Yup, same thing happened to me. Did the acclaim_restore.zip method of returning it to stock, then redid the root. Came up and asked for everything this time. Although for some reason it didn't see the SD card I had in it, so gApps didn't actually install. But I'm up and running fine with GO Launcher, and I'll do the seperate add-on for gApps tonight, should take care of that. But even without gApps, I have the Amazon Appstore installed and have grabbed games from it and installed them fine. Do still need to do the Stop OTA Updates fix though, but that will be simple. Then I can finally freely play with my new toy!
  19. aceofspades626

    aceofspades626 Well-Known Member

    I rooted after the block was incorporated, but I guess the process didn't quite finish. I got through gapps and was asked about debloat. I hit 3, but then it just closed. Guess I figured that was normal.

    Just restored and ran again. This time debloated and was asked again. Hit 6 and was asked about block and permanent menu button. Totally never saw that on the previous try. Guess that was it.

    Thanks much all!
  20. Hrethgir

    Hrethgir Well-Known Member

    I am now fully rooted and have the OTA block done, loving this thing! So much better for playing games on than my Droid X, and much more convinient for web surfing than my big laptop!
  21. 80yearold

    80yearold Active Member

    with a new tablet planning to purchase SD card I have a concern. Is it best to root with card inserted, does it make a difference and this is a 1.4.1
  22. Hrethgir

    Hrethgir Well-Known Member

    Are you going to downgrade it to 1.4.0 and then root? I did my root with the SD card in it, I think it needed to be there to write files onto it.
  23. zero2toy

    zero2toy New Member

    Looking for access to TGPS Launcher. Could you please allow me to download so I may root my nook?
  24. varxtis

    varxtis Active Member

    Trying to Root Nook BNTV250.
    Cannot find very many current/recent methods or straight forward explanations on how to root. I found the following youtube video that seems to be the most recent. but there are a few questions I have
    [How To] Install CM 10.2 (Android 4.3.1) For The Nook Tablet In 10 Minutes or Less [NOT NOOK COLOR] - YouTube

    It sounds like if I were to root based on a micro sd card, then it will only remain in root if the SD card is inside if the Nook is powered off/restarted. And even then, you have go through the process each time. is this correct? Id much rather root to the internal storage, so as not to have to rely on the SD Card. Ive gone to the wordpress link provided in the "about" section of the youtube video, but the information there, how to root to the internal storage is extremely confusing for me. There is a lot of mention regarding gApps when I search the matter, but I can't understand if it's a must for rooting the Nook, or just an option. Please, if anyone can help me with this, it would be greatly appreciated.
Loading...

Share This Page