1. Check out our app, Forums for Android! Download and leave feedback here!

Root 2.2 GMail doesn't sync

Discussion in 'Android Devices' started by ech0, Jun 6, 2010.

  1. ech0

    ech0 Active Member
    Thread Starter
    18

    May 30, 2010
    35
    12
    18
    Chicago
    I've started using 2.2, and it's going great, but I've noticed that when I read and archive an email on my phone, it's not reflecting it on the computer.

    Previously whenever I'd run into issues like this I'd clear the cache on the Gmail Storage in the Manage Applications menu, and it'd resync, but in 2.2 there's only the Gmail app, and the Clear Cache button is grayed out.

    Accounts are all set to sync.

    Anyone else having this issue?
     

    Advertisement

  2. nstallion

    nstallion Well-Known Member
    143

    Nov 13, 2009
    1,152
    136
    143
    San Diego, CA
    Just sent myself an email with Gmail on desktop. Droid got it within about 10 seconds. Deleted it with my Droid. Checked 30 seconds later and it's gone from my Gmail on the web.

    Mine is working fine.
     
  3. ska.t73

    ska.t73 Well-Known Member
    163

    Mar 11, 2010
    1,659
    305
    163
    Phoenix, AZ
    I get this every so ofter no matter what rom I'm on... I got it once yesterday on the 2.2 rom but I was able to clear data in the app settings for Gmail and it worked... I did notice there is no app options for Gmail Storage but the Gmail options worked for me... Is your clear data greyed out too or is it just the clear cache?
     
  4. ech0

    ech0 Active Member
    Thread Starter
    18

    May 30, 2010
    35
    12
    18
    Chicago
    Clear data is available. Will that effect my account on the phone at all, or will it just delete all locally stored email and redownload it?

    Edit: I just cleared my inbox from my desktop computer, and it synced up with my phone, so I guess it is working fine. It's just that I had one unread email on my desktop that I had read and archived on my phone, but it wasn't reflecting that on my computer.

    Edit, Redux: Turns out that when I read/archive things on my phone, it doesn't reflect it on the web client on my computer. It does, however, work vice-versa.
     
  5. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    Whoa, that is a problem then. The view should be the same regardless of the interface.

    Still, I saw something just like that the other day - and didn't think twice about it.

    I had removed an email from either my phone or from Thunderbird, but the webmail interface didn't register it regardless of the number o time I refreshed the page - only after changing the view to another folder and then coming back did it register.

    This may, in fact, be a Webmail interface issue, not a phone issue.
     
  6. unobtrusivetones

    unobtrusivetones Well-Known Member
    16

    Dec 28, 2009
    64
    2
    16
    Cali
    Go into your gmail settings and check your labels. Make sure your inbox and sent folders are set to sync all. I usually have to do this after flashing a new ROM.
    Not sure if it will solve your problem but good luck :cool:
     
  7. johnlgalt

    johnlgalt Antidisestablishmentarian
    453

    Oct 28, 2009
    9,416
    1,924
    453
    Male
    Graduate Research Assitant | That part time IT guy
    3rd Rock
    God, I have so many folders, I prefer to only sync the inbox, and a few others.

    I have folders (aka labels) set up in GMail so I can do server side filtering - makes it a lot easier then trying to let my email clients do it and mess things up when I get hit with a dropped connection cause I use GMail IMAP exclusively at home....
     
  8. ech0

    ech0 Active Member
    Thread Starter
    18

    May 30, 2010
    35
    12
    18
    Chicago
    Thanks for the suggestions. I went ahead and cleared data from the Gmail app in Applications settings and that did the trick. :]
     

Share This Page

Loading...