1. Are you ready for the Galaxy S20? Here is everything we know so far!

Can't Connect to a Certain Wi-Fi Access Point, but can others

Discussion in 'Android Help' started by yoshiMoshi, Dec 20, 2020.

  1. yoshiMoshi

    yoshiMoshi Lurker
    Thread Starter

    Just bought this Moto G Fast phone today, brand new, and I'm having issues connecting to Wi-Fi. Whenever I attempt to connect to a Xfinity Wi-Fi access point, it attempts to connect and tells me sign-in is required. I get to the screen where I enter in the username and password, but it then disconnects me from the access point, and takes me off the sign-in page before I can enter in the information. This happens in an endless loop. Never staying connected for more than a few seconds before it disconnects and reconnects.

    I tried doing a factory reset multiple times.

    I tried forgetting all wi-fi networks.

    I have tried resetting the wi-fi, Bluetooth, and wireless network settings.

    I tried doing a hardware Wi-Fi test, and get the green check mark.

    I tried turning off my phone, waiting for thirty seconds, and turning back on my phone with the issue still existing.

    I have tried resetting my phone multiple times.

    I have removed my SIM card and reinserted it.

    I can use my computer to connect to this Xfinity Wi-Fi access point, and then use my computer as Wi-Fi hotspot. My phone is then able to connect to my computer to access Wi-Fi to this Xfinity Wi-Fi hotspot indirectly. It however cannot connect directly to it by itself.

    I'm able to connect to other Wi-Fi access points without issues, it's just Xfinity Wi-Fi access point near my home that I can no longer connect to. My computer however is able to connect to this same exact Xfinity Wi-Fi access point without issue. The connection from my computer to the Xfinity Wi-Fi access point is stable, I'm able to watch YouTube videos etc on it. However for whatever reason, sitting at the SAME exact desk my computer is at with my phone, my phone isn't able to maintain a constant connection for more than a few seconds.

    I don't have physical access to the router.

    Thanks for any help! I have the feeling I should just return the phone, but I don't want to pay the $49 restock fee, and this seems to be a software issue, and not a hardware issue, so I'm not sure anything is wrong with the device from a hardware perspective.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Dannydet

    Dannydet Extreme Android User

    You don't have physical access to the router....
    And this is a generic wifi signal.
    Good luck with that.
     
  3. mikedt

    mikedt 你好

    Occasionally some WiFi routers and WiFi APs can have issues where one device can't connect, but others can, and rebooting them can often fix it. Like it could be its DHCP pool is full, and it can't allocate any more IP addresses to devices that are trying to connect.

    If you don't have access to the router/AP, then check with the person or admin who does. I've had this happen in a hostel in Hong Kong, and the manager did reboot the router for me.
     
  4. Xavier Black

    Xavier Black Android Expert

    I used to have this same exact issue in my Note4..now I don't surfer of it..the problem went away I believe in the moment I changed my rom..
     
    mikedt likes this.
Loading...

Share This Page

Loading...