1. Check out our companion app, Forums for Android! Download from Google Play

Can't remove write protect on micro sd, card shows up damaged on phone

Discussion in 'Android Accessories' started by howareyourcats, May 21, 2012.

  1. howareyourcats

    howareyourcats New Member
    Thread Starter

    May 21, 2012
    I recently bought a 16gb micro sd card for my droid. The first time I put it in my phone it worked fine; I was able to add and delete the contents on it. So, I put it in the adapter and into my computer to move the stuff from my old card to the new one with no problems. Then I put the new micro sd into my phone and it showed up as damaged, asking if I wanted to reformat it. I chose yes and after that nothing happened. After having this happen a few times, I put the micro back into the adapter and into my computer. It showed up as write-protected and would not let me do anything to the card. I tried the lock switch trick and still nothing. Just to make sure the adapter wasn't the problem, I put my old micro sd in it and did not get the write-protected message.

    Anyway.. I guess what I'm asking is, where should I go from here? Did I do something wrong in the process of transferring data from card to card? Is my card a dud or is there hope for the little guy?

    I know I'm asking a lot, but thank you for any and all help :D

    Nevermind, I found a solution through another forum.. I would just delete this post but since I'm new I'm not sure how, oops


  2. vansue1981

    vansue1981 New Member

    May 22, 2012
    How did you get it fixed?! Mine is doing the same thing and I'm frustrated!!! Please let me know the link to where you figured out how to fix it cause so far I can't find anything...

Share This Page