1. Are you ready for the Galaxy S20? Here is everything we know so far!

Could not authorise Facebook

Discussion in 'Android Devices' started by parasmohan, Sep 15, 2011.

  1. parasmohan

    parasmohan Newbie
    Thread Starter

    Hi,

    I keep getting messages on my mobile - "Could not authorize with facebook" but when i click on the link , it connects to facebook and opens up the page saying - " This phone is already authorised with facebook ".

    Can someone help me plz to resolve this issue.

    -Paras
     

    Advertisement

  2. Profile7

    Profile7 Newbie

    I'm getting the same thing today... did you manage to resolve this?
     
  3. beau420

    beau420 Android Expert

    What version of Android are you guys running? 2.1 or 2.3?

    Have you tried running any Market updates to make sure there aren't any facebook app updates?

    Facebook may be forcing people to login over HTTPS instead of HTTP (login securely instead of using plain text password) I know that they changed that for gmail accounts a couple months ago.

    I would suggest trying to login from scratch. Maybe open Settings->Applications->Manage Apps->Find Facebook and click into it, and click Clear Cache......then try logging back in.

    Or open a browser on the phone and goto Welcome to Facebook - Log In, Sign Up or Learn More and try and login without the facebook app.
     
  4. Profile7

    Profile7 Newbie

    Thanks for the suggestions beau420.

    There isn't actually any problems logging in. I can log in using the app as normal and just ignore the notification. Clicking on the notification just takes you to a screen which says 'You have already authorised Sony Ericcson Xperia. Press Okay to continue', and when I press OK, then it disappears, only to reappear a minute or so later.

    When I go into accounts/sync, there are two different facebook icons, which differ slightly. If you click on the slightly bigger icon (the regular facebook icon) it shows my email address at the top with the word 'Facebook' underneath, and a sync Contacts option. The other icon has 'Sony Ericcson Facebook Integration' under my email address with the options to sync contacts, calender and albums in the gallery.

    If I 'remove account' on the regular icon, it does so and the other icon disappears too. But if I 'remove account' on the other icon, it just reappears again immediately. I don't know if this has anything to do with it.

    I tried clearing the cache/data but that didn't work. I'm running 2.3 by the way, and never had a problem with it until today...
     
  5. beau420

    beau420 Android Expert

    Something to do with Facebook messenger:

    Facebook Messenger update hits Android, BlackBerry smartphones

    I have never used facebook on my phone.

    Do you have the messenger off? On know on the computer there is a way to view and chat with users that are currently online. Do you have that option turned off? I would suggest turning it off.

    My guess is that the problems is facebooks fault....maybe something to do with facebook update today.
     
  6. Profile7

    Profile7 Newbie

    I think you could be right, because the 'you are already authorised' screen has the facebook logo at the top, so it must be something at their end.

    I don't use the messenger/chat thing, but it must be something to do with this... thanks so much for your help.
     
  7. clockwork58

    clockwork58 Android Enthusiast

    I am also getting the same error throughout the day.

    The Facebook App works just fine, and I have it set to update manually. So I think it has to do with the FB sync within the OS. It's either the FB API is down on FB's end, or the FB API has changed and SE needs to update code to adjust.

    Those are my thoughts.
     
  8. 916x10

    916x10 Android Enthusiast

    Are you guys rooted?
     
  9. clockwork58

    clockwork58 Android Enthusiast

    You know I am.
     
  10. 916x10

    916x10 Android Enthusiast

    Cool. Then uninstall the real facebook app, then using timescape, attempt to log on to facebook and make a post. If problem persists, remove facebook in xperia app, reinstall facebook app and see what happens. Don't fret, I can get all the stock GB apk's for you so you can get it all reinstalled;)
     
  11. wooks63

    wooks63 Well-Known Member

    I'm on normal, unrooted 2.3 firmware and started getting this yesterday.

    After much messing about, I seem to have got rid of it (fingers crossed). I just went into facebook and 'unauthorised' my xperia from there and then went back in on my phone and authorised it.

    I was getting the message almost constantly, but since doing this (over 3 hours ago) i've not had any more. Hopefully it will stay that way!
     
  12. Smokey_Barr

    Smokey_Barr Well-Known Member


    How did you do that?
     
  13. Profile7

    Profile7 Newbie


    I tried that last night but it didn't work. I left my phone on all night and when I got up this morning, I cleared the notification and it didn't come back.

    There were loads of complaints about this on SE's facebook page so I presume they (Facebook) got round to fixing it.
     
  14. wooks63

    wooks63 Well-Known Member

    Go onto facebook from your PC or the browser on your phone and at the top right hand corner, click the drop down arrow next to 'Home' and select Account Settings. From this screen, on the left hand side, select apps and somewhere on this list that displays you should see something like 'Sony Ericsson Xperia'. click on 'Edit' and then 'remove app' (I think just clicking on the 'x' will also remove it).

    Then go into the facebook app on your phone and it will ask you to authorise it. Do it and see if all's OK.

    Since doing this yesterday morning I haven't had any further authorisation messages.
     
  15. clockwork58

    clockwork58 Android Enthusiast

    I myself did the same stuff.
    - Remove fb account from "Accounts & sync"
    - Logged out of the fb app
    - (don't use timescape)

    Removed all authorized devices from fb.

    Started over again in readding. I got the error msg again, but haven't gotten it again in the 24hrs since then.

    I think the API was probably acting funny.
     
  16. alex_ncfc

    alex_ncfc Member

    I'm still getting this message, but not as frequently as 3 or 4 days ago (it was literally happening every time I woke my phone up) Now it's happening once a day or so.
     
Loading...

Share This Page

Loading...