1. Are you ready for the Galaxy S20? Here is everything we know so far!

Desire 2.2 NO GPS! Non rooted, Voda

Discussion in 'Android Devices' started by Pace, Aug 10, 2010.

  1. Pace

    Pace Newbie
    Thread Starter

    So since the 2.2 OTA Update. I havent been able to get a GPS Lock on my HTC Desire. This used to take seconds. Now I get nothing, no matter how long I wait.

    Vodafone, non rooted HTC Desire

    1. Download the Forums for Android™ app!


  2. anoniemouse

    anoniemouse Android Expert

    Try doing a factory reset, this should help clear any conflicts
  3. Pace

    Pace Newbie
    Thread Starter

    Hi, thanks for the feedback. This was the first thing I tried. Still no joy
  4. anoniemouse

    anoniemouse Android Expert

    Have you tried turning off the phone & removing the battery, then replace & turn back on as this can sometimes help.
    Check & make sure the gps isn't turned off.
    Other than that i am not sure what else to try, other than contact vodafone.
    no fit state likes this.
  5. post #4 by anoniemouse worked for me but I also unmounted the sd card before turning off. GPS fine now after exactly the same problem.
  6. Pace

    Pace Newbie
    Thread Starter

    Hmm I was really hoping this would fix mine. I still seem to have the same problem however.

    Does anyone know if I can do something like flash the radio without root or something in case something messed up during the update?
  7. afroboy70

    afroboy70 Newbie

    Hi I got the OTA update on the 23 /8 /10 and since the update I cannot get the GPS to lock or work at all with google maps or navigation. Just says "waiting for satellites"

    Two month old branded locked desire.

    Already tried factory reset, switching off taking battery out, switching on. using outside for 30 mins with gps switched on.

    htc-kernel@and18-2 #1
    build CL229389

    Any ideas how to get this working? everything else working fine with the phone.
  8. TonyHTC

    TonyHTC Newbie

    I'm also not able to get GPS since the Voda OTA update on 23/8/10.

    I've tried this but it doesn't seem to have worked - do you mean "Check & make sure the GPS isn't turned off" BEFORE I turn off, replace battery etc? i.e. turn on GPS then turn off phone?

    I would really like to get my GPS back as I use it loads with Mytracks. It's annoying waiting for 2.2 only to find it doesn't give full functionality! I wanted more not less!!!
  9. Gisbourne

    Gisbourne Member

    Realise I will probably sound like a duffer when I say this, but you are trying to get a signal outside I hope?

    Only reason I mention it is as I read a thread elsewhere where someone wasn't getting a signal because they were indoors!

    Start with the basics as they say! Assuming you are trying it outside and have already done the hard reset, sadly I think it might be a candidate for replacement...

  10. no fit state

    no fit state Well-Known Member

    Just realised I hadn't tried using my GPS since I updated, and.....it didn't work :(

    Thankfully turning it off and pulling the batter as suggested by anoniemouse has got it working again :)
  11. afroboy70

    afroboy70 Newbie

    Yep, outside, away from buildings, clear sky, 30 mins leaving on the maps app...no joy syncing up even though the a-gps is working fine and is meant to speed up the process.

    @ no fit state
    I'm so happy for you ;)

    I've spoken to Voda tech support and HTC tech support and I guess it's a new issue as they don't know what to do. Have had to book the phone in for a warranty repair. 14 workings day turn around!! WHY AM I AN EARLY ADOPTER, IT ONLY LEADS TO HEARTACHE....
  12. Grace6889

    Grace6889 Lurker

    This is my first post. So hello everyone.:)
    I know there is a way can double check this problem.
    Try to enter safe mode, this mode will bypass the any 3rd party application download from market.
    This could help us to analysis if device come with strange behavior issue under OS mode.

    For Desire,
    Press power key then press and hold the menu key
    1. Press " power key " for power on device
    2. Press and hold " Menu key " until entering OS
    3. " Safe Mode " text will appears on the lower left of screen.

    So if after enter safe mode, and you really fail to use GPS/Google map...etc
    there might be FOTA update problem.if not, it might be other market application merge problem..
    I hope this way can help you before you get your phone to repair.:p
  13. Donniehun

    Donniehun Lurker

    Hi everyone,

    I'm having the same issue I've tried all the "tricks" which were mentioned above but no joy.
    My desire is unbranded factory unlocked from Irish Voda.
    I hope it will be sorted out soon as I will need the GPS.
  14. afroboy70

    afroboy70 Newbie


    thanks for the info. tried in safe mode but no joy :(

    handset off the HTC today..... lets hope the turn around is quicker than the 14 WORKING days....
  15. TonyHTC

    TonyHTC Newbie

    Did anyone get a fix result yet on this. I still can't get my GPS working!

    Tried all of the above, the device GPS doesn't even seem to be turning on let alone searching for a position. There's no notification icon.

    I want my GPS back!!! :(
  16. TonyHTC

    TonyHTC Newbie

    Hello all,

    I think I may have a solution for you. (It has worked for me!!)

    I'll just let you know exactly what I did in case any of it had an effect.

    I turned off my phone as mentioned previous.
    Took out the battery
    Took out the SIM
    Took out the SD Card
    Waited for about 5 minutes
    Put it all back in again and turned on the phone

    Then I installed "GPS Status" by EclipSim from the market

    Went to the park and turned on GPS on the phone.
    Opened the app and let it search (this was the first time the GPS icon has appeared in the notification bar)
    It found my location!!
    Now my other apps (google maps/navigation/mytracks) all seem to work.

    Tracked my way home from work last night and it was perfect.

    Hope this works for other people too.
    dekoboko likes this.
  17. cse201

    cse201 Lurker

    I have discussed this issue with HTC and they say that this was the first they have heard about it and will have to get back to me. Perhaps they should monitor the forums.
  18. SUroot

    SUroot Extreme Android User

    My story is similar but used GPSTest on the market by Mike Lockwood.
  19. cse201

    cse201 Lurker

    How may people have contacted HTC about this issue? HTC UK have categorically stated that I am the first person to contact them about this issue and they have not been informed about it by any of there international collegues. I now have to return my phone (for a third time).
  20. anoniemouse

    anoniemouse Android Expert

    Not had any problems with gps on my phone, but i normally find one of the following work to clear problems with the desire.

    1) Reboot the phone.
    2) Turn off the phone remove the battery, replace battery & turn back on.
    3) Factory reset settings/privacy/factory data reset.
    4) If you are rooted reinstall rom & radio, or try a different rom.
  21. TonyStark

    TonyStark Lurker

    I had this problem. found the answer on xda forums, the problem was mobile internet not downloading the SUPL data for the A-GPS, once I put it into the APN type how it is meant to be for O2 this it started working for me with 2.2.
  22. Beaker

    Beaker Lurker

    I have.

    I have a ticket to send it back to the repair centre, again. :rolleyes:
  23. lammertsm

    lammertsm Lurker

    I tried several solutions, but nothing Works.
    The solution that works was this.

    Power off Phone
    Remove SIM
    Start Phone (without SIM)
    Start GPS Status (download from market)
    I got some satellites and a fix (indoor)
    Power off Phone
    Insert SIM
    Start Phone
    Start GPS Status
    Works still
    dekoboko likes this.
  24. dekoboko

    dekoboko Lurker


    My phone used to be able to pick up a GPS signal pretty easily from my window, but maybe the satellites have since moved or something, as the past few days have been GPS-free.

    I tried a combo of the methods described in #23 and #16:
    - Download some form of GPS testing app (I used GPS Test by Chartcross)
    - Power off
    - Take out SD and SIM cards
    - Wait
    - Power on
    - Turn on GPS testing app (find out what all the screens and things mean first!)
    - Where I usually get my signal (by a window) wasn't showing any love, so I moved towards the balcony... then opened the door, stuck my phone outside and whammo -- GPS!

  25. reinholt65

    reinholt65 Lurker

    This worked for me. Thanks!

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page