1. Download our Official Android App: Forums for Android!

Root [Guide] Internet Tethering w/ Evo - 4G/3G, Wireless/Wired

Discussion in 'Android Devices' started by mdizzle99, Jan 2, 2011.

  1. frenchy714

    frenchy714 Android Expert
    Rank:
    None
    Points:
    333
    Posts:
    3,153
    Joined:
    Nov 11, 2010

    Nov 11, 2010
    3,153
    1,957
    333
    Male
    East Tawas, MI
    I agree it should be stickied, as well as Akazabam's PCI36IMG.zip thread.
     

    Advertisement

  2. JohnnyMack

    JohnnyMack Newbie
    Rank:
    None
    Points:
    16
    Posts:
    23
    Joined:
    Dec 9, 2010

    Dec 9, 2010
    23
    5
    16
    Minnesnowta
    I switched to MikFroyo and it started back working.
     
  3. GrandMasterBirt

    GrandMasterBirt Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    131
    Joined:
    Sep 12, 2010

    Sep 12, 2010
    131
    2
    36
    Question: As i travel across NYC with wifi tether and 4g turned on, periodically the tether will go into "dead mode" where its still thinking tethering is turned on but it wont talk. The only solution is to restart tethering by turning it off, then on again. This happens frequently. And only when moving locations. I am assuming that interference from other wifi networks is the cause, but the app especially crashes. I will try again using the 3.0 release to see if anything has improved. So the question is: Is there a known reason for this, is there a workaround?
     
  4. mdizzle99

    mdizzle99 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    68
    Posts:
    418
    Joined:
    Jul 10, 2010

    Jul 10, 2010
    418
    108
    68
    Thanks for everyone's support on this thread. I am glad to know it has helped some people.


    In response to this question... I wished I had a good answer. I have read of similar issues - even when people aren't traveling - in regards to wireless tether. The best advice I have is to try a couple different versions. I list some in my original post; you may need to do the "fix" to get 4G speeds.

    Just curious, have you tried using the native wireless hotspot on 3G? I wonder if that also has problems staying connected while traveling. Let us know if you find any good solutions, and I will keep an eye out and maybe do some research myself to see if I can help a little more.
     
  5. JB in AZ

    JB in AZ Android Expert
    Rank:
    None
    Points:
    173
    Posts:
    1,869
    Joined:
    Oct 27, 2009

    Oct 27, 2009
    1,869
    267
    173
    Florida
    Using Calkulin's EViO2 v1.8 ROM which includes both with Wireless Wi-Fi Tether and unlocked Sprint Hotspot. When using Wi-Fi Tether, I can connect either my laptop or my netbook just fine, and get on the Internet. Using the Sprint Hotspot, I can connect on both laptop and netbook, but the netbook will not get me on the internet.

    I have tried all the different security settings, as well as NONE (as a test)... still no internet on the netbook using Sprint Hotspot. Of course this is the one I travel with.

    The netbook connects to the internet just fine thru my home wi-fi, as well as any Wi-Fi that I have tried while traveling. (hotels, book stores, etc)

    I could just use the Wi-Fi tether when I travel, but the Sprint HotSpot should work on the netbook, right?

    WinXP SP3 on both.
    Netbook: AcerOne D255 2GB RAM, less than 6 months old

    Thanks for any ideas!
     
  6. Chuck Bevitt

    Chuck Bevitt Lurker
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Sep 3, 2010

    Sep 3, 2010
    6
    0
    5
    Computer Programmer
    Los Angeles
    I've got wireless tethering working on my EVO for 3G but not 4G.

    So far what I've done is to root it with unRevoked 3.32 following the instructions in the Rooting for Dummies thread here. I've confirmed root. Then I installed the market Wireless Tether for Root Users, version 2.0 6.

    The prerequisites for Wireless Tether are listed as Root & Netfilter-enabled kernel. I don't really know what Netfiltered-enabled is or if I have that. However, I don't get an error message regarding it when I run Wireless Tether.

    It's working for 3G speeds, but not 4G. I tried the fix by deleting the fixroute.sh file, but that just makes things worse (it causes clients to take a long time to connect and the speed is even worse).

    I know it's a 3G vs 4G issue, because internet speed tests done on a connected client is exactly the same as on the phone itself with 4G turned off. A speed test on the phone with 4G on is way faster.

    Anyone have a recommendation for getting the 4G through to Wireless Tether?

    PS: Getting this working has finally decided me to buy an iPad. I didn't want to get the 3G one that was more expensive and required another data contract, but I didn't like the idea that the wi-fi one couldn't connect away from a wi-fi hot spot. Now I can have it all!!

    Later .. I've also discovered that having Wireless Tether loaded slows down my 3G data connection to Sprint. Even if it's not running, even if I reboot my phone and don't run it, my 3G data connection on phone itself slows down from about 1.2 Mbps to about .8 Mbps. This is by measuring the speed using internet speed test web sites in the phone's browser. As soon as i unload the app (I also reboot - don't know if I need to), the speed goes back up again. Hmmm....
     
  7. petarded

    petarded Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Mar 5, 2011

    Mar 5, 2011
    4
    0
    5
    Just rooted then installed wireless tether... that worked but even after following the instructions on how to make it use the 4g it was still slow.

    I then installed the wired and now 4g coverage is out... any fix for this i tried uninstalling and rebooting 4g is gone :( help please. I probably have a similar issue as above i'll flash that rom and get back to you guys.
     
  8. petarded

    petarded Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Mar 5, 2011

    Mar 5, 2011
    4
    0
    5
    Threw on MikFroyo and 4g is back... thanks for your post JohnnyMack... Threw on the wired tether app and it just forces closed... cant get anymore than 1.6mbs on the wireless tether... and mikfroyo doesnt hack the hotspot... so I suppose i'll just have to stick to 3g tether until someone posts something else.

    Thanks for the write up =)
     
  9. snorlax2

    snorlax2 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 5, 2011

    Mar 5, 2011
    1
    0
    5
    Wireless tethering isn't working on 4G and I can't figure out why. I'm using Sprint EVI and rooted on 2.2 stock. WiFi is turned off. I've tried all channels and none work with 4G.

    It started happening about a week ago. I didn't install any new apps. Pretty sure I didn't update anything voluntarily either.

    3G works, 4G doesn't work with wireless tether.
    Google.com will load on laptop browser, I can search, but any external links won't load after clicking through.
    All other sites will time out on laptop browser.
    Phone, mobile browser, etc. works fine while 4G is turned on, not sure if it's 4G speeds though.

    I would appreciate any help. Thanks.
     
  10. syi

    syi Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    588
    Joined:
    Mar 5, 2011

    Mar 5, 2011
    588
    58
    98
    Male
    I dont do shit
    oregon
    weird problem with wifi tether, I can see the network, connect to it, and i cant load a single page, not even google.

    in my network and wifi setting wifi says error, and wireless tether had an error on startup that say failed to load wifi drivers
     
  11. gms81

    gms81 Lurker
    Rank:
    None
    Points:
    25
    Posts:
    3
    Joined:
    Jun 1, 2011

    Jun 1, 2011
    3
    0
    25
    Hi guys needs some advice,

    HTC EVO 4G, 3.70.651.1, rooted using unrevoked 3 (possibly 3.32)
    Stock ROM with titanium backup and wireless tether 2.0.7 downloaded from the google code site.

    It work beautifully with 4G and get excellent speeds on all connected devices, however when I leave it on 3G it does not seem to connect to the net.

    Should I try a different version? Which?
    Should I try a different app?

    On the road 4G may not be available but 3G is but then wifi tether does not seem to work

    all assistance is appreciated
    thanks
     
  12. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #6
    Points:
    3,033
    Posts:
    26,516
    Joined:
    May 13, 2010

    May 13, 2010
    26,516
    16,493
    3,033
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    have you tried the other releases of the wireless tether app? i would try 3.0 and see if that works for you.
     
  13. gms81

    gms81 Lurker
    Rank:
    None
    Points:
    25
    Posts:
    3
    Joined:
    Jun 1, 2011

    Jun 1, 2011
    3
    0
    25
    haven't done that so far (since it was experimental). will do so now and update this

    thanks
     
  14. tenraii

    tenraii Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Aug 14, 2011

    Aug 14, 2011
    1
    0
    5
    On a rooted Evo 4G ... I have the option to use either a wireless tether app or the hacked sprint hotspot. My question is ... Is a wireless tether faster or slower or even the same speed as the hacked hotspot. I'm assuming there is no difference, but would like to know before I put this aside.
     
  15. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #6
    Points:
    3,033
    Posts:
    26,516
    Joined:
    May 13, 2010

    May 13, 2010
    26,516
    16,493
    3,033
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    the wireless app can do 4g while the hacked hotspot cannot do 4g. other then that they should be about the same sppeds with 3g.
     
    tenraii likes this.
  16. 350zx6r

    350zx6r Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    111
    Joined:
    Apr 7, 2011

    Apr 7, 2011
    111
    3
    36
    so theres no proven numbers right? cause im kinda confused. i mean if you root your phone and you get sprint built in hotspot app why would you download another tether app, specially if you do not get 4g coverage?
     
  17. mdizzle99

    mdizzle99 Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    68
    Posts:
    418
    Joined:
    Jul 10, 2010

    Jul 10, 2010
    418
    108
    68
    Wow. I log onto the forum for the first time in months and see this thread still being brought back to life...probably means I should do some updating : /

    Anyway, if you do not have 4G coverage and you have the native hotspot feature unlocked, most people would not see a need to install a third-party app. However, as for the reason for this thread, individual results may vary. Some people have better luck with tethering in different ways. For instance, I have had ROM/kernel setups that do not function well with the native feature - especially for wired tethering. But if you have found something that works well for you, then I would just stick with that.
     
    dustwun77 and ocnbrze like this.
  18. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #6
    Points:
    3,033
    Posts:
    26,516
    Joined:
    May 13, 2010

    May 13, 2010
    26,516
    16,493
    3,033
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    mdizzle99 in da house!

    yep we have a fresh new group of flashaholics thanx to revolutionary who still need their tethering fix thanx to your guide.
     
  19. cfcheong

    cfcheong Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Sep 23, 2011

    Sep 23, 2011
    1
    0
    5
    I'm not rooted, and am on the internet at the moment using Pda/net with a usb cable. It actually seems to work as fast as my Clearwire modem. Haven't figured out how to link up wireless yet though, but glad this works without having to root.
     
  20. peeyurr

    peeyurr Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Oct 5, 2011

    Oct 5, 2011
    1
    0
    5
    I had the same problem. Still not sure what the solution is. I downloaded this.

    WiFi Tether for Root Users 3.1-beta6 *** BETA ***

    It only works on 4G but not 3G. I also downloaded the wired version and its the same thing.

    Any suggestions? Thanks for the help.
     
  21. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #6
    Points:
    3,033
    Posts:
    26,516
    Joined:
    May 13, 2010

    May 13, 2010
    26,516
    16,493
    3,033
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
  22. jwhitlock206

    jwhitlock206 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    34
    Joined:
    Aug 29, 2011

    Aug 29, 2011
    34
    1
    16
    Stay at Home Mother
    NM
    Please help me. I did the sprint wifi tether that gives you the mod thtat is warm twopointtwo. however warm 2.2 never loaded so i tried flashing a different mod and it totally wacked my phone sorry screens galore so i just wanted to get my phone back to the original rom and everything any ideas or anything my backups don't work either by the way thanks for any help
     
  23. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!
    Rank:
     #6
    Points:
    3,033
    Posts:
    26,516
    Joined:
    May 13, 2010

    May 13, 2010
    26,516
    16,493
    3,033
    Male
    being a flashaholic sponsor, helping others gettin
    los angeles
    what happens when you try to restore your nandorid backups? what did you wipe when flashing warm 2.2? what recovery do you have? what mods were you trying to flash?

    if you can give us more detail on what is going on we can help you.
     
  24. frenchy714

    frenchy714 Android Expert
    Rank:
    None
    Points:
    333
    Posts:
    3,153
    Joined:
    Nov 11, 2010

    Nov 11, 2010
    3,153
    1,957
    333
    Male
    East Tawas, MI
    Please give us more information so we can better help you.

    When you say "mod" do you mean "ROM"? Were you trying to flash the ROM Warm 2.2 and it never finished? Please answer these ?'s and the questions Ocn posted so we know exactly where you're at in all of this.
     
  25. EVU

    EVU Well-Known Member
    Rank:
    None
    Points:
    63
    Posts:
    216
    Joined:
    Oct 5, 2010

    Oct 5, 2010
    216
    47
    63
    I activated the ($30) Sprint Hotspot on my NON-rooted stock EVO this past weekend & my wife's iPad hooked on to it with no issues.

    However, my netbook couldn't keep the signal.
    My EVO was either plugged into the wall or plugged into the netbook for powering purposes.

    Neither, instances could the netbook keep the signal from the EVO.

    I also have the EasyTether wired solution & that worked fine with my netbook.
    Initially, I wanted to go wireless so my wife's ipad could get a signal.

    Any ideas why I wasn't able to keep a signal on the Sprint Hotspot with the netbook?
     
Tags:

Share This Page

Loading...