1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Guide]rooting and adding CWM Recovery to 2.3.5 with Corn Kernel

Discussion in 'Android Devices' started by geeve420, Feb 2, 2012.

  1. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    depending on the version of gapps, you might not have Google Play, you might have the older Market app. Use that to connect to the store and it should update to play momentarily.
     


  2. danishahmed

    danishahmed Lurker

    I need your help. I have Samsung galaxy s sgh-i897. last night I was rooted my cell by using odin3 and corn kernel.

    after that success full operation, I upgraded firm ware from gingerbread to jelly bean. that was also done smoothly. but after having reboot the device, there was no signals, I tried so many times by different ways to start the network but each time I got failed.

    now an hour ago, I connected my phone with my laptop and started odin and followed the step 1 (which I have mentioned on top) i thought that process will bring the ginger bread. now after that process my phone stucks on systems crops screen. nothing is happening. I search every thing every where but found nothing.

    Please help me to sort out this
     
  3. vrana116

    vrana116 Lurker

    I was so scared to root my android but it worked like a breeze.
     
  4. lifeistime

    lifeistime Lurker

    Hi there. i have attemped to do this but when i hold volume buttons down and plug it in it says firmware update, step 1/2, unpacking, update failed, and odin will not recognise it.Help?..
     
  5. canoeny

    canoeny Lurker

    Hi all. New to this forum. I tried the kernel install and root on my i897 as described, and it worked like a charm. Thanks for the clear instructions.
    I now have root and cwm, but this did not fix the original problem that brought me here: My phone only boots into download mode, unless it is plugged into either my computer or a wall charger. I have tried the following, to no avail:
    - factory wipe
    - cleaning various caches
    - 1 click unbricks and stock Rom installs
    - flashing 2.3.5 KK4 Rom (currently installed)
    - corn kernel and root per instructions in this post
    - cleaning out usb port with acetone and electronics cleaner

    Any ideas on how to push the power and have the phone boot normally?

    Thanks
     
  6. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    Are you saying that it boots normally when a USB cord is plugged in? Have you tried it with the cord plugged into the phone and not plugged into the PC? It sounds like you may have a short in the phone's USB port.

    Once you have your phone booted while plugged in, what happens when you unplug it?

    You could try taking a small brush with some denatured alcohol and cleaning it out, then blowing it out with compressed air in case it's just dirty.
     
  7. canoeny

    canoeny Lurker

    Hi. thanks for getting back to me.

    Yes, if I power the phone down and plug in a cable (either to computer or wall charger) the battery charging icon appears on the screen. From there, I hold down the power button, and it boots normally. If I plug in a cable not attached to the computer, it goes to download mode.
    Once the phone boots, it acts completely normally; USB cable can be plugged in or unplugged without issue.
    A couple other notes -
    - Once in download mode, I can only get it out of it by pulling the battery.
    - With the phone powered down and not plugged into anything, I cannot get into recovery mode via any button combination.
     
  8. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    That sounds like a short or failure of one of the buttons. I don't know of any software that can fix that.
     
  9. canoeny

    canoeny Lurker

    The only thing I have (intentionally) not tried anything with is bootloaders. If the bootloader was corrupt, would it make the phone behave this way, or would it be totally bricked?
     
  10. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    It seems to me that if it boots normally (or semi-normally) when plugged into a power source, but only gives you d/l mode otherwise, and that the you can boot into recovery when plugged in but not unplugged it is a problem with either the button or the USB connector. I don't think the bootloader is the issue. It probably won't brick you, but I doubt it will fix it either.
     
  11. acw89

    acw89 Lurker

    Was originally afraid to attempt rooting.. you made it very easy.
    But people DO need to read and Pay Attention.
    Thanks for all the work it must have taken to do this.

    Catmom
     
  12. Rarewolf

    Rarewolf Android Expert

    this causes my phone to reboot once i open apps or load a long page.

    restocked the kernel and everything is fine again.
    would like to know how to get one click root to work too.
     
  13. g206

    g206 Lurker

    Have tried rooting, but whenever I put the phone into download mode, the computer does not recognize the phone, have tried method 2 and 3 and the computer recognizes the phone any other time.
     
  14. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    You do have USB debugging enabled?
     

Samsung Captivate Forum

The Samsung Captivate release date was July 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...