1. Download our Official Android App: Forums for Android!

Root How to Root Your Droid (For Non-Linux/Non-Geeks)

Discussion in 'Android Devices' started by Jarek, Dec 9, 2009.

  1. Jarek

    Jarek Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    7
    Joined:
    Dec 4, 2009

    Dec 4, 2009
    7
    1
    6
    Here's a guide written for non-linux users on how to root your droid. What you do beyond that, well, I have another thread set up for that. Let's get going!

    You will need the following:
    http://www.4shared.com/file/168496608/8fa27888/droid-root.html
    OR
    http://www.mediafire.com/?ydaqjmditjh
    OR
    http://www.multiupload.com/XYPZLK4K22
    (Those 3 are the same file, just use either link, and choose another if any is dwn)
    AND
    http://developer.android.com/sdk/download.html?v=android-sdk_r04-windows.zip
    AND
    http://www.magicandroidapps.com/su.zip
    AND
    http://www.smilepak.com/temp/Droid_USB_Driver.zip


    Once you have all these files downloaded, extract them all into a new folder at C:\Android

    You should now connect your Droid to your computer and Mount the SD Card through the phone (A dialogue will pop up on your phone asking to connect your SD Card. Click Mount)

    Courtesy of Fadelight:
    (go to Device Manager. There you will see your droid (A855) with a yellow "!" next to it. Right click. Select "Update driver" and point it to the android folder. That is where the drivers are.)


    Go to the C:\Android folder you created. Rename the file droid-root.zip to update.zip. Then take update.zip and move it to the SD Card on your phone.

    Once this is done, unplug your phone and turn it off by holding the top button, then selecting Power Off.

    Open your phone's keyboard. Hold down the letter X key on the keyboard and power your phone on WHILE HOLDING THIS KEY DOWN. You will see the Motorola logo, followed by a graphic with an ! mark on it. At this time let go of the X key and the power button. Press and hold the Volume + key on the side of your phone, then press the camera button while holding the Volume + key.

    Now you will be presented with a menu. Navigate to "update" using the D-pad, and click the middle button. Now wait for the process to finish.

    When it is complete, your phone will power up again. Go to Settings->Applications->Development and check the USB Debugging checkbox.

    Connect your Droid to the Computer again.

    Click Start on your computer, and click run. Type cmd in the box, and hit ok. Now type the following, pressing Enter after each line:

    cd c:\Android\tools

    adb push su /data/local

    adb shell

    su

    mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system

    cd /system/bin

    mv su osu

    cat /data/local/su > su

    chmod 6755 su

    ls -l *su
    (you should see the following)
    -rwsr-sr-x root root 76200 2008-08-01 05:00 osu
    -rwsr-sr-x root root 76200 2009-05-30 11:28 su
    (now continue typing these following lines to finish)

    sync

    reboot

    You're done!
     

    Advertisement

    MUHAMMADJINDAN likes this.
  2. BottledHate

    BottledHate Android Enthusiast
    Rank:
    None
    Points:
    58
    Posts:
    463
    Joined:
    Nov 28, 2009

    Nov 28, 2009
    463
    11
    58
    Electronics/Electrician
    WA
    thank you!!!!

    +1
     
    MUHAMMADJINDAN likes this.
  3. Fabolous

    Fabolous Superuser
    Rank:
    None
    Points:
    313
    Posts:
    3,635
    Joined:
    Nov 7, 2009

    Nov 7, 2009
    3,635
    2,126
    313
    Multi-platinum Rapper
    Illinois
    This is the result of a successful root:

    [​IMG]
     
    MUHAMMADJINDAN likes this.
  4. Matthew

    Matthew Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    183
    Joined:
    Nov 4, 2009

    Nov 4, 2009
    183
    8
    56
    Michigan
    This thread should be a sticky. Thanks, good write up.
     
  5. Breakmyfootoff

    Rank:
    None
    Points:
    36
    Posts:
    35
    Joined:
    Nov 6, 2009

    Nov 6, 2009
    35
    1
    36
    Awesome! Rep added!!!!!
     
    MUHAMMADJINDAN likes this.
  6. blackngray70

    blackngray70 Lurker
    Rank:
    None
    Points:
    26
    Posts:
    8
    Joined:
    Nov 3, 2009

    Nov 3, 2009
    8
    1
    26
    Crane Operator
    Georgia
    When I get to this step it tells me Operation not permitted.

    mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system

    I have no idea what I'm doing wrong.
     
    MUHAMMADJINDAN likes this.
  7. Droid212

    Droid212 Member
    Rank:
    None
    Points:
    16
    Posts:
    38
    Joined:
    Nov 27, 2009

    Nov 27, 2009
    38
    1
    16
    How would you do this on a Mac?
     
    MUHAMMADJINDAN likes this.
  8. MysteryloverAnne

    MysteryloverAnne Well-Known Member
    Rank:
    None
    Points:
    35
    Posts:
    75
    Joined:
    Nov 7, 2009

    Nov 7, 2009
    75
    0
    35
    Minnesota
    Can a truly non-geeky person ask why I would want to root my Droid without getting flamed. [​IMG]
     
  9. Fadelight

    Fadelight Android Expert
    Rank:
    None
    Points:
    148
    Posts:
    1,395
    Joined:
    Oct 29, 2009

    Oct 29, 2009
    1,395
    95
    148
    Security
    Mulberry, FL
    If you are asking, then you probably wouldn't want to.

    When you find things that bug the crap out of you and you can't change them... then you will know why you might want to root.

    ;)
     
    MUHAMMADJINDAN likes this.
  10. gotwillk

    gotwillk Android Enthusiast
    Rank:
    None
    Points:
    38
    Posts:
    365
    Joined:
    Nov 7, 2009

    Nov 7, 2009
    365
    12
    38
    haha I was gonna ask the same thing. I'm semi geeky but why would I wanna root my phone for? id rather leave this up to the experts and their custom roms than mess around with it on my own. unless there are some stuff that even non geeks can do after rooting the phone.
     
  11. Fadelight

    Fadelight Android Expert
    Rank:
    None
    Points:
    148
    Posts:
    1,395
    Joined:
    Oct 29, 2009

    Oct 29, 2009
    1,395
    95
    148
    Security
    Mulberry, FL

    Well, I am a linux-illiterate geek. Does that count?


    I rooted my phone for a couple of reasons. The first is to delete the default apps that I don't want or use, such as amazon MP3 and Facebook.

    The rest I can't remember because I've been up for about 22 hours now... the last 6 trying to remember everything I once knew and have since lost about basic linux commands. My brain is bluescreening.
     
    MUHAMMADJINDAN likes this.
  12. mickeyx323

    mickeyx323 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    19
    1
    16
    Im trying to root this, but when i type adb shell it gives error: device not connected. The phone is connected into the usb. And is the su file suppose to be in c:\android\tools file or just android?
     
  13. rzawora

    rzawora Newbie
    Rank:
    None
    Points:
    36
    Posts:
    14
    Joined:
    Nov 13, 2009

    Nov 13, 2009
    14
    2
    36
    Management
    Lewes, Delaware USA
    I'm stuck at the same point. I'm using a force updated to 2.01 Droid and a Windows 7 64-bit PC. Any ideas? USB Debugging is on...tried restarting both.
     
    MUHAMMADJINDAN likes this.
  14. Fadelight

    Fadelight Android Expert
    Rank:
    None
    Points:
    148
    Posts:
    1,395
    Joined:
    Oct 29, 2009

    Oct 29, 2009
    1,395
    95
    148
    Security
    Mulberry, FL

    android\tools

    And make sure you installed the USB drivers for the phone.

    go to Device Manager. There you will see your droid (A855) with a yellow "!" next to it. Right click. Select "Update driver" and point it to the android SDK folder. That is where the drivers are.

    After that, it should be smooth sailing with the connection.


    OP - perhaps you should edit the instructions to include installing the drivers?
     
  15. rzawora

    rzawora Newbie
    Rank:
    None
    Points:
    36
    Posts:
    14
    Joined:
    Nov 13, 2009

    Nov 13, 2009
    14
    2
    36
    Management
    Lewes, Delaware USA
    Fadelight
    Thank you for your help. I was just looking at that as you posted. Just a couple notes. The link to the SDK from Google in the OP isn't correct. I copied and pasted the URL and it directs you to a d/l of an SDK which I downloaded and extracted, but the USB drivers aren't included there. I did a quick search and found a link here http://www.smilepak.com/temp/Droid_USB_Driver.zip
    No problems after this...it was smooth as you stated.
    Let the games begin...
     
    MUHAMMADJINDAN likes this.
  16. Fadelight

    Fadelight Android Expert
    Rank:
    None
    Points:
    148
    Posts:
    1,395
    Joined:
    Oct 29, 2009

    Oct 29, 2009
    1,395
    95
    148
    Security
    Mulberry, FL

    Are you using XP? I am using W7 64bit, and the drivers were included in the SDK - 2.0.1
     
  17. mickeyx323

    mickeyx323 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    19
    1
    16
    Thanks for the help fadelight and rzawora, everything worked just fine after the drivers.
     
    MUHAMMADJINDAN likes this.
  18. mickeyx323

    mickeyx323 Newbie
    Rank:
    None
    Points:
    16
    Posts:
    19
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    19
    1
    16
    I get
    -rwsr-xr-x root root 72188 2009-12-09 11:54 osu
    -rwsr-sr-x root root 0 2009-12-09 12:00 su

    Are the two things in red suppose to be that way or is the xr suppose to be sr and is the 0 suppose to have a value or is that normal?

    Edit: Got it working. When you extract the su file extract it into C:Android\tools. NOT C:\Android
     
  19. Howie

    Howie Android Expert
    Rank:
    None
    Points:
    148
    Posts:
    1,412
    Joined:
    Oct 28, 2009

    Oct 28, 2009
    1,412
    71
    148
    IT
    Central NY
    Looking at the first post I would assume it should be sr and have a value. I haven't tried it though.
     
  20. gcroberson

    gcroberson Well-Known Member
    Rank:
    None
    Points:
    15
    Posts:
    85
    Joined:
    Nov 14, 2009

    Nov 14, 2009
    85
    0
    15
    When I enter "adb push su /data/local" i am getting "cannot stat 'su': no such file or directory. I have the su in the folder c:/android. The icon for su is a white paper "its not compatible/i need a program to open it". Can someone please help. I am pretty comfortable with linux which is why I thought this would be a walk in the park.

    Forget all that upthere ^^^^^ i got to the end but I am not getting those numbers. I am getting:

    -rwsr-xr-x root root 72188 2009-12-09 11:58 osu
    -rwsr-sr-x root root 76232 2009-12-09 12:38 su
     
  21. link1305

    link1305 Member
    Rank:
    None
    Points:
    16
    Posts:
    41
    Joined:
    Nov 9, 2009

    Nov 9, 2009
    41
    3
    16
    Software Developer
    The column with '0' is the file size, and having 0 there means su is an empty file....so in other words something went wrong. Try copying it again.
     
  22. gcroberson

    gcroberson Well-Known Member
    Rank:
    None
    Points:
    15
    Posts:
    85
    Joined:
    Nov 14, 2009

    Nov 14, 2009
    85
    0
    15
    I went ahead and finished even with the numbers above. How can I tell if it was successful?
     
  23. dbarrett480

    dbarrett480 Member
    Rank:
    None
    Points:
    16
    Posts:
    60
    Joined:
    Nov 3, 2009

    Nov 3, 2009
    60
    1
    16
    download "android terminal emulator" from the market and then type "su" you should get a message "su: access granted, courtesy of www.magicandroidapps.com" and then a # sign that means you have root access. You can type "reboot" and it will reboot your phone, you can't do that without root access.
     
  24. gcroberson

    gcroberson Well-Known Member
    Rank:
    None
    Points:
    15
    Posts:
    85
    Joined:
    Nov 14, 2009

    Nov 14, 2009
    85
    0
    15

    Thank you for the response. I'm rooted and ready to go!
     
  25. mooshu47

    mooshu47 Newbie
    Rank:
    None
    Points:
    15
    Posts:
    28
    Joined:
    Nov 7, 2009

    Nov 7, 2009
    28
    0
    15
    I think it's been said already but the link in the original post to the android SDK is wrong, it actually points to the su tool instead. The text of the link is correct but the underlying URL is not. Android SDK is at:

    Download the Android SDK | Android Developers
     

Share This Page

Loading...