Dec 8, 2010
I just purchased a Samsung Galaxy S22. It runs Android 12 and One UI 4.1.

What I am trying to do is use a custom notification sound for my text messages (Google Messages). I want a custom sound for one specific person and another for everyone else. I had this previously on my Galaxy S8.

Unfortunately this does not work for me. I have added the sounds I wish to use to my phone's storage. This includes custom ringtones. Those do work as I am able to select them when choosing a ringtone. I can see them in my list of available ringtones. But the sounds I have added for notifications do not appear in the list of available notification sounds so I am unable to select them.

I have tried placing them in the following locations:
  • /root/sdcard/Notifications
  • /root/sdcard/Ringtones
  • /root/sdcard/Android/media
  • /root/sdcard/Android/media/Notifications
It's this still possible to do? If so, what am I missing?
You say you are using Google Messages as your message app. I just enabled that on my s21 and tried to set a custom notification for one contact and it could see the custom tones I keep in the Notifications folder in my internal storage. Different phone, but One UI 4.1 on the May security patch, so I doubt there is a difference in the system sound picker's behaviour.

Of course if you have a file browser that offers to handle that job instead of the system picker you could see whether that works better (on my phone Solid Explorer can also handle this particular intent).
I also went from s8 to s22 try this;

This works as long as you have a message from the person you want to customize

1. Launch the Google Messages app and choose a conversation.

2. Tap on the three vertical dots menu at the top right of the screen and choose the Details option.

3. Tap on Notification, select ringtone in sound box.

4. You can add custom notification sounds to audio files / notifications and they will show in the sound selection box.
  • Like
Reactions: ocnbrze
Turns out what I was missing is that the format of the file *must* be MP3. Mine were .wav files which worked on the older OS but not in the newer OS.