1. Are you ready for the Galaxy S20? Here is everything we know so far!

I have a galaxy S4, with android 4.3 it doesn't connect to kies or recognizable by mac or windows?

Discussion in 'Android Help' started by Android Question, Dec 3, 2013.

  1. Android Question

    Thread Starter

    So just as the title says I am having trouble with my S4 being detected by my mac and a windows 7 laptop. The phone beeps when connected to both but I can't view files or transfer/backup anything. I am also using the original data cable, which charges the phone fine when plugged into the wall or the computers. In the notification area of the phone, it is SUPPOSE to say "connected as USB media device, or have a list of assorted things to use the phone as. Mine DOES NOT have this notification showing when connected. I have tried to restart both phone/computer, reinstall kies and the driver, take the battery out of the phone with NO HELP. I also can't restore factory settings because this phone has been flashed to a different carrier other then verizon, and can't lose its internal settings. What am I to do? Also if anyone knows how to root android 4.3 for the samsung s4 let me know if possible. Be as detailed as possible as I have never done this. Rooting will not erase my flash settings either, so don't worry about this. That was my primary reason for connecting it to the computer. PLEASE HELP! I have even contacted samsung, with no help. Searched the DAYS on this issue. I love this phone, but sucks its so hard to get it to connect. I know flashing it didn't cause the problems, it does nothing to OS, it only changes the PRL version, MIN and phone # that sends to the towers to connect. Also, I have tried with USB debugging and developer tools both on and off, it makes no difference.

    Thanks for all of your help with this.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Rukbat

    Rukbat Extreme Android User

    There's a Windows program called USBDeview. See if the computer is actually seeing the phone, or if it's just seeing a generic "USB insertion". (You DID install the drivers, right?)
     
  3. Sipendra

    Sipendra Lurker

    Try your Luck using these steps once:
    1. Go to Settings
    Steps_1.png
    2. Tap on Storage

    3. Tap on More (three dots on top right corner)
    Step_2.jpg
    4. Select option "USB Computer Connection"
    Step_3.png
    5. Select Option "Media device"
     
Loading...

Share This Page

Loading...