1. Are you ready for the Galaxy S20? Here is everything we know so far!

ICS performance on Samsung Galaxy S

Discussion in 'Android Devices' started by Amphibian59, Jul 5, 2013.

  1. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    First, my phone information:

    Android version: 4.0.3
    Baseband: I9000XXJVU
    Kernel: 3.0.8-NEO-3.0-TeamICSSGS-257174-g197c9a1-dirty
    Build number: GT -I9000-user 4.0.3 IML 74K eng. onecosmic-20120204.223407 test-keys

    Rooting the phone went OK, and so did installation of ICS. All the built-in apps worked fine. I then installed my preferred apps including Chrome, but I found that over a few weeks the phone got much slower. Chrome in particular was impossibly slow, and the stock browser was far better. Navigation became useless as the app was too slow to detect satellites. Apps commonly halted and had to be closed, especially the camera. I have now deleted Chrome and other less useful apps, and the phone is a bit better, especially navigation. But now I am unable to install any new apps! The progress bar on the Play app just keeps scrolling and never completes. The same happens if I try to install anything via USB from the Play website.

    From what I have read, the i9000 should run ICS and even Jelly Bean with acceptable speed. I don't think I can clean up the phone any more, so there must be something else wrong. Any ideas? I've done all the usual things - hard reboot etc.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. chanchan05

    chanchan05 The Doctor

    Probably the ROM you used. Get a better ROM from xda. RemICS is nice, and its Jellybean already. I got that running on my i9003.
     
    funkylogik likes this.
  3. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    Thought that might be the case. On reflection, I am wondering about changing the method completely and installing CyanogenMod. That doesn't require a rooted phone apparently. Does that make sens?
     
  4. LilBit

    LilBit Extreme Android User

    Hi Amphibian59, I moved your thread here, let's see what the people with this device can do for you also.:)
     
    Amphibian59 likes this.
  5. chanchan05

    chanchan05 The Doctor

    You can't change ROMs on an unrooted phone. Just go to xda forums and read in the section for your specific device. ROM threads there have very specific instructions and downloas links for everything you'd need.
     
    Amphibian59 likes this.
  6. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    Thanks. I was proposing to do factory reset and thus unroot the phone, before trying again with another ROM. I have been to XDA but obviously have not read enough yet. I was concerned that the i9000 was simply not fast enough but it probably is, I just don't have the best firmware.
     
  7. chanchan05

    chanchan05 The Doctor

    The I9000 has the same hardware as a Nexus S, and that one runs Jellybean like a champ.
     
  8. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    So far I am encouraged to learn that the i9000 should run JB well. I have done a lot of reading and most of it confuses me, so perhaps someone could direct me to the best places to help with what I want to do.

    To recap, I rooted the phone using CF Root. I then installed ICS (ICS_4.0.3_MR1-RC4.2_I9000), having backed up as instructed. But I am not totally happy with a rooted phone, as my banking and security apps won't run. I really wanted to unroot the phone, retaining ICS, but that does not appear to be possible.

    So what I want to do now is to install a better ROM, ideally Jelly Bean. My questions are:

    1. Should I hard reset the phone, and get back to Gingerbread before trying anything else?
    2. Would I be better off installing CyanogenMod 10.1, the JB clone? The instructions I have seen for that only work from GB.
    3. What is the best way to upgrade the firmware and keep the phone unrooted?

    The fact remains that my ICS installation is not working correctly so I have to replace it anyway. Please just point me in the right direction!
     
  9. chanchan05

    chanchan05 The Doctor

    The Galaxy S cannot be upgraded beyond Gingerbread without rooting because Samsung never released an update for it with a higher version. So it's your choice, stick to Gingerbread with your bank apps, or move to Jellybean but lose those.
     
    Amphibian59 likes this.
  10. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    Well on balance the upgrade is probably worth losing the bank's app! I think I'll press on with it. Now, which direction to take?
     
  11. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    OK, I have followed the process to install RemICS that I found here. It has halted at the first stage. The boot halts at the orange Android screen which says `powered by Mackay Kernel. There was previously a message saying that the ROM was incompatible, although at XDA it vis specific for the Galaxy S i9000. The phone won't respond at all at this stage, and I can't get back into recovery. Any suggestions?
     
  12. chanchan05

    chanchan05 The Doctor

    Go to download mode and flash stock firmware.
     
  13. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    Actually I did get it to boot into recovery, just once, but it won't do it again. It booted into Mackay recovery not CWM which I installed before.

    It won't boot into download mode either. It stills goes to the orange Android logo and the Mackay Kernel message, but no further.
     
  14. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    Presumably everyone is on holiday! But just in case anyone is reading, there is further news. The reason I could not start recovery mode was that the button sequence was different from what I had been told. It now boots reliably into Mackay (which of course is TWRP). I have found that the phone is unable to mount the partitions DATA and SYSTEM - they seem to be corrupted. Hence it has not wiped DATA, although TWRP wrongly reports success. I have tried updating the partitions to ext3 or ext4 but this fails every time. I could format the thing from Windows but that will wipe everything including recovery of course. I need a tool to repair these partitions. This may well have been the reason the phone was getting creaky in the first place.

    I have copied a new ROM to the external SD card, using a card reader, and inserted this into the phone. Strangely the TWRP file manager reports that EXTERNAL SD is a sub-folder of SD CARD, and that is empty. The file manager does not show the real external SD card. But the real external SD shows up on the Windows USB connection. What is going on?

    Edited to add: When I try to mount the partitions, DATA and SYSTEM can't be checked - the other partitions (Cache, sdcard, and emmc are all checked.
     
  15. Amphibian59

    Amphibian59 Newbie
    Thread Starter

    Well for the benefit of anyone else with the same problem, I have managed to re-flash the ROM back to stock. It just took 3 days of intensive web browsing until I understood how to do it, and found software that worked - a lot of stuff out there has errors. Here is the method I used.

    To summarise, the problem was:

    1. Data and System partitions became damaged, so phone became unstable.
    2. Attempt to upgrade ROM failed because of damaged partitions.
    3. Could not boot phone into recovery or download because button combination was different from what I was told.

    The solution was:

    4. Boot into download mode using correct button combination.
    5. Re-flash back to stock ROM and re-partition using Odin.

    Yes, someone did tell me that, and I would have done that straight away if I could have gotten into download mode. We live and learn
     

Samsung Galaxy S Forum

Features and specs are not yet known.

unknown
Release Date
0
Reviews
Loading...

Share This Page

Loading...