1. Download our Official Android App: Forums for Android!

Support "Messaging is not your default"

Discussion in 'Android Devices' started by snidely, Apr 18, 2016.

  1. snidely

    snidely Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Jun 17, 2015

    Jun 17, 2015
    4
    0
    15
    Male
    cat herder
    A little house down by the depot
    The only way I can send a picture is using the default Messaging app. Any other gives me "Cannot compose message. Messaging is not your default message app."

    I've been googling around for a long time and not found anything like this.

    LG G4, Android 6.0

    Any help would be most welcome.
    Steve
     

    Advertisement

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    32,120
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,120
    24,096
    3,118
    Scotland
    What other messaging apps have you tried?

    Textra sends MMS no problem for me.
     
  3. shadavis08

    shadavis08 Newbie
    Rank:
    None
    Points:
    18
    Posts:
    27
    Joined:
    Aug 5, 2015

    Aug 5, 2015
    27
    12
    18
    You probably need to go in and erase defaults on another messaging app
     
  4. Clementine_3

    Clementine_3 Android Expert
    VIP Member
    Rank:
     #27
    Points:
    1,043
    Posts:
    5,688
    Joined:
    Nov 16, 2009

    Also clear cache and force stop any you have installed and are not using. It's just confused :)
     
  5. snidely

    snidely Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Jun 17, 2015

    Jun 17, 2015
    4
    0
    15
    Male
    cat herder
    A little house down by the depot
    I've tried ChompSMS, Textra, and one other I don't remember. I'm on T-Mobile, if that matters.

    I can send pictures using the built-in Messaging, but none of the others. I made each the default app when I tried it, and I don't understand "You probably need to go in and erase defaults on another messaging app"
     
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    32,120
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,120
    24,096
    3,118
    Scotland
    Did you check the APN settings when using textra?

    There's also a setting specifically for T-Mobile users. Try again, entering TMO APN Settings and using the wifi calling fix.
     

    Attached Files:

  7. snidely

    snidely Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Jun 17, 2015

    Jun 17, 2015
    4
    0
    15
    Male
    cat herder
    A little house down by the depot
    I've tried all suggestions, but no change. When I "Force Stop" Stock Messaging, it won't stay stopped. When I try to send a picture, it always opens the Stock, even though both it and Textra are stopped and Chomp is set as default.
     
  8. snidely

    snidely Lurker
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    4
    Joined:
    Jun 17, 2015

    Jun 17, 2015
    4
    0
    15
    Male
    cat herder
    A little house down by the depot
    I checked those at the beginning of this little adventure. I'm beginning to think I'll just use the world's ugliest messaging app and just avert my eyes as much as possible.
     
  9. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #5
    Points:
    3,118
    Posts:
    32,120
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,120
    24,096
    3,118
    Scotland
    Not sure what else to suggest then, sorry.

    You are right, the stock messaging app is hideous..
     

LG G4

The LG G4 was launched in 2015. It has a 5.5-inch IPS display and a 16MP camera with Laser Auto Focus and Color Spectrum Sensor. It has a 3,000 mAh removable battery and expandable storage. The G4 can be customized with 6 different leather back covers, and 3 different traditional back covers.
Tags:

Share This Page

Loading...