1. Download our Official Android App: Forums for Android!

Support proximity sensor not working for 2.1

Discussion in 'Android Devices' started by joemonkey, Nov 10, 2010.

  1. joemonkey

    joemonkey Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    385
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    385
    12
    38
    Seattle, WA
    before i updated to 2.1, The proximity sensor turns the touch screen off when your face touches the screen. after the updated, it does not seem to work anymore.

    anyone has the same experience??
     

    Advertisement

  2. f891roy

    f891roy Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    85
    Joined:
    Sep 7, 2010

    Sep 7, 2010
    85
    5
    16
    FITNESS CONSULTANT
    Belfast
    only if you have adw installed.
    adw settings > system preferances > UNTICK SYSTEM PERSISTENT:D
     
  3. joemonkey

    joemonkey Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    385
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    385
    12
    38
    Seattle, WA
    is this the case for both 1.6 and 2.1? or just for 2.1? i think i installed ADW in 1.6 but not for 2.1.

    funny in the x10 user manual, it talks about how the sensor works but why would it require ADW for it to work?
     
  4. f891roy

    f891roy Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    85
    Joined:
    Sep 7, 2010

    Sep 7, 2010
    85
    5
    16
    FITNESS CONSULTANT
    Belfast
    then try
    SETTINGS>SOUND&DISPLAY>ORIENTATION
     
    joemonkey likes this.
  5. joemonkey

    joemonkey Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    385
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    385
    12
    38
    Seattle, WA
    @f891roy... thanks for the suggestion...

    well, this seems to work even though i can't say why selecting orientation did the trick.

    however, i also discover something interesting in the process. it does not work when you embale speaker phone. how strange is that?

    anyone care to address...
    1. why Orientation has anything to do with the sensor
    2. why turning on the speaker phone causes the sensor NOT to work
    ** my guess would be when you turn on the speaker phone, they expect you not to put your ear next to the phone. but then again due to the volume issue with the X10, especially outdoor, it helps to put on speaker and put your ear next to the phone.
     
  6. BingoRingo

    BingoRingo Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    399
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    399
    54
    53
    Aylmer, Quebec
    For your information, if you want to see if it's a hardware problem, at the lock screen instead of swiping push: menu > back > back > menu > back > menu > menu > back

    then select "Service Tests" then Proximity Switch.

    EDIT: Use "Home" instead of "Menu"!
     
  7. joemonkey

    joemonkey Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    385
    Joined:
    Jun 27, 2010

    Jun 27, 2010
    385
    12
    38
    Seattle, WA
    by the way, is the HOME button instead of the MENU button.
    home > back > back > home > back > home > home > back
     
  8. BingoRingo

    BingoRingo Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    399
    Joined:
    Aug 9, 2010

    Aug 9, 2010
    399
    54
    53
    Aylmer, Quebec
    Yes you're right, that's what I meant, the one in the middle!

    The old code is good on 1.6 though.
     
  9. amitkumarajain

    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jun 9, 2010

    Jun 9, 2010
    5
    0
    5
    Me also facing same issue on android 2.1 xperia x10 mini. i also dont find the option for proximity sensor which i thot was present in 1.6
     
  10. amitkumarajain

    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    Jun 9, 2010

    Jun 9, 2010
    5
    0
    5
    Me too with same issue when i upgrade to android 2.1 on my xperia mini
     
  11. benzmar

    benzmar Member
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    May 1, 2010

    May 1, 2010
    47
    1
    16
    I went to services test, and found that my Proximity Sensor is OFF.
    How do I ON it?
     
  12. benzmar

    benzmar Member
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    May 1, 2010

    May 1, 2010
    47
    1
    16
    Found it.

    In the Service Test mode, when you see the Proximity is OFF, close the sensor with your finger, and its turns ON. That's it [​IMG]
     
  13. benzmar

    benzmar Member
    Rank:
    None
    Points:
    16
    Posts:
    47
    Joined:
    May 1, 2010

    May 1, 2010
    47
    1
    16
    Hi, I get a text stating "No SIM Card on Phone". Though I have the SIM inserted and works fine, after I unlock. This text comes frequently. What's the problem and how do I fix it? The SIM is new and works perfectly.

    This happened after I updated my XPERIA x10i to 2.1.

    Any fix for this?
     
  14. luke318is

    luke318is Well-Known Member
    Rank:
    None
    Points:
    56
    Posts:
    147
    Joined:
    Jun 6, 2010

    Jun 6, 2010
    147
    3
    56
    I had a ton of problems with the prox sensor in 1. 6. i discovered it was caused by walking into changing light while talking on the phone. if i walk out into a sunny day, my face would hit the end button, happened so much while talking to my boss and pissed him off.

    i hope this is fixed now.
     
  15. buck56

    buck56 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Mar 26, 2011

    Mar 26, 2011
    4
    0
    5
    I have 2 xperias in my family, both of them show proximity sensor as being 'off', so does this mean the sensor is on, but when you go into this screen its giving you the option to turn it off? Eiether way, I am unable to change the setting, pushing the screen does not alter the reading on either phone, so how do you actually change the visible setting from 'off' to 'on'?
    thks
    b56
     

Share This Page

Loading...