1. Are you ready for the Galaxy S20? Here is everything we know so far!

Text messages "Pending" and not being sent

Discussion in 'Android Devices' started by NickRo, Dec 9, 2009.

  1. NickRo

    NickRo Newbie
    Thread Starter

    Hello all,

    I have recently been having issues with text messaging. About half of the texts that I try to send end up in a "pending" state. If you go to the factory messaging, and long press on a message, there is an option to "View Report" and that is where it has the pending status. I can't seem to figure out a rhyme or reason to this, but they don't actually get sent to the people I'm trying to send them to. Does anyone have any ideas? I've been fine with the stock messaging program, but would Handcent fix this? I'm up for trying anything at this point, as long as I can text and be sure the people are going to get them.

    Thanks for any help. BTW I was hoping the 2.0.1 update would fix this, but I force loaded the update and it's still doing it.

    skippypb673 likes this.

    1. Download the Forums for Android™ app!


  2. BucYouUp68

    BucYouUp68 Android Enthusiast

    It seems the people that forced the update are having a variety of issues with the update. i cant confirm as i have not done it, and have not had any issues thus far. I am still waiting for the OTA to hit my phone.
  3. NickRo

    NickRo Newbie
    Thread Starter

    It's not a problem with the forced update. Maybe I was unclear with that part, if so, my bad. I've been having this problem for a little while now. It didn't happen that I can remember when I first got the phone about a week after it was out, but recently this whole pending thing started (before I force updated). I was hoping that the update would fix it, so I was waiting until then to complain. With the force update being available now, I did that, but it's still happening. BTW, I'm not having any problems with the force update, this pending issue, as I said, is an ongoing thing from before the update.
  4. MajesticFlame

    MajesticFlame Member

    Before the update I needed to have the country code for MMS messages 1-XXX-XXX-XXX to go through but after the update I had to take the 1 off to get them to go through. Doesn't seem to matter for regular texts.
  5. Gunner

    Gunner Android Enthusiast

    I have occasionally had this happen to me also. No rhyme or reason to it. I'm still on 2.0 and using the stock SMS app. I hit the little letter icon and it usually resends ok.
  6. krichek

    krichek Android Enthusiast

    My wife had this same problem on her Eris in addition to a number of other wonky things going on like, a seriously bad echo, sending blank texts to random people everytime she successfully sent a text etc... I finally called tech support and I'm not sure which one of these was the cure but hers is now fixed. I did a hard reset and the tech removed her phone from the system entirely and then re-added it.
  7. NickRo

    NickRo Newbie
    Thread Starter

    If you've had this happen before, what messaging program are you using? The stock app? Handcent? Just curious because I just installed handcent, and for the first few messages, it appears to be working better. I will update as I continue to use it though. Might just be a bug in the stock messaging program?

    Thanks for the input guys.
  8. johninbigd

    johninbigd Android Enthusiast

    I've had this problem a couple of times on the Droid. I haven't figured out how to re-send a txt that is stuck. On my old iPhone there was an option to re-send a txt, but this phone doesn't seem to have that option. I'm using Handcent, btw.
  9. jestexman

    jestexman Android Enthusiast

    I had this happen on my Droid (stock and Handcent) my wifes dumb phone and buddy's BB.

    I called Tech support and they took down all 3 phone numbers and the next day everything started to work. This was only with MMS not regular txt.

    I know this is not much help but after the phone call (next day) everything is great.
  10. NickRo

    NickRo Newbie
    Thread Starter

    Yeah, I haven't been able to figure out how to resend a text either. It may have been said already too, but it doesn't tell you when it doesn't go through either. Frustrating for sure! Hopefully someone somewhere has an idea or a fix in the works!
  11. krichek

    krichek Android Enthusiast

    Long press the message that is pending or shows that it failed to send and you'll have the option in the pop-up menu to resend.

    This option is not present once the message has been confirmed sent.
  12. krichek

    krichek Android Enthusiast

    Do you not have the little envelopes beside your texts that indicate when a message has been received?
  13. johninbigd

    johninbigd Android Enthusiast

    Interesting. I haven't seen that option when I've had failed messages before. I wonder if the Droid is automatically trying again and succeeding, but just not clearing the "failed" message.
  14. johninbigd

    johninbigd Android Enthusiast

    I don't. I use Handcent and I don't think it has those.
  15. krichek

    krichek Android Enthusiast

    Oh, sorry. I use the stock messaging app, I'm not sure if either of my previous statements would be the same when using Handcent.
  16. NickRo

    NickRo Newbie
    Thread Starter

    I did when I was using the stock messaging app. It was always the same though, no matter if it went through or not. It had the envelope with a little i in a bubble. That's what it looked like if I remember correctly anyways. The problem was that it never told me if it didn't/couldn't send the message. I only found out when I talked to the person later and they said, "Oh, no, I never received that text!" Then I would look and it always said "pending" in that status report.

    I'm using Handcent now, (just started yesterday) and the little bit that I did yesterday, it worked beautifully. I'll keep trying this and hopefully it stays working well.

    The other thing is, that this is obviously not solely a Droid problem. If blackberry's, iphones, etc are all having this problem too, then what could be causing it? I'm so confused. I just want it to work properly when that's what I'm paying for!

    EDIT: Oh and I never had a message actually "fail" to send. It would just not go through and my phone would never tell me. It was just pending instead of failing.
  17. krichek

    krichek Android Enthusiast

    The little envelope changes size to indicate when it has been received, it starts out large and then shrinks to indicate that it has been received. If you press it while it is still large it will show pending. Failed messages are indicated by an envelope with a red ! instead of the i in the bubble.
  18. NickRo

    NickRo Newbie
    Thread Starter

    Yeah, they never did that for me. IIRC, they were small right after hitting send, and then got a little bigger and with the i in the bubble shortly after that. Kind of like it was sent. They never ever changed from the i in the bubble though. All of the texts that I sent (or tried to send for that matter) via the stock messaging app all had the same envelope whether they went through or not. After starting this thread yesterday, I tried long pressing the envelope with the i bubble and it didn't do anything. I quickly got frustrated when it didn't send one through again and downloaded Handcent and all texts after that yesterday worked. I always got quick responses from who I sent them too. So I don't know what happened or if it will stay that way but I sure hope it does.
  19. dmm

    dmm Newbie

    If you don't want the icon with the envelope with the "i" over it, uncheck Delivery reports under settings for the message app. I couldn't figure out why I was suddenly getting that icon, and it turns out I accidently checked that box. All the reports for messages I sent to verizon customers say "sent," whereas all the reports for the messages I sent to non-verizon customers say "pending," even though I believe they were all sent correctly.
  20. dramad33r

    dramad33r Lurker

    I'm having the same problem. My text inbox reset by itself this morning then later in the day my texts all have the pending symbol. People are still getting my texts because they reply, but the symbol stays for all of them. Anyone know how to fix this?
  21. alostpacket

    alostpacket Over Macho Grande?

    alostpacket's reply to this thread is pending....
  22. croyde

    croyde Member

    Just to bump this but I seem to be getting this text pending message everytime I use the group text. If I try to forward the message to an individual it is still pending yet if I write the message directly to the other person it sends no problem.

    Basically means the Group bit is useless which is a shame.

    I'm using a Desire btw.

  23. kratos

    kratos Back on my throne!!!
    VIP Member

    This may not be much help, but I have never had this happen. I use Handcent SMS and haven't touched the stock messaging app for a few months now. Maybe try using Handcent and see if it still happens.

  24. IN2-H2O

    IN2-H2O Lurker

    My Wife just had this issue today as well and found the "delivery reports" checked. She swears she never checked anything and that it just started happening on it's own. Unchecking the box clears it right up so at least it's an easy fix.

    It started when I was using my phone as a tethered modem and responded to her text in the popup that appeared on my laptop.
  25. megaera

    megaera Well-Known Member

    Try erasing the data and cache for handcent. Or uninstalling and reinstalling. On handcent, a long press will bring up the message options, scroll down the menu to the resend option.

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date

Share This Page