Help Trouble installing F-Droid


LG Volt LGLS740
Android 4.4.2

I've tried installing F-Droid to the 7 year old phone above.

When I tap on the apk file I keep getting this message:

Parse Error
There is a problem parsing this package.

FWIW I successfully installed NewPipe and the ACR-Lightning web browser.

Is there anything I can try to get F-Droid installed?


Thread starter

Hopefully this will work on your device.
If not, let me know and I will find another version.

That version worked! Thank you!

Yes the phone is very old.

I tend to be a last adopter. Cheaper and better technology with better support.

I'm on a computer day and night so phones aren't a big thing for me to get.

I've only ever upgraded when carries told me that my current phone would no longer work on their network.

That just happened to me, and I got a new phone, number 3.

Number 2, is the 7 year old model.

I still like it and decided to use it at the gym with their wifi, and avoid putting my new phone at risk.

I've been installing F-Droid apps to get support for the apps I have being discontinued.

Thanks again for the help.


Android Expert
F-Droid is a wonderful appstore.
I go there first when I look for apps.

Do you have additional repositories for F-Droid?
There are many more apps that you can have access to, and some are very very good.

Add these links to your F-Droid apps on all of your devices.