1. Are you ready for the Galaxy S20? Here is everything we know so far!

upgrade crashed

Discussion in 'Android Devices' started by oilyboy, Apr 19, 2012.

  1. oilyboy

    oilyboy Member
    Thread Starter

    I was trying to upgrade my ssg2 to the latest firmware using Kies it stopped upgrading at 3% I tried the emergency recovery but it fails to work. I get the message "failed to convert to upgrade mode".
    The phone is unlocked on 02.
    I would be grateful for any help Please.

    Regards
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Forbidden 403

    Forbidden 403 Android Enthusiast

    Since you have already tried the emergency firmware recovery I can only recommend the following.
    • If you still have warranty then take it to a service center.
    • If not then just download the firmware to your PC and flash it via Odin. (I am assuming you can manually enter download mode using a jig or the three button combo)
     
    oilyboy likes this.
  3. oilyboy

    oilyboy Member
    Thread Starter

    Thanks Forbidden

    I pressed the three buttons and got to a screen saying about custom OS.
     
  4. Forbidden 403

    Forbidden 403 Android Enthusiast

    Yes that is how you enter download mode. You press volume up to confirm that you wish to enter download mode.

    So now that you can enter download mode it is possible to flash a firmware via Odin and salvage the phone.

    Keep in mind though that improper flashing can brick the phone, so be very careful if you choose to flash it yourself. Also make sure that you only update to the Official formware for your phone so that your warranty is not voided and you are eligible for future updates via Kie or OTA
     
  5. oilyboy

    oilyboy Member
    Thread Starter

    I phoned Samsung this morning and was told to start the phone and then press and hold the home and power button untill it restarts and then do the emergency firmware recovery.
    I had to do it a couple of times and then it worked. upgraded to ICS.
     
  6. Forbidden 403

    Forbidden 403 Android Enthusiast

    Good to see that it worked for you.
     
  7. oilyboy

    oilyboy Member
    Thread Starter

    Thanks!:shakehands:
     
  8. FCBarca

    FCBarca Newbie

    Yeah, that power & home button shortcut didn't work for me...Otherwise, experiencing the same issues

    I have an unlocked S2 that I was attempting to upgrade the firmware to ICS via Kies on a PC. Everything looked good bu at around 85% progress in the installation or downloading process of the update, it froze.

    Stuck on the 'Firmware upgrade encountered an issue. Please select recovery mode in kies & try again.'

    I can't get it to change from this screen and I can't upgrade or reset the phone. I attempted the reset with the hold, vol. down & power buttons pressed but it brought me to the rooting option screen. I could choose to root or reset but resetting brought be back to the frozen screen I mentioned. I've restarted the phone (removing battery) and kies but nothing works.

    Am I only left with trying to root the device or can I somehow manage to get back on the upgrade track (Which I prefer)?

    I've gathered from elsewhere that my best option is to flash the firmware...I have a Mac 10.6.8 and I saw somewhere that Heimdall supposedly works well in place of Odin...I downloaded what appeared to be the correct ICS firmware for my country and carrier although when I tried to have the md5 file load into the Heimdall program, I received an error message about it being malformed...Moreover, I am unclear as to how to locate the PIT file that is mentioned in the guide
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...