1. Are you ready for the Galaxy S20? Here is everything we know so far!

WIFI disconnect while sleeping

Discussion in 'Android Devices' started by Solangeburgas, Jun 9, 2017.

  1. Solangeburgas

    Solangeburgas Member
    Thread Starter

    S7 Edge Neverlocked.
    I have WIFI settings set to always on but the phone disconnect from WIFi after about 15 min after goes to sleep. Like the settings would be "while charging"
    I have this phone for about one year and this WIFI problem was not present until few weeks ago ( maybe update time ? :)
    I try reset all network settings, set the WIFI for DHCP or static... toggle between "while charging" "always on" and "never" . forget network and log again... no result. Router has 2.4 and 5 ghz bands. I try on both, disconnect either band i use.I also reboot phone and clear cache
    Is not about my router, various other phones (including another one S7) stay connected and this one stay connected as well for months. No changes done on router or phone settings, no new app downloaded...
    Other settings i miss or a new bug ?
    Any help appreciated, thx


    Meanwhile i found an app like WIFI Keep Alive and look like with this app the phone stays connected. But i dont like this workaround, look like stupid to me to have an app doing what phone should do,
     


    #1 Solangeburgas, Jun 9, 2017
    Last edited: Jun 9, 2017

    1. Download the Forums for Android™ app!


      Download

       
  2. Solangeburgas

    Solangeburgas Member
    Thread Starter

    After 12 hrs while WIFI stay connected with the help of app... now begin to be disconnected again in 10-15 min after phone goes to sleep , despite settings and helping app. Only me having this problem ?
     
    #2 Solangeburgas, Jun 10, 2017
    Last edited: Jun 10, 2017
  3. Leon Marco

    Leon Marco Well-Known Member

    Are you using a Samsung mobile? If so, scroll  down the status bar,touch and hold the wifi button,select options and select keep Wifi on during sleep. If you're using any​ other do the same steps and choose advanced option when you see it and select keep Wifi on during sleep. Presto! Done!
    If your problem has not been solved yet then let me know we could try for something else. If it works post it. If someone's facing the same problem he/she can follow the instructions given above.
     
  4. Solangeburgas

    Solangeburgas Member
    Thread Starter

    Sure not working, i already mentioned i have a S7 Edge and keep WIIF always is selected.... Screenshot_20170610-133716.png
     
  5. Leon Marco

    Leon Marco Well-Known Member

    Have you tried connecting to another router? Does the same problem take place with any other device connecting to the same router? Does problem occur when connect to any AP?
    You say that this problem started occuring only a few weeks ago. Try remembering what you must have done. Probably you tried an app that saves your battery by reducing the number of apps in the background or disabling the Wi-Fi frequently.
     
  6. Solangeburgas

    Solangeburgas Member
    Thread Starter

    Not tried on another router, i will when ill have the chance. But on my router there are several mobile connected (including an S7) which stays connected, Also this phone stay connected for several months on this router, suddendly (maybe after update) begin to discconect.
    I have no app for battery saving. And i never try this kind of app. Also power saving mode is set to offl
    Yep, begin to disconnect several week ago, without any modification on phone settings or router.
     
    #6 Solangeburgas, Jun 10, 2017
    Last edited: Jun 10, 2017
  7. Solangeburgas

    Solangeburgas Member
    Thread Starter

    Tried on another router. Still disconnects.
     
  8. Solangeburgas

    Solangeburgas Member
    Thread Starter

    And tried also on a third router.....still disconnects
     
  9. Solangeburgas

    Solangeburgas Member
    Thread Starter

    Some guy on other forum said to set phone to airplane mode, open wifi than turn back airplane mode to off. Tried this, not working
     
    #9 Solangeburgas, Jun 11, 2017
    Last edited: Jun 11, 2017
  10. seVer

    seVer Android Expert

    have you tried safe mode? that will eliminate 3rd party app issues. too often I've seen random apps have crazy impacts on unrelated things.
     
    Solangeburgas likes this.
  11. Solangeburgas

    Solangeburgas Member
    Thread Starter

    No, is the first time hearing about safe mode. How i enter my phone to safe mode ? Thx for reply


    Later edit
    Meanwhile i found this about safe mode, i will try this and post my results. Thx again

    Turn on and use safe mode
    Safe mode allows you to turn on the device with third-party apps disabled. Then you can easily unistall apps that may be causing a conflict or software problem.



    1. Turn the device off.
    2. Press and hold the Power key past the Samsung Galaxy S7 edge screen.
    3. When "SAMSUNG" appears on the screen, release the Power key.
    4. Immediately after releasing the Power key, press and hold the Volume down key.
    5. Continue to hold the Volume down key until the device finishes restarting.
    6. Safe mode will display in the bottom left corner of the screen.
    7. Release the Volume down key when you see Safe Mode.
    8. Uninstall apps that are causing a problem.


    Turn off safe mode
    1. Press and hold the Power key.
    2. Tap Restart.
     
    #11 Solangeburgas, Jun 12, 2017
    Last edited: Jun 12, 2017
  12. Solangeburgas

    Solangeburgas Member
    Thread Starter

    I did perform this test. Phone confirmed is in safe mode by labeling this in left lower corner and third party app was not started, missing from home screen. But i dont find anything new... the same, after 10-15 min after phone goes to sleep the wifi disconnects. When i wake up the phone WIFI is connecting again immediately. I did this test twice.
     
  13. seVer

    seVer Android Expert

    then it's not a 3rd party app. since you've reset network settings, you can reset all settings. just defaults everything, it does not delete anything.
     
    Solangeburgas likes this.
  14. Solangeburgas

    Solangeburgas Member
    Thread Starter

    Mysterious are ways of Lord :) Yes, resetting all settings (not just network) solved my problem. Now WIFI stay connected when phone goes to sleep.
    Thank you very much for support.
     
  15. Solangeburgas

    Solangeburgas Member
    Thread Starter

    But after one day, without any modification on router or phone... WIFI begin to disconnect again while sleeping.
     
  16. seVer

    seVer Android Expert

    sounds like it's time to backup and factory reset. make sure you don't restore from a backup until you've tested without anything loaded/installed.
     
    Solangeburgas likes this.
  17. Solangeburgas

    Solangeburgas Member
    Thread Starter

    Thx, This is only thing to try. But way too disturbing for the moment. If ill perform this factory reset i will come back to post resolution
     
    #17 Solangeburgas, Jun 16, 2017
    Last edited: Jun 16, 2017
  18. ei05056

    ei05056 Lurker

    Did you find the solution?
    Me and a friend both both a S7 Edge recently and we are both having the exact same problem. :(
     
  19. ei05056

    ei05056 Lurker

    Didn't see anything related in the power settings. :/

    The only setting related to it is the "Keep wifi on during sleep" and that seems not to be working.

    Seems to be a samsung bug and also rather common, how come they don't fix this?
     
  20. Solangeburgas

    Solangeburgas Member
    Thread Starter

    I did not find a solution, i did not perfrom a factory reset. And i will not perform soon because too much hassle and i dont know if this will solve.
     
  21. Jason Broad

    Jason Broad Lurker

    I have exactly the same problem on S7.
    No idea how to fix
     
  22. Colmss

    Colmss Well-Known Member

    Have y'all tried resetting network settings?
    General management -> Reset -> Reset network settings
     
  23. Solangeburgas

    Solangeburgas Member
    Thread Starter

    Yes, i did and not solved the problem. But with last update look the problem is solved, more than three weeks now since the wifi dont disconnect anymore
     
  24. MDAR Ltd

    MDAR Ltd Lurker

    Hi

    I've been having this extremely annoying condition too, since the last software update.

    I came to the conclusion that it was some kind of aggressive power management setting that was putting all kinds of apps to sleep.


    Today.... I think I might have found a solution... I say might, as it's only been a few hours..


    So I've done is this..

    Go to settings.

    Search for "Battery"

    Click on the three menu dots in the top right hand corner.

    Click on "Advanced Settings"


    Turn off "App Power Monitor"




    So far, so good.


    My WiFi stays connected and the 2 VoIP apps and Text-to-voice app are alive and well.


    Curiously, my battery drain doesn't seem affected.


    I'd be interested to know if this solution works for other people.

    Good luck.


     
    RepubiicWirelessUser likes this.
  25. MDAR Ltd

    MDAR Ltd Lurker

    Hi

    I've been having this extremely annoying condition too, since the last software update.

    I came to the conclusion that it was some kind of aggressive power management setting that was putting all kinds of apps to sleep.


    Today.... I think I might have found a solution... I say might, as it's only been a few hours..


    So I've done is this..

    Go to settings.

    Search for "Battery"

    Click on the three menu dots in the top right hand corner.

    Click on "Advanced Settings"


    Turn off "App Power Monitor"




    So far, so good.


    My WiFi stays connected and the 2 VoIP apps and Text-to-voice app are alive and well.


    Curiously, my battery drain doesn't seem affected.


    I'd be interested to know if this solution works for other people.

    Good luck.


     

Samsung Galaxy S7 Forum

The Samsung Galaxy S7 release date was March 2016. Features and Specs include a 5.1" inch screen, 12MP camera, 4GB RAM, Exynos 8890 Octa processor, and 3000mAh battery.

March 2016
Release Date
0
Reviews
Loading...

Share This Page

Loading...