1. Download our Official Android App: Forums for Android!

Support WiFi Issue?

Discussion in 'Android Devices' started by brikholl, Sep 15, 2011.

  1. brikholl

    brikholl Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 30, 2010

    May 30, 2010
    4
    0
    5
    Hi Folks. I've been reading about the reports about radio issues on the Bionic, but nothing really matched this behavior I'm seeing. Thought I'd see if anyone else was having this issue. (if this should be added to the existing radio thread, that's fine, but that seems to be more around 3G/4G)

    What's going on is that the phone doesn't auto connect to an access point when in range if the screen is locked. For example, I'll be on WiFi at home, and leave for work. I've already set up the AP for the office on the phone, but here it is 1:30pm and it hadn't connected to it yet. I unlocked the phone and it took about 30-40 secs and then finally connected. It'll generally stay connected until I leave, and then won't connect at home until I unlock the screen there.

    What's puzzling is that my previous phone (Incredible) would connect on it's own when it found an AP it knew.

    I never lose 4G though, so it's just the WiFi that's behaving this way. Is this just a difference in brands, or might there be an issue? It's done this ever since I bought it last week.

    Anyone else seeing this?
     

    Advertisement

  2. kingnut

    kingnut Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    229
    Joined:
    Aug 20, 2010

    Aug 20, 2010
    229
    19
    38
    i doesnt connect cause it saving battery life. i think theres a setting you can go into and change were it will pick up a wifi hotspot while the display is off. the only time wifi works with the screen off is when your streaming data ie (pandora or iheart).
     
  3. amageus

    amageus Android Enthusiast
    Rank:
    None
    Points:
    53
    Posts:
    439
    Joined:
    Dec 24, 2009

    Dec 24, 2009
    439
    85
    53
    Could it possibly be to do with the Battery Mode? I believe stock it's set to "Maximum Battery Saver" but it doesn't really specify what it does. And I am guessing while you're phone is sleeping it doesn't auto connect. Try "Performance Mode" and see what happens. It's located under Settings/Battery and Data Manager.
     
  4. jpetersen5

    jpetersen5 Well-Known Member
    Rank:
    None
    Points:
    16
    Posts:
    80
    Joined:
    Nov 2, 2009

    Nov 2, 2009
    80
    3
    16
    The problem I have is similar, but not quite the same. At home, it connects just fine, but at work, I have to go into Wireless Settings and then wi-fi settings. Once I go there, then it finds the Access point at work and connects to it right away. Without doing that, I am not connected to wifi at all at work, just 4G.
     
  5. kingnut

    kingnut Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    229
    Joined:
    Aug 20, 2010

    Aug 20, 2010
    229
    19
    38
    mine is on performance mode. still cuts off wifi unless im streaming. it does check for updates but im pretty sure thats via 3g/4g.
     
  6. brikholl

    brikholl Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 30, 2010

    May 30, 2010
    4
    0
    5
    Yeah, I'm in performance mode as well. I get updates too, but must be over 4g. I'm a pretty light user, so it's not like this is a battery saving issue, but it's more an annoyance that it behaves this way.

    Couldn't find a setting to make it connect while locked either.
     
  7. Somniferum

    Somniferum Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    283
    Joined:
    Jan 14, 2010

    Jan 14, 2010
    283
    65
    63
    Try this: Go to Settings > Wireless and Networks > WiFi Settings > Options button > Advanced, then select WiFi Sleep Policy and change to Never. In theory this could help with battery life over WiFi as well, since the phone won't be popping in and out of WiFi all the time.
     
    brikholl likes this.
  8. brikholl

    brikholl Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    May 30, 2010

    May 30, 2010
    4
    0
    5
    So far this seems to be working. Will see how it goes at the office on Monday. But so far, so good.
     

Share This Page

Loading...