1. Check out our app, Forums for Android! Download and leave feedback here!

Wireless hardware problem

Discussion in 'Android Devices' started by benkitcher, Nov 17, 2009.

  1. benkitcher

    benkitcher New Member
    Thread Starter
    5

    Oct 30, 2009
    3
    0
    5
    Hi Everyone,

    I've been a lurker on here for a little while now, picking up hints and tips as i go. I've happened on my first problem with my hero now though, and wondered if you guys can help before i send my phone back to CPWH for suspected hardware failure. I've tried searching, but this wireless issue seems fairly unique in that my phone has worked for a long time but now does not.

    I've had my wireless working on the network at work since I got the phone (which was the first week the hero came out on orange uk, july maybe?) and all has been well. I have recently however experienced some frustrating anomalies. Symptoms are as follows;

    1) Wireless will not turn on at all using either toggle widget or through settings menu any more. Sometimes will turn on, maybe works 1 try in 5. The phone almost locks up while trying to turn on the hardware, the widget continues to flash for a good while but not actually turn on. On the settings menu i will get a message saying "wireless cannot turn on right now" or something to that effect.

    2) If it does turn on, it will connect to my preferred network and disable 3G, but loading web pages is very sporadic (will load maybe 1 in 10 pages tried)

    3) Since this problem started, the phone has become totally unresponsive maybe 20 times, each time requiring a battery out restart.

    To remedy the problem I've tried a factory reset several times with and without re-installing my old apps, and the problem persists.

    Current build number is 2.73.405.5, updated from HTC site in september.

    Has anyone come across similar problems?

    Thanks in advance,

    Ben
     

    Advertisement

  2. vido.ardes

    vido.ardes Well-Known Member
    163

    Oct 17, 2009
    1,059
    200
    163
    Software Developer
    Kent, UK
    I haven't heard of similar problems, and it sounds like you have tried all the correct steps to rule out a software problem. Sounds like the hardware to me, I would get it checked
     
  3. benkitcher

    benkitcher New Member
    Thread Starter
    5

    Oct 30, 2009
    3
    0
    5
    Appreciate the second opinion. It seemed clear to me whilst writing that post that it is hardware.

    Just don't want to send it off and 'droid-less for 2 weeks :(
     
  4. vido.ardes

    vido.ardes Well-Known Member
    163

    Oct 17, 2009
    1,059
    200
    163
    Software Developer
    Kent, UK
    It's nice to see someone do thier homework before asking about a problem :D
     
  5. benkitcher

    benkitcher New Member
    Thread Starter
    5

    Oct 30, 2009
    3
    0
    5
    Quick update;

    I sent the phone off to HTC through the Carphone Warehouse a few weeks back and it has returned to me in the same condition. Their solution was to 're-load ROM to 2.73.405.5'!!!! I'd already told them i was sure it was hardware, and i've now been without the phone for a few weeks and am no better of for it :mad:

    I'm going to go back in and demand a replacement there and then.

    Cheers
     
  6. MattW

    MattW Well-Known Member
    16

    Nov 26, 2009
    68
    2
    16
    IT researcher
    Cheshire, UK
    Have you tried connecting to other wireless access points? There is a known issue regarding 802.11n access points / routers.

    If the problem is occurring at home, try configuring your router to only use 802.11b/g.
     
Tags:

Share This Page

Loading...