All In One Recovery Thread

Last Updated:

  1. chefjw

    chefjw Member

    Well I gave up and tried the old 1.1.0 thunder-c recovery and it seems to work perfectly fine.

  2. wrath_00

    wrath_00 Well-Known Member

    I'm sure GNM will let us know when he gets it fixed. I'm using clockwork untill this recovery is fixed.
  3. santhoshs

    santhoshs New Member


    Today i successfully rooted my P500 (with z4root) and installed custom recovery (Custom Recovery P500/Thunderg v1.2). it was late night i stopped here.

    when i used the custom recovery for taking back up, i got the menu as mentioned by you with options:

    1. Nand Backup
    2. Nand Backup + .android secure
    3. Nand + ext backup
    4. Nand + ext backup secure
    5. Nand Restore...

    I selected the 4th option, i got a message = Error: use " from adb. The log file is attached. How do i take back-up

    One more Q - when i log into custom recovery a msg at the bottom of screen displayed saying - E: 'Bad Boot Message', any help on this?Other details:

    Phone - LG P500
    Custom recovery - Thunderg v1.2

    Attached Files:

  4. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Thats an old version please use the one listed on downloads in this thread. You want version 2.2.1
  5. wrath_00

    wrath_00 Well-Known Member

    GNM any luck with the Optimus V recovery?
  6. Itbagurmom

    Itbagurmom New Member

    idid this and now my phone will not boot up instead its stuck at a screen that says fastboot mode started
  7. dautley

    dautley VIP Member VIP Member

    Has anyone playing around with 2.2.2 on the ally noticed Amonra recovery 2.2.1 will not stick? I can flash it, and boot into Amonra but after I reboot it goes back to Verizon's stock recovery and I must flash Amonra again to use it, then it goes back to Verizon's stock recovery again on the next reboot.

    **Edit** the phone boots up into 2.2.2 fine but when I try to go back into recovery its always Verizon's unless i reinstall Amonra before reboot.
  8. santhoshs

    santhoshs New Member

    When tried to install V 2.2.1 with the following commands:

    $ su
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock1 /system
    # cat /sdcard/flash_image > /system/bin/flash_image
    cat /sdcard/flash_image > /system/bin/flash_image
    /sdcard/flash_image: No such file or directory

    I got the above error "no file....", but in fact the flash_image was there in the sd card. what may be problem

    Before using V2.2.1 should i uninstall older version or upgrade. I did not do this in the above case. If i have to uninstall upgrade, how should i do it. Pls help me.

    Battery is more than 60%
    Free space of about 1GB on sd card
  9. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    You must remove as per directions.

    You must unzip into root directory of sdcard (not in any folder)
    dautley likes this.
  10. dautley

    dautley VIP Member VIP Member

    I thought I had but apparently not, it's working now.:)
  11. lwk523

    lwk523 New Member

    May I know is it the same method for me to update my custom recovery ? And how to check my current version of custom recovery ? Newbie here. Anyway, Big thank first ;)
  12. santhoshs

    santhoshs New Member

    Yes i ensured that the file is unzipped and the file was present at the root directory of sd card.

    I had no issues when i first rooted and installed the custom recovery. Today i tried to install the same V 1.2, i got the same error. Is it because the flash_image file is already present in the bin.?

    I am attaching the pics of root dir, battery level, free space availibility and the commands used by me to install V 2.2.1. I have also attached the recovery log file.

    i got error msg after second line of command.

    V2.2.1 was not intalled.

    Pls let me know the solution.

    Attached Files:

  13. wrath_00

    wrath_00 Well-Known Member

    If you want try the optimus s recovery. It works just the home and menu buttons are switched.
  14. Masema

    Masema Member

    I'm having the same problem on my LG Optimus V, as well. I didn't have any trouble while following the directions. (I didn't have the file to delete.)

    But when I try to boot to Recovery, I get just a black screen after the LG logo. If I keep holding the buttons, it usually reboots again into the normal mode. If I let go, it seems to just stay on a black screen until I pull the battery.

    I guess I should have read the whole thread before trying. (I also should have grabbed a copy of my oren stock recovery to fall back on.)

    Out of curiosity, what is the difference between the stock flash_image and the provided replacement?
  15. wrath_00

    wrath_00 Well-Known Member

    More options. With this recovery your able to flash roms stock you can't. I tried the optimus s version on the optimus v and worked just the home and menu buttons are switched maybe try that one untill the optimus v version is fixed.
  16. Masema

    Masema Member

    Yeah, I've learned the difference between the recovery images themselves. I was wondering what the difference is between the versions of the "flash_image" program itself (between the one that is already in /system/bin/ and the one we download and overwrite it with).

    I did find another Recovery .img that worked for me. It identifies itself as "RA-thunderc-1.1.0-GNM". So, thanks GNM! (Yes, the menu and home keys appear to be switched.)
  17. Bronxand

    Bronxand New Member

    So i believe i followed everything correctly (but since im having trouble apparently i havent. lol)

    I have an LG Optimus V

    so i type everything in the command prompt and when i enter the line where you type in the recovery image name i get the following:

    usage: flash_image partition file.img

    then when i type in sync.

    from this point i expected it to reboot automatically but nothing happened. So i fiddle around with my phone, turning it off, and pushing the home volume down and power button simultaneuously, but i cannot boot into recovery mode.

    any suggestions?
  18. hidronico

    hidronico New Member

    afterwards you type sync then reboot recovery
  19. wrath_00

    wrath_00 Well-Known Member

    If your using the optimus v version its not working yet as far as I know. I'm using the optimus s version. The home and menu buttons are swapped but no big deal. Are you switching from stock or a custom recovery?
  20. thunderkiss65

    thunderkiss65 Well-Known Member

  21. thunderkiss65

    thunderkiss65 Well-Known Member

    When i flash to this everything goes through fine, but when i go into recovery i have my same exsisting recovery, RESOLVED, had one typo in adb.
  22. allchat2010

    allchat2010 New Member

    I'm having the same issue, theres no way to get any files on or off of it, adb wont work because my computer no longer recognizes my phone when i plug it in,, recovery doesnt work because i can no longer boot to recovery ( even with key combo) just keeps booting to android screen and thats it,, i have vortex as well...
  23. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Optimus V has a comfirmed bug in it and I have not yet had time to investigate the cause of it. For now optimus v users please use the Optimus S recovery.
  24. wrath_00

    wrath_00 Well-Known Member

    Thanks fotr the heads up
  25. getitnowmarketing

    getitnowmarketing Well-Known Member Developer

    Optimus V and Vortex are not the same and not interchangeable and if you flashed optimus v to vortex thats a recovery that has a bug in it. I would suggest restoring your phone via LGNPST and then flashing the correct recovery to it.

Share This Page