[APP] GrooVe IP - Google Voice VoIP


  1. snrb

    snrb Well-Known Member

    We received word from a few X2 users that the Gingerbread update fixed the issues people were having with the app. We've marked the X2 as supported again on the market.
  2. z3N#

    z3N# Active Member

    Can someone please tell me how to get the update ?
    There is no update showing at Android Market in My Market Account.

    I am having a lot of trouble now with echo...whatever I do it persists, making conversations impossible for the other party.

    Thx.
  3. TnTWalter

    TnTWalter Member

    what am i doing wrong. it rings either in or out but then goes right back to dial pad.

    i am using my minutes....really frustrated as i only did the 300 minutes with virgin moible because everyone said how great GROOVE IP is....

    thanks.

    trish
  4. snrb

    snrb Well-Known Member

    Take a look here snrb Labs - FAQ. There are some steps under "GrooVe IP is signed-in (GV notification icon is green) but outgoing calls don't work" that should fix the issue. My guess is making a call from your pc using the gmail calling will fix the problem. You're able to sign-in right? Just outgoing calls ring once and then go back to the dial pad?
  5. TnTWalter

    TnTWalter Member

    incoming calls...when i click answer goes back to dial pad too....i did call from my pc using gmail...i'll try it again.
  6. snrb

    snrb Well-Known Member

    I should also ask:

    - What kind of phone do you have?

    - Are you using WiFi or 3G?

    - Do you have any task killer or battery manager apps like advanced task killer or juice defender? Because those can cause problems
  7. TnTWalter

    TnTWalter Member

    did get it to answer but hung up twice so i gave up. but it is actually calling and receiving now.

    it was 3G when I did finally receive/send calls. I will probably use wifi at home.

    lg optimus v.

    i think i have juice defender. but no idea if i'm running it. this is all way above my head.

    thanks.

    trish
  8. snrb

    snrb Well-Known Member

    I'd enable the Keep Screen Alive checkbox in the app troubleshooting settings.

    Also try disabling juice defender or similar apps. They can kill GrooVe IPs background process or turn off your data which will cause calls to disconnect or have no audio.
  9. rfb813

    rfb813 Member

    Earlier post.
    "Using the GrooVe IP dialer when I hold down the 0 key the + for international call does not function. I have to dial 011 to make the international call. Am I doing something wrong? How do you get the + to appear?"

    The Gmail dialer functions, ie; the + appears when you hold down the 0 key. This does not function with Groove IP on either of my devices, the HTC Aria or the GT P1010.
  10. snrb

    snrb Well-Known Member

    Sorry, thought I responded to your post. It's a known issue, hasn't been fixed yet.
    rfb813 likes this.
  11. Beeray

    Beeray Well-Known Member

    When dialing the USA from Europe, do I have to use any special country code, or do I dial as if I am in the states?


    Thanks
    Beeray
  12. snrb

    snrb Well-Known Member

    Dial as if you are in the US
    Beeray likes this.
  13. Beeray

    Beeray Well-Known Member

    Thank you
  14. VermontDroid3

    VermontDroid3 New Member

    Hi! Been using GIP for a week or two now on my Droid 3 with no issues, there was a slight echo at first but I fixed that as recommended in the settings - however, yesterday I received a call (wifi) and the caller couldn't hear me, and I could only hear the caller super faintly - so we hung up, I tried calling them back (wifi), and they picked up but still couldn't hear me, though I could hear them clearly this time. I *think* I just updated to the newest version, so I'm guessing it was something in the update that changed things on my phone? I rely on this app as my cell signal at home is terrible so any help is greatly appreciated! Up until now it has been a really great experience! Thanks :)
  15. techninja2

    techninja2 New Member

    Hello snrb!

    Thanks for developing this program; I picked it up and found it helped a lot for keeping in touch while overseas.

    However, I'm having problems with it on the data network. It works perfectly on wifi, but when I try using it on the go, it tell me:

    "Can not sign in, no valid network. Please check your internet connection and try again."

    I'm in an unique situation in that I can get perfect data connectivity with the provider I'm using (data-only B-Mobile, an MVNO of NTT Docomo in Japan), but because of some issues with the SIM card (not well documented, exists on almost all non-Japanese Android handsets for this provider), the status bar will show (both!) the no signal icon and the G (up/down) icon, signifying GPRS is working (the lock screen will similarly show "no signal" quite largely but hitting up the secret menus for Phone info will show -83dBm 15asu, very much usable). That said, it's not just GPRS; I've tested the connection to about 2716kbps/365kbps at 184ms, which should be your usual 3G speeds.

    Is there some type of hardcoded check only for the network? All other applications work fine with this data connection--Gmail, Talk, Opera Mini, Maps, etc.--and I'd really appreciate it if GrooVe IP worked too!

    Thanks!

    Edit: I forgot to mention, I do have "Allow 3G/4G Calling" set to enabled.
  16. snrb

    snrb Well-Known Member

    Hm. The default settings in the new version should be exactly the same as the old version. Only enabling new settings should change the behavior. Have you tried restarting the app or your phone to see if that fixes it? Any new updates or apps on the device? You can try the Keep Screen Alive checkbox to see if that helps.
  17. snrb

    snrb Well-Known Member

    Thanks for the update, the first thing I was going to ask was if you had Allow 3G/4G calling enabled. Did you purchase from the android market? I'd have to send you a version with logging turned on to see what the issue was and what we could do. The app checks checks for WiFi connectivity and then if Allow 3G/4G calling is checked it also calls the android api to see if there is any data connection available. My guess is the data connection check is returning that there is no data connection. I don't think I can remove that check for the market version, but I could build you a custom version if you email me at snrb.labs@gmail.com
  18. VermontDroid3

    VermontDroid3 New Member

    Thanks :) I was actually able to make a call ok yesterday, so maybe something just went haywire on my phone for a minute when I had the problems? I do remember that when the initial problem call came in, my 5 year-old was in the middle of Angry Birds :rolleyes: so maybe there was just too much going on and something shorted for a minute. I will let you know if I have the same problem again. Great app though, and SO happy to have found it given that we got rid of our land line and 3G signal at our house is marginal at best. Cheers.
  19. snrb

    snrb Well-Known Member

    Thanks for the update. If you like the app, please consider giving us a 5-star review :)

    Should be posting another update (1.2.1) tonight!
  20. HondaDNA

    HondaDNA Member

    I have a problem with GrooveIP signing out randomly. Every once in awhile I'll turn my screen on to see GV is red but as soon as the screen is unlocked it signs back in. I have High Perf WiFi Lock turned on and I have WiFi set to stay awake. I have a Optimus V Rooted running Android 2.3.4. My home PC has a Gmail notification program, could it be from it checking for new mail?
  21. snrb

    snrb Well-Known Member

    Try an app called Advanced WiFi Lock. Other Optimus V users reported it fixed that problem for them.

    https://market.android.com/details?id=opotech.advancedwifilockfree&feature=search_result

    We'll likely add that same type of logic as an option in GrooVe IP after tonights update.
    HondaDNA likes this.
  22. snrb

    snrb Well-Known Member

    Version 1.2.1:
    - New accessibility option to allow the Search button to hang up calls (under miscellaneous->accessibility)
    - Option to break out missed call notifications so each missed call is a new notification with caller id instead of just the missed call count
    - Allow + to be dialed from the GrooVe IP dialer
    - Add more options for dialing from the native dialer
    - New echo canceler option to auto detect the echo tail setting
    - Add images to the menu buttons
    rfb813 likes this.
  23. 54yls

    54yls New Member

    I have the latest update Version 1.2.1 today. I called my land line home phone by GrooVe IP from Samsung Galaxy, my home phone can hear the echo sound when speaking to the home phone. Is there a way to troubleshooting. I am using Samsung Galaxy GT-P1000 with Android 2.2. Thanks,
  24. snrb

    snrb Well-Known Member

    Did you turn on echo cancellation in GrooVe IP? Also make sure you're not calling from the same room, that will cause echo.
  25. 54yls

    54yls New Member

    How to turn on the echo cancellation in GrooVe IP?
    Second, the problem is also found from my friends too. They all hear their voice echo in their phone. Thanks,
    EVU likes this.
Loading...

Share This Page