Clock is giving me the wrong time?Support


Last Updated: 2011-01-27 02:17:59
  1. Palomino

    Palomino Well-Known Member

    I dont know whats going on but my clock just started giving me the wrong time all of a sudden?? Not the widget the actual tiny clock at the top right. help please?

    Advertisement
  2. PyroSporker

    PyroSporker Well-Known Member

    You may have done this already, but My advice is to do a reboot. Once the phone is off do a battery pull and wait 30 seconds to a minute before replacing the battery and powering back on.

    That should fix it, but if not, then navigate; menu key -> settings -> Date and Time. Check the 'Automatic' box and it will reset to 'use network provided values' it should re-sync the time with Sprint/Satellite. If that doesn't update it, then make sure 'Automatic' is un-checked and you can reset the date, your time zone and the set time to whatever you want.

    These settings are somewhat hidden and don't exactly jump out at you when you look through the menus.
  3. Palomino

    Palomino Well-Known Member

    ok i fixed it, but any idea as to why it did this? It was on automatic. Im wondering if anything else is wrong with it now...

    I had to change it to the actual time zone...
  4. PyroSporker

    PyroSporker Well-Known Member

    I've got no good ideas as to why. There could be something going on with it. Maybe a different app interfering? Maybe the system thinks you are located somewhere else. GPS settings, Weather app?

    Maybe you could check/update the PRL and Profile (Menu->Settings->System Updates). It might help?

    Check out this thread, it might give you some ideas:
    http://androidforums.com/evo-4g-sup...-phone-telling-me-wrong-time.html#post2039553

    One guy had a app or widget interference, and one other guy's phone thought he was in Estonia so he called Sprint and they helped do a OTA network reset.
  5. PyroSporker

    PyroSporker Well-Known Member

    :D Hope that fixed it for good. Glad to help
  6. overclock

    overclock Well-Known Member

    I had this happen to me too. You can only change the time zone when you uncheck the use network settings. I've had my phone think I was overseas as well. So I had to go to manual settings, set the time and my time zone. I checked the use network settings box. I'll see where I'm at tomorrow.
  7. Palomino

    Palomino Well-Known Member

    its so weird.... I havent installed any new apps since a couple of days ago.. and it was fine.
  8. bltserv

    bltserv Well-Known Member

    This began to happen after the late December OTA Update. We got Blockbuster, Kindle, and lost our time and place. My EVO does this on a daily basis. Its kind of fun to see where it thinks it is. Angola and Estonia are my phones favorite destinations. You can reset, reboot, battery out, Sprint Network reset. You name it I have tried it. Just last night it just decided it was 4:00 AM when it was about 6:00 PM. Seems like 10 Hours off is a favorite time for it to display. Lets see if we can get another update to fix the bugs from the last "Bloatware" Sprint forced us to use. I have learned NOTto depend on this phone. It was flawless before the update.
  9. mysterywhiteboy

    mysterywhiteboy New Member

    had the same issue yesterday and today...pulled battery, didn't help...then unchecked and rechecked "automatic" in time settings and that did the trick...

    but now i have another time-related issue: the time on my text messages is showing the wrong time. they are 3 hours off (which is the same discrepancy the rest of the phone had)...it's the stock program that came with the phone, not a third-party app.

    anyone having a similar problem? any solutions?
  10. Mr. Ed

    Mr. Ed Well-Known Member

    someone posted in another thread that sprint had mentioned to them that there is currently some sort of network issue causing this.

    the above steps seem to fix it every time.

    I have seen it before..years ago on sprint but not really as often as it is happening now
  11. spyder40

    spyder40 Well-Known Member

    Just had it happen to me again, off by an hour. Powered down then back up and I'm good again.
  12. Munnarg

    Munnarg Well-Known Member

    Been happening to me all day today. Updating my profile worked for about five minutes, but doing a battery pull did absolutely nothing.
  13. Mr. Ed

    Mr. Ed Well-Known Member

    Go into the clock settings and turn off auto time settings. Press clock widget..click on earth. Menu.local time settings. Turn off automatic. You can also ceck ur settings here and in home settings just to make sure they are right
  14. violeta0929

    violeta0929 New Member

    my time keeps changing randomly to india standard time . its like it loves going to meerut . its ever since i updated the phone with blockbuster , kindle , etc. ive called sprint and they just had me clear storage , and it works for a while , but lately its been happening on a daily basis . ive went to settings and changed automatic on and off , nothing works . i dont know what else to do .

Share This Page