Help: Samsung Galaxy S2 won't connect to KiesSupport


Last Updated:

  1. ivanck

    ivanck Member

    thank you in advance if any 1 could help ...

    Advertisement
  2. hs0kbl

    hs0kbl New Member

    Hi, I originally got connected by using this forum. Then last night I tried re-connecting at home and the phone stated connected but the PC would not recognise the device. I was on for 3 hours trying everything. I went to work today and managed to connect to the PC at work straight away. The only difference was the USB lead so i brought the USB lead from work back home and it installed the drivers immediately and recognised the device. So if anyone out there has followed all the instructions already posted and is still having no joy, then I recommend you try changing your USB lead. I am not sure if the one I was using was broken or was limited to charging only. The great thing is my phone is connected to both PC's now and I look forward to a stress-free night! :)
  3. liting90

    liting90 New Member

    u can go for setting>wireless and network>USB utilities> connect storage to PC.......then will be ok.....it do works for me.....:)
    yohannie likes this.
  4. john999xxx

    john999xxx New Member

    Using Kies (most recent version) to synchronise with Outlook 2010 was working fine for me till some days ago and then suddenly stopped working for no apparent reason, simply reporting there was an error. I found nothing from Samsung to offer any help of guidance. Eventually I tried uninstalling and reinstalling. Now I can't even connect. I've tried DavidWOT's remedy, but that hasn't worked for me. Kies is set to open automatically when the phone is attached. It does this, so at least part of the link is OK. But then it reports "Unable to connect to GT-I9100. Failed to retrieve device information." The troubleshooter reports that everything is in order -- but I still can't get a connection! The same is true trying to link by WiFi. Can anyone suggest anything else to try?
  5. dartiss

    dartiss New Member

    Ok, I'm having the same problem Kies not connecting via USB.

    However, using the USB debug option doesn't work for me - Windows (7 64 bit) doesn't look for drivers or connect in anyway - connecting a USB cable to my phone just does nothing.

    I've tried uninstalling the driver and Kies, downloading and installing the latest Kies but... still nothing. Rebooted the phone. Rebooted the computer.

    Any thoughts?
  6. Galaxycat

    Galaxycat New Member

    I'm having this same problem as well. The first 5 or so time I connected via usb it was ok. Even when the phone's screen would eventually time out the connection will still be there. The last couple of time I tried the connection kept getting lost. I have the latest version of Kies and the firmware was updated to DXKI2
  7. Russell Ng

    Russell Ng Well-Known Member

    Never realized so many having problems with Kies. Truth, I don't really like Kies. Its actually way to slow. If not for the fact that I need it for firmware upgrades (Officially), and backup of contacts, memo, notes etc., I probably won't be using it at all.

    Transferring files (to back them up), is so much faster by going into USB mode and connecting like that so that the phone works like a external HD. Simpler too.

    So far though, I noticed that Kies is more stable on Windows XP Pro. I am using Windows 7 64bit as well, but when using it with kies, it ran into some issues. I also noticed that if your internet connection is not stable or fast enough, the firmware updates can stop midway. I use XP in the office and the internet connection there is faster, and that could be the reason I have less issues with Kies using XP.

    That said, I never had to do any debugging for the USB connecting to Kies. I downloaded the Kies of the net, installed it and then everytime I plug in the cable to the computer, it will just go straight to the MTP screen. That's when I usually press the home button. :D

    But if I want to use Kies, I usually switch it on first before connecting the USB cable. Sometimes the connection do seems to get stuck, so I usually just restart my phone and the computer and eventually they do connect. Never had a case where just cannot connect at all (Yet?).

    Cheers and sorry if can't really help since never had all the problems described or had to go through all the debugging steps.
  8. sam142000

    sam142000 Well-Known Member

    I guess I have a unique problem here.
    My phone connects to Kies perfectly, but its not detected under the Firmware upgrade settings. Because of which I'm not able to update my phone.
    I've even tried formatting my laptop for this to work.
    My phone doesnt event upgrade the firmware OTA. When I contacted Samsung regarding the firmware OTA update, they said that its currently not supported in India(I live in Delhi, India).
    Someone please help me on this!!
  9. cfc

    cfc Well-Known Member

    I can't get my phone to connect to kies either have tried everything thats worked for others,
    my phone is on 2.3.4 and rooted, and pc is windows 7 64bit
  10. stephenhicks

    stephenhicks New Member

    I was having the same isues as the other guys but then I...
    1/ turned off Bluetooth
    so Kies wasn't trying to connect via Bluetooth and used the USB cable instead.
    2/ turned off the screen lock
    so the system was not locked during connection.
    ... and all worked!
  11. Adunaphel

    Adunaphel New Member

    I did all of that and it still wasn't working but when i went to minimize all my windows something told me to restart my computer and when i did i plugged in my phone then started kies and BOOm instantly connected it was weird...
  12. krypt23g

    krypt23g Member

    I had the same problem like the poster; I just re-installed the OS (by pressing 'home' 'volume up' 'power' during re-start).

    Mine use to work before and it suddenly stopped working. This helped me. If urs never worked then probably dont try it.

    Backing up data without kies is really difficult; it took a lot of time for me to do it manually.
  13. ss_bhullar

    ss_bhullar New Member

    Hurrah this worked for me also
  14. Nirvana1000

    Nirvana1000 Well-Known Member

    This CONNECTING ISSUE has not been permanently resolved and it should be!:mad::mad: Connect with USB Debug,disconnect,re-connect without USB Debug then it's connected.NOT.Then it fumbles to connect.I don't know if it is Windows XP or KIES or both.But it's up to Samsung to resolve this.:eek:They should scrap KIES and/or design a new program,driver,fix,plugin or whatever.This is a fantastic phone and my enjoyment has been marred with this connection issue.
    plum and roge26 like this.
  15. LFCLasse

    LFCLasse New Member

    It worked:) Thanks!

  16. Gurba

    Gurba Well-Known Member

    How about some advice on how to get the S2 to connect to Kies that DOES NOT involve unticking debugging. My phone isn't in debug mode but it won't connect to my Win7 64-bit PC nor my Vista 32-bit PC. Kies can't even make up it's mind what's wrong. Either process on the phone won't start, the phone can't connect in this mode reconnect in Kies mode or it just tries to connect forever to no avail. I've tried to connect with debug ticked whitch got the PCs to install some additional drivers but Kies won't connect with or without debugging. IMHO Kies is the worst phone-to-PC app I've ever had the misfortune to try. If I made Kies I would be so ashamed that I would move into the woods and never see another person again for the rest of my life.
    BillAnderson likes this.
  17. roge26

    roge26 New Member

    Hi, new to this forum although I've looked at it before when Kies was driving me mad. It is total rubbish but it was at least working for me. Today I went on it to sync calendar etc. and it said there was an upgrade version of kies. Foolishly I imagined a beautiful utopia where the new version would work seamlessly with my Galaxy S2. Unfortunately...now it won't connect at all. It just sees the phone as being in mass storage mode and tells me to set it to PC Studio mode or something but the phone should automatically default to this as far as I can tell. I still have to go to settings>USB utilities>"Connect storage to PC" to get it to work in mass storage mode. When I click the connection troubleshooter that just comes up with an error too. Previously had a Nokia and that just used to connect to the computer and sync like a dream :'(
    plum likes this.
  18. Nirvana1000

    Nirvana1000 Well-Known Member

    I and many others have given up on Kies.Just use Windows explorer.
    plum likes this.
  19. axesever

    axesever New Member

    I had this problem, here was my fix:

    Plug the phone into the USB.
    Turn phone off, hold lock and select Turn Off.
    Wait.
    After its off and loads the Battery Charging icon, turn it back on.
    Wait.
    It should send the driver info to the computer and recognize it.

    If it doesn't work for you, it might be because I enabled USB debugging prior to restarting it. It works in Kies now.
    vlad21ro likes this.
  20. kevinjensen

    kevinjensen New Member

    None of the fixes that I read worked for me.

    In the end I rebooted s2 and every thing was great
  21. roge26

    roge26 New Member

    Oh....guess what it's working now.....this is my fix...connect your phone on a Monday morning at 9.47am; absolute guaranteed success :D
  22. roge26

    roge26 New Member

    In seriousness....I re-downloaded the Kies software and installed. Re-booted computer. Connected phone but still got the "Re-connect the device in Samsung Kies (PC) Mode. Current connection is not supported by Kies" message. I disconnected the phone and ran the connection troubleshooter (which wouldn't run prior to re-installing the software). This ran and then I re-connected and lo and behold it worked. I'm just off to skip around the neighbourhood with a delighted grin on my face...until the next time folks (tomorrow probably)!!!
  23. sireid

    sireid New Member

    I'm at the end of my tether with this phone now.
    After spending day's comparing phones and networks I finally bought this lovely phone, but I'm now thinking 'come back Ovi Suite, all is forgiven!'
    Purchased two weeks ago, it has never connected via USB. I did once get it to sync with Kies Air, but never again since. :confused:
    Working in Win7 64bit, I've tried all the solutions listed above and can get nowhere...

    1. in debug mode
    2. in normal mode
    3. turned phone off, turned pc off, reboots, nothing
    4. In USB connection, my phone says it's connected but the laptop says it's connecting and stays that way.
    5. In Kies Air, when adding the IP address to Firefox, the window background changes to a grayish colour, but won't go any further. Looking at the page source all elements should be displaying, but they're not.
    6. Also tried this in IE9 and it crashed.
    7. Tried it in Chrome and it won't connect at all.
    Seriously, seriously hacked off with spending money on a product that won't work at all! I would use it in Explorer, but I would prefer to use it with contacts and calendar etc synced which I use a lot.
    Time to spend an hour on the phone Samsung support tomorrow as a last resort...and probably get nowhere too. :mad:
  24. star_devilyn

    star_devilyn Member

    Kies is such a failure. When there an update to the software it can't update it! I've got to search for the new version of the software from Samsung website itself just so I could update it and get the new firmware for my Galaxy sII. It has support for MAC but users cannot update firmware of their phones on their MacBook,iMac..etc.
  25. beyond

    beyond Well-Known Member

    ^Where did you get info/confirmation of your last line from?

    Cause that sounds like my problem. Kies works fine with my 2.3.3 Galaxy S2 and 2009 MBP (after a restart on both) but under firmware it says 'GT I900 does not support firmware upgrade'!

Share This Page