[How To] Root 2.3.4/downgrade and Get S-off

Thread Status:
Not open for further replies.

Last Updated:

  1. RewindByChance

    RewindByChance Active Member

    Update for you guys... I called Verizon, they told me to dial some number, and after a few seconds my phone works again. :) Now I'm off to go root my phone and get another ROM again, haha. Since I'm S-OFF can I now just flash a new ROM and run unrevoked?

    Edit: After looking around I think I answered my own question. I'll just follow iowa's guide to regain root with S-OFF.

    scotty85 likes this.
  2. rootnewbie

    rootnewbie Member

    *22899 was what they told me; I tried but the programming was successful and still no texts...
  3. timelord65

    timelord65 Well-Known Member

    Success, s-off running [Rom] Official Inc Ota 4.08.605.2 [Updated:23Nov2011] available at RootzWiki

    Your guide was perfect. Everything occurred exactly as stated in this guide. I did have a few problems, all of them my own mistakes. Thanks again :)

    However, I did manage to brick my Inc shortly after. Well not bricked, but I got the 5 vibes of death at one point. Seems I deleted a file called mtd0.img from my sdcard. Didn't think it was important. However when I tried to update my superuser, it broke root. So went to boot into recovery to flash a nandroid, backup. That's when I got the 5 vibes of death. Phone wouldn't even turn on. Just 5 vibes and nothing. Couldn't even get to hboot. Luckily I had a copy of the mtd0.img on my pc. Plugged in charger, then I could turn on the phone again and it booted up completely. copied back the .img file, and the phone again booted into hboot. Got into CWR and restored my 2.2 nandroid, then flashed the the new 2.3.4 rom.

    So all's well that ends well.
    scotty85 likes this.
  4. redbean25

    redbean25 Member

    So...I have gained root access on my Droid Incredible, but I cannot do anything when I adb reboot to HBOOT. The buttons do nothing. The volume up/down buttons do nothing, and neither does the power button. In clockworkmod recovery I can use the volume buttons to select options and use the optical button to be enter. In HBOOT nothing works. Also when running normally, the Volume UP/DOWN buttons work, but my power button has been non-functional for a couple of weeks. I was hoping it was a software thing...but I believe my power button is not working at all.

    Is there a reason why no buttons would work at all in HBOOT mode??
  5. iowabowtech

    iowabowtech root@android:/ #

    This is very strange. I can understand the power button not working due to a hardware failure but the volume buttons working in CWM but not hboot is what bothers me. Never heard of a similar issue. My instinct says to reflash 0.92 hboot but in order to do that you'd have to load a PB31IMG in hboot and use volume up to load it...not a good combo in your situation. :confused:

    I honestly don't know what to suggest on this one.
  6. redbean25

    redbean25 Member

    Was quite a surprise to me as well...guess I am just stuck with the device as is. I would like to replace the button on the board for the power switch. Just have to find the replacement part and see if I can get one on digikey. Off to the solder station I suppose. Wish I could figure out why the volume keys stop working.
  7. scotty85

    scotty85 Guides Guide

    A couple things come to mind... You could reflash an ruu with the .92 hboot. That would prolly be the easiest,as you could just run a .exe file.

    If your s-off,you can use the .exe utility to flash just an hboot by finding "rom.zip" at the last second when running the utility and replace it with a Rom.zip that is just the hboot.

    Last and not least,you could flash an hboot with adb commands, or maybe in fastboot. Id have to check and see if the neccessary fastboot commands are useable with a normal-engineering bootloader.

    All that should work without working buttons :eek:
    iowabowtech likes this.
  8. redbean25

    redbean25 Member

    Not S-OFF yet. I got root access, and was trying the HBOOT part of the process when I ran into this issue. I'd need a bit of help finding an executable that will reload 0.92 of HBOOT. I'm relatively new to android development, so I don't have quite enough experience yet to know all the details. Thanks for the help and suggestions.
  9. phlyphish

    phlyphish Member

    This is a great thread. So far I've been able to get my 2.3.4 Dinc to root, but still have S-On, which is as far as I wanted to go.

    I was hoping to just delete bloatware and use a few root apps like wireless tether, Titanium backup, etc. and they work fine.

    However, I haven't been able to delete any bloatware. I'm no expert, but I'm guessing that the "Force remove app (by recovery exploit)" in Titanium backup doesn't work with the ClockWorkMod recovery.

    Anyone know for sure if that's the case? If so, is there some way to re-install the stock recovery and maintain root?

    Or is there some other way to remove bloatware. I thought I had understood from the instructions in this thread that just rooting and leaving s-on would still allow me to remove bloatware.

    Any insights would be appreciated. Thanks again for a great thread.
  10. timelord65

    timelord65 Well-Known Member

    I'm pretty sure you can delete bloat with s on

    the Titanium backup app, will remove bloat. You can either freeze or delete the apps. The pro version allows you to freeze bloatware, free version only deletes them. Freezing is best since you can defrost it if you need it again.
  11. today

    today Well-Known Member

    woohoo. works like a CHAMP. don't know what i did. but it was successful.appreciate the help from all involved in this endeavor. noob out.
  12. scotty85

    scotty85 Guides Guide

    So you are still on 2.3.4? You can downgrade without using hboot. You will just have to use a .exe for 2.2. Hopefully it will fix your hboot in the process. I believe Iowa linked an .exe a couple pages back.
    iowabowtech likes this.
  13. scotty85

    scotty85 Guides Guide

    iowabowtech and aaoaoo like this.
  14. hugoqzd123

    hugoqzd123 Member

    4.06.605.3 is not the latest version. I was having the same problem with that version. Verizon pushed update 4.08 afterwards but for some reason my phone would downloaded and not installed it. I update using the RUU in this link provided in this thread to Stock Images | PvilleComp's. This fixed the missing text problems.
  15. redbean25

    redbean25 Member

    Ok. Flashed to Froyo successfully in HBOOT. The volume keys now work. I lost root now though, so I suppose I have to start this process again to gain root back.
  16. aaoaoo

    aaoaoo New Member

    this worked for me. thanks a million for all your hard work.
  17. scotty85

    scotty85 Guides Guide

    root and s-off are easily gained on froyo by running unrevoked 3.32 :)

    glad your bolume keys are cooperating now.
    iowabowtech and redbean25 like this.
  18. redbean25

    redbean25 Member

    Yeah, I figured that would work now that I am not on the Gingerbread version. Thanks for the help. I'll try that again later this evening as I have to run out for a bit now.

    ...this is what happens when a Hardware guy tries to dive into software...:rolleyes:
    scotty85 likes this.
  19. gkinsella2

    gkinsella2 Member

    I'm following the zergRush method, but I'm getting a different md5 than the one provided. The one I'm getting is 55ac17ad7d8c93583f19afb9c1138dc2. I've scanned through the thread, haven't seen anyone mention this. I did download from the link provided. Is this just an updated version since this thread was started?
  20. gkinsella2

    gkinsella2 Member

    Nevermind...found the edit at the bottom of the zerg instructions...I'll just make sure the md5sum commands match
    scotty85 likes this.
  21. phlyphish

    phlyphish Member


  22. sdrawkcab25

    sdrawkcab25 Well-Known Member

    Buy the paid version of titanium and "freeze" apps you don't want. Or just press on the app you don't want and select "uninstall" in the free version. Lastly you can use adb to remove/disable apps.

    Be extremely careful when removing apps, it may have unintended consequences, so it is highly recommended to "freeze" apps with titanium so they can easily be restored. Otherwise make sure you have a good nandroid to return to.
    iowabowtech and scotty85 like this.
  23. scotty85

    scotty85 Guides Guide

    just to add a little more to what sdraw said,buy the paid titanium. its well worth the $$. in addition to being able to freeze apps first,it also lets you do batch backups and restores of your apps. if you have alot,it sucks big time to have to go thru and manually back up each one :eek:

    i have no idea about the clockwork option you mentioned,but the best way to get rid of bloat IMHO is:

    1)install free titanium.buy/install titanium pro key
    2) make a nandroid backup
    3) go thru and freeze everything you dont want.
    4)run the phone 2-3 days. if you have no issues,go back thru and "uninstall" everyting frozen. if an issue does pop up,you can go back and "melt" any apps that you suspect may be related.
    iowabowtech likes this.
  24. redbean25

    redbean25 Member

    Ok ...well just to update. I flashed the ROM to v2.2 Froyo, then ran unrevoked3 and rooted the phone and am S-OFF. I was then able to flash the ROM to Cyanogenmod7.1 and have it all set up. Finally, I got this device rolling. My power button no longer works, but that's only an issue with I get on a plane since I need it to turn the phone back on (I can turn it off via the software). Now it wakes from lock using the optical stick, so I don't need the NoLock and LockBot apps anymore for that functionality. I'll look into replacing that button one day, but for now I'm happy. Thanks for the help Scotty.
    scotty85 likes this.
  25. scotty85

    scotty85 Guides Guide

    awsome! thanks for the update. to deal with your power button prollem,you might look at the quickboot app. it has options to reboot,reboot to bootloader or recovery,and to power off.

    youll just need a way to turn it back on :eek: :D

    quickboot app
    iowabowtech likes this.
Thread Status:
Not open for further replies.

Share This Page