Hp TouchPad CM9 and CM7 Charging Problem *FIX*Tips


  1. JALStudios

    JALStudios Well-Known Member

    If you have an Hp Touchpad then you have probably went to a charging problem! When the red battery symbol with a lighting in the middle shows up for 1 sec and then goes to a charger symbol! I have experienced this a couple times my self! Read below on the different ways you can fix it!

    Method 1:
    Charger port (Not cable) has 2 parts! Unscrew them and reattach them!

    Method 2:
    Hold the Power Button (On Top Of Tablet) and the home button for 15 seconds!

    Method 3:
    Try using a different Micro-USB cord!

    Method 4:
    Connect to a different charger...(Make Sure It Is A USB 2.0)!

    Method 5:
    Try RE-FLASHING the Rom! Try using ClockWorkMod Recovery first. If that does not work then try using the ACMEInstaller!

    Method 6:
    Let the TouchPad sit for about a Week! So the battery can 100% drain! Usually when you run out of battery there is still about 5% left! Then try and charge it!

    The Hp TouchPad only charges on a 2.0 charger! It requires that for more charging power! It does not matter what kind of Micro-USB cord you have! When my charger went out (UNIT) I hooked it up in my car (Has USB Port) and it charged great!!!

    Leave a comment below if you are still having problems!

    Advertisement
  2. robzillaa

    robzillaa Member

    We have two modded touchpads with similar charging issues..the stock charger wont work on either and we have to use a touchstone to charge.. touchstone charges extemely slow 3 hours maybe gives it 30% charge at best.. plus the battery runs down very fast..

    I have tried the double reset mentioned to no avail.. i am very wary about opening this up to tighten some screws as I dont want to damage anything. I have never opened these up before. I think my computer is not USB 2.0 as I tried charging once and nothing happened.

    Any thoughts. This is driving me crazy
  3. lwb250

    lwb250 Active Member

    Not sure about the screws, but if you take the plug end of the charger and rotate it back and forth it re-establishes connections to the body. I don't recall it unscrewing, just rotating maybe 90 degrees or so - just twist it one way and back the other until it stops. Unless you're really ham-handed you won't break it.

    I don't know if this is some sort of reset or just opening and closing connections, but it seems to work in some instances.

    Since the Touchstone is inductive there is a "sweet spot" where it charges best. This is especially true if you have a case. I have a leather case on my 32GB TP and I have to be very precise about how I place my TP on the Touchstone to make sure it charges. With the TP turned on, try placing it in the Touchstone and making sure it's centered. You might even open up the Settings menu for the battery and see if moving it around just slightly changes the charging rate - I'll bet it does. If you have a case, take it off and see how quickly it charges that way.

    USB charging by plugging it into a USB 2.0 port is limited to 500 milliamps (half an amp.) Charging through the wall charger is 2.0 amps maximum. If you attempt to charge it through USB and use it at the same time you'll probably have a net loss, depending on what you are running at the time.

    Dan
  4. lwb250

    lwb250 Active Member

    With your Touchpad plugged in to the wall charger and charging in CM9, open the terminal emulator app and type su and tap enter. If it asks for super user permissions, allow it. Now type "cat /sys/power/charger/currentlimit" (without the quotes) and tap enter. Note: there is a space between cat and /sys. What result do you get?

    If it is charging correctly, you should get a report of 2000mA. What does yours say?

    Dan
  5. robzillaa

    robzillaa Member

    Ok.. so i tried twisting the plug.. it did twist and clicked in different position.. but it still doesnt charge the touchpad at all with the original charger..
    I entered your info with the touchpad on the touchstone.. the total came to 1400.. not 2000.. and I always center the pad and take it out of case to charge..
    We do not abuse are pads and dont get heavy use either..but its hard when they take forever to charge even 1/2 way..
    Rob
  6. colchiro

    colchiro Well-Known Member

    I doubt the touchstone is 100% efficient so I would expect a 2 amp charger to be less than 2 amps when it hits the battery.

    I gave my touchstone to my wife. I found it a bother, but she loves it.

    Do you have another device (phone?) you can charge with your TP charger? I use mine to charge everything since it's 2 amps.
  7. JALStudios

    JALStudios Well-Known Member

    Well would i would suggest now is buy another charger! If the touchstone at least charges it then you know that the TouchPad is not the problem! Also some cars have 2.0 USB ports that you could try! And pretty much any 2.0 USB will work with the TouchPad!


    Good Luck with trying to fix your TouchPad!:)
  8. lwb250

    lwb250 Active Member

    The charger that came with your Touchstone is the same as your stock charger. Have you tried using it to charge using your USB cable?
  9. colchiro

    colchiro Well-Known Member

    Not really. Ever hear of a bad usb connector? I had to replace my phone after 4 months due to that.
  10. robzillaa

    robzillaa Member

    So... i went to plug my tpad to my ps3 40 gb with 2.0 usb.. NOTHING.. it does s-l-o-w-l-y charge with touchstone, but I cant plug a touchstone charger into my USB port cuz its not built that way. Whats weird is that both connections should go bad about the same time?
    When you have a touchstone charger you dont use the side port on the pad (for those who didnt know). I dont know how to fix the connector and dont really want to take both in and pay for two fixes.
  11. binary visions

    binary visions Well-Known Member

    Most data USB ports (i.e. the one on your PS3 and the ones on your computer) will only output 500 mA. While I can successfully charge my Touchpad like that if I leave it overnight, it's outrageously slow and if you've got anything draining your TP at all, it might overwhelm the charger.

    If you plug your USB port into the computer, can you transfer data?
  12. colchiro

    colchiro Well-Known Member

    I assume you're in the US, so std 110 vac outlets?

    What about:

    Computer >> stock cable >> TP
    Different charger >> different cable >> TP
    Tried other outlets known to work?
    Test charging with webOS.

    Don't use a power strip, plug directly in the wall.

    Have you tried every other combination, even if you have to borrow a cable?

    It's easy to mess up a cable if you bend it at either end. My impression of the stock cable is it's not very durable.

    Through the process of elimination, you should be able to figure out exactly which is causing the problem:

    Bad cable
    Bad charger
    Bad outlet
    User error
    Problem with CM7/9
  13. lwb250

    lwb250 Active Member


    I fear there may have been some confusion when I suggested using the charger from the Touchstone. Just to be sure, the charger that comes with the Touchstone is exactly the same as the wall charger for the Touchpad.

    My suggestion was that you unplug the charger from the Touchstone and use it to attempt to charget the Touchpad.

    This would give you an idea as to whether the issue is a cable or a charger.
  14. robzillaa

    robzillaa Member

    Ok.. it appears that both my desktop and laptop do not have usb 2.0.. i tried charging but nothing appears when i plug in usb..now. the touchstone IS different.. one end has standard usb with plugs into wall outlet adapter.. the other end is concealed inside the touchstone holder which you place the pad into.. there is no option to unplug this end the way it is made. But I can try to use just the end piece of touchstone charger with my other reg charger.. i do have two regulation chargers which were both not charging at all or correctly.
    I live in the US, Orange County Ca, and really, really, do appreciate all your ideas to help me out. I love my modded touchpad like you good folks do as well. I can try plugging directly into wall, which might be problem here.. Let you guys know.. thanks again.

    Rob
  15. binary visions

    binary visions Well-Known Member

    Right. So take the wall outlet adapter, and unplug the Touchstone.

    Now take the Micro USB plug that came with the Touchpad, plug it into the wall outlet adapter, and plug it into your Touchpad. See if that starts charging it.
  16. robzillaa

    robzillaa Member

    Results are in.. tried charging directly into wall.. using touchstone wall plug with reg usb cord.. nothing.. using touchstone charger normally.. charges on both web OS and mod.. when i tried charging with different cords plug into the side.. no results at alll..
    also with touchstone wall plug combined with usb into side.. no charge..
  17. colchiro

    colchiro Well-Known Member

    You tried webOs with Touchstone, did you also check with CM7/9?

    When did this start?

    What rom are you running? (Settings...about...)

    I have seen reports of charging issues with CyanogenMod only... worked fine with webOS.

    The fact that's it's on both TP is disturbing. Do you update both about the same time usually?
  18. JALStudios

    JALStudios Well-Known Member

    Ok well I do have another way that may fix your problem!

    Try and RE-FLASH the Rom you are using! Go through all the steps on how to flash a Rom! I would try using the ClockWorkMod Recovery first but if it still does not work then try to use the ACMEInstaller!

    Sometimes there are errors with the Rom that could be messing up the charging!

    HOPE THIS WORKS!!! :bike:
  19. colchiro

    colchiro Well-Known Member

    That's why I suggested trying webOS.... already installed.
  20. robzillaa

    robzillaa Member

    Hi.. i had a friend do the modding for me.. and yes, both were done at the same time.. also, the usb charging port did not work on both web os and android.. it did work better this weekend by plugging touchstone directly into wall.
    One other issue.. is that the battery drains incredibly fast with the mod..probably cant go 4 hrs or more on full charge.. when i had web OS, it was at least 10-12 hrs of use.. i honestly dont use web os anymore so i cant say about the current use.. i will have my friend flash the rom to see if that works.. his touchpad seems to be working fine.
    Again.. thanks a million for the help.. at least i can get faster charging now directly into wall..
    Rob
  21. colchiro

    colchiro Well-Known Member

    Assuming you have cm9.... the latest nightlies would be a lot better than say a2 build.

    He needs to show you how to update. It's really not that hard.
  22. JALStudios

    JALStudios Well-Known Member

    You could also try and use a friends USB charger for your touchpad to see if the charger is the problem or the ROM!


    Good Luck!
  23. FJoeC2

    FJoeC2 New Member

    I thought I had bricked my CM9 Touchpad but it revived after 15 hours charging with wall charger.

    It died when I tried to reboot with USB cable connected to my PC.

    Curiously, my PC would recognize it as a Palm device even though it appeared dead. PC said I needed drivers, which I didn't try to install since I had no idea what would happen.
  24. JALStudios

    JALStudios Well-Known Member



    Well even though some computers show that it is charging it may not be charging! I usually get about 10 hours on one charge with the CM7 alpha 3 or CM9 Nightlies! So I would suggest trying to flash one of those! Also you could try MIUI! I heard from a lot of people that the MIUI rom was a good one!
  25. colchiro

    colchiro Well-Known Member

Share This Page