Kies / USB mode issueSupport


  1. SavageRobot

    SavageRobot Well-Known Member

    Hello Guys have got a bit of a problem that I have been reading through forums etc for fixes, have found some that looked promising but no luck so hoping a new thread will point me in the right direction.

    Basically for the last month or so when I try to connect my SGS2 to the computer to use Kies I get the message
    "Unsupported connection mode alert
    Reconnect the device in Samsung Kies (PC Studio)
    Mode.
    Current connection mode not supported by Kies."

    I wouldn't really care as Kies is rubbish in my opinion, and it is a lot easier and better to use the phone as a mass storage device, but I have been waiting patiently for the official ICS update and now it is finally landing I am unable to update without Kies.
    I have checked the usb debugging is not enabled, I have tried all solutions I can find (turn usb debugging on connect and let load drivers, unplug and turn usb debugging back off and try again),(uninstall and reinstall Kies), etc etc. There are a lot of things I have tried but nothing is working.
    Also I assume it is something to do with it, but I know I used to have 2 or 3 options when I go to Settings\Wireless & Networks\USB Utilities. But now there is only one, "USB Mass Storage".

    Any help would be great please as I can't wait to try the Icecreamy goodness :)

    Thanks in advance.

    Advertisement
  2. SavageRobot

    SavageRobot Well-Known Member

    Well there are quite a few views but still no ideas? Is nobody else having this same problem? Am I right in thinking that in Settings\Wireless & Networks\USB Utilities there should be two or three options? Does this look like a handset problem that means sending it to see its maker...and see if they will fix it under warranty?
  3. squirreluk

    squirreluk Active Member

    I had the same problem and was only able to sort it by installing another copy of phone software via odin. This got rid of the Kies issue allowing me to then update to official ics update via Kies.
    SavageRobot likes this.
  4. SavageRobot

    SavageRobot Well-Known Member

    Thanks for this sqirreluk, is this the odin...
    https://play.google.com/store/apps/...xLDEsImV1LmNoYWluZmlyZS5tb2JpbGVvZGluLnBybyJd
    if so what exactly is it I have to do? Only solution that there seems to be out there is to root the phone then? Been waiting patiently for official ICS because I didn't want to have to root the phone and possibly brick it, but if that is the only way I suppose I will have to take my chances. Did you think it was worth it? I see there are a lot of people with issues with the new firmware and my biggest issue with gingerbread is that my battery life sucks and don't think that can get any worse so...
  5. SavageRobot

    SavageRobot Well-Known Member

    Well I gave up searching, trying and hoping and resorted to the dreaded factory reset (obviously loosing all contacts etc because Kies wouldn't sync) and after a lot of *$!@ing around Kies finally recognized my phone, still no update for Orange though grr. Oh well at least it can now recognize it when it is rolled out...
    Samsung really need to work on their software playing nice with their devices because I have seen lo-ots of people having problems with this trying to find a cure.
  6. ironass

    ironass Well-Known Member

  7. chinthakaru

    chinthakaru Member

    I had the same problem till today. I just removed my SIM and connected to Kies.
    It was connected successfully.

    The thing i cant understand, My SIM was working with Gingerbrid. This problem only happened after ICS update.

    Regards
  8. bkkbob

    bkkbob New Member

    The current full version of Samsung Kies is the worst piece of software I've seen released to the public domain in 50 years. Forget about trying to make it connect, just use the USB Mass Storage mode to transfer files and use Kies Mini for the once in a decade Android software upgrades.

    I can't believe the software test and debug team at Samsung let this total piece of crap out in the wild.
  9. ajmount88

    ajmount88 Well-Known Member

    What I can't understand is how MyPhoneExplorer can be so much faster and more stable than Kies, even though it is supposed to work for any Android phone, from any manufacturer. Apart from an official method for upgrading, I'd recommend for anyone to use this for USB connection and Airdroid for wifi (instead of Kies Air).
  10. SavageRobot

    SavageRobot Well-Known Member

    Well, I thought it was too good to be true. Tried connecting a couple of days later and it didn't work again. This time though I am getting a different error message
    "Cannot start service on the device. Please disconnect and reconnect the device"
    Looks like I'm destined to stick with with Gingerbread.

    I think this link is dead.

    Hear hear, an absolute abomination. What is Kies mini then? is it just a Web based Kies? I can update through that?
  11. steve19800

    steve19800 Member

    Hello all,

    I just solved this problem on phone. Just go to setting and wireless n networks, at the usb option or usb connection, choose samsung kies instead of mass storage. Hope this helps
    ericdrewe likes this.
  12. fahdeen

    fahdeen Member

    Hi guys been here for sometime...
    i have the same problem after i updated my kies to the latest version 2.3.0.12035_16_4. Now the MTP driver just does not install even after following the following instructions from the link http://androidforums.com/samsung-ga...-galaxy-s-i9000-mtp-application-crashing.html
    and also other instructions from around the net!
    1) tried deleting samsung entirely from my drive including drivers and rebooted and then reinstalled. no hope!
    2) tried deleting all files with 16 characters from phone memory and sd card. still no hope!
    3) installed all drivers successfully via usb debugging mode and then after that i disabled usb debugging and connected it says MTP driver successfully installed but i have to restart my pc. when i restart it says MTP drivers installing and then it fails!!!!!! kies keeps saying connecting..........

    Same results at home (vista) and work (win 7 pro)!!!
    whats happening?????
    I'm in Qatar my phone details are as follows
    Model: GT-I9100
    PDA: I9100JPKJ2
    Phone: I9100XXKI4
    CSC: I9100OJPKJ1
    Android Version: 2.3.5
    Kernel Version: 2.6.35.7-I9100JPKJ2-CL655700 root@DELL143 #2

    Any ideas if i have ICS update? This is my first android phone bought it last july. I'm a bit nervous about updating via odin!
    any help anyone???
  13. ericdrewe

    ericdrewe New Member


    This worked for me Thanks
    :)
  14. LithoBlitho

    LithoBlitho New Member

    Hi all. I am having the same intermittent problem. it upgraded to the newest vwersion of Kies earlier this week, and also latest gingerbread version also and since then it is hit and miss if I can connect my phone. Nothing at all today apart from device cannot connect message. I tried to do the usb option solve but all it offers me is mass storage, and a button to link to mass storage, no other usb link option :( Any help or advice would be appreciated. Only want to connect to Kies to get the long awaited ICS update! Thanks

    Simon

    Edit - I don't know how, but the problem is now solved, running brand new ICS too!
  15. SavageRobot

    SavageRobot Well-Known Member

    Hi steve, thanks for the suggestion but as posted i thought i used to have a couple of options in the usb utilities but now only shows mass storage device (which sounds like what simons problem was too). The whisper in the wind is that the update for me is due on sunday so would like to get solved soon. steve any ideas why mine has no other options in usb utils.? Simon, do you have no idea what it was that worked for you? just worked by chance? Thanks for the help so far guys...
  16. LawrenceIdem

    LawrenceIdem New Member

    It's my duty to make sure no one else suffers as a result of the 'Failed to convert to upgrade mode' error during the Gingerbread to ICS upgrade. The information below will prevent you flashing your phone with Odin etc which could void your samsung warranty if done wrong (I have nothing against it btw)

    Prequisites
    You must use the latest version of Samsung Kies (2.3x)
    You must make sure the Laptop or PC you are using does not have any other connections except mouse and keyboard (My experience is its more reliable on a Laptop as mouse and keyboard are not using USB
    Go through the entire upgrade process leaving the phone connected via USB all the time until it completes - don't despair if it takes too long.

    N/B
    The main thing I noted was that when the phone reboots into download mode - A USB scan seems to happen in the background and the first USB connection encountered is assumed to be the phone. IF its another connected device - you are likely to get the error or the upgrade just fails

    This is harder to eliminate on a PC because USB Mice and Keyboards are often used. IF you have a PS2 (Round ended) Mice and Keyboards then the PC (without any USB connection other than the SGS2 connected) would be ok

    I hope this helps someone

    ICS Rocks
  17. fahdeen

    fahdeen Member

    solution anyone?????
  18. SycoCreation

    SycoCreation New Member

    Ive got the same problem, tried everything out there, spent ages scrolling through forums and nothing has worked :(
    Im using a Macbook pro and im unsure on how i can download the right drivers, I have tried direct from kies but that seems to do nothing...
  19. jorgeoviedof

    jorgeoviedof New Member

  20. asialove

    asialove New Member

    hello, did u solve the problems? what error message appeared? what is the model number of your Galaxy S 2, ?

    As far as i know, the AT & T Galaxy S2 (SGH-I777) is a little different with I9108 or I9100 S2 phones. The I1900 "connect with Kies mode" option is under "wireless & network"

    ---------------

    Android MTP or MCS ? The KIES/dubbing (ADB) use MTP , the Mass storage mode is using MCS.

    -------------------------------------------------
    Kies need following on your computer:

    .Net Framework 3.5 SP1*
    Windows Media Player 10 or later
    ActiveSync(Windows XP), Device Center (Windows Vista)
    DirectX 9.0C

    Microsoft Windows Mobile Device Center 6.1 for Windows Vista (32-bit) ]

    -----------------------------------------------------
    Choose the right usb connection mode:

    "Applications\Settings\Wireless and networks\USB settings" or "Applications\Settings\Wireless and networks\ " select "Kies Mode"

    ------------------------------------------------------
    Samsung Kies crashes on firmware update?

    1. Open windows explorer C:\Program Files\Samsung\Kies\External\FirmwareUpdate and search for *.config files. You should get one under folder names using your device id (EX. GT-P1000)
    2. Open the config file and remove the runtime version 4 and save it.
    before :
    <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" />
    <supportedRuntime version="v2.0.50727" />
    </startup>


    after :


    <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v2.0.50727" />
    </startup>

    3. Since the firmware upgrade downloads each time under this directory, it will replace the above config file, to avoid this mark the file as readonly. Just right click select properties, check the Readonly check box. This will prevent the firmware upgrade to replacing again with the old one.

    4. Now open Kies and upgrade the firmware :)

    ------------------

    Fix : Samsung Kies crashes on startup

    I download the Kies from Samsung site to sync with my tablet , but it simply not running on Windows 7 OS. After some research (like checking the event viewer) i got the root cause of the issue. The application is trying to use .Net framework 4.0, but it seems due to some issue in the framework it was not running, so i decided to change the application to use framework 2.0 instead of 4.0..guess what... it WORKED...So here are the steps to make it work :

    1. Open windows explorer and goto Kies installed directory (C:\Program Files\Samsung)
    2. Use Search box and type (*.config) which will show all the config files
    3. Edit each config file and check for the following code at bottom of the file :

    <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0" />
    <supportedRuntime version="v2.0.50727" />
    </startup>

    4. Remove the supportedRuntime version="v4.0" from the config files and keep only version 2.0

    <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v2.0.50727" />
    </startup>


    5. Now start the application, it should start with out any issues. If you upgrade the application you have to follow the above procedure after the upgrade.


    ---------------------------------
  21. asialove

    asialove New Member

    Download the android SDK tools from Google official, if you have MTP driver error
  22. fafaism

    fafaism New Member

    the computer and kies doesnt recognize the phone? ive tried everything and almost gave up on it and ive found out the only solution is this.

    go to setting - wireless and network - usb setting - media player.

    there u go, the phone is ready to be connected! then u go to my computer, find the phone icon then explore the folders in the phone. open media player and u can sincronize photos and music, sent them to your phone! desperated but it works for me!
  23. bcf

    bcf New Member

    Hi-

    Just go to settings ---> usb connection ---> choose ask on connection. Then select Kies on phone when prompted. Hope this helps.

    bcf
  24. Rizwan101

    Rizwan101 New Member


    This is the problem - How exactly do you so that please? When i go into usb mass storage i only get one option 'connect storage to pc'? please help.
  25. Chris0312

    Chris0312 New Member

    If you've already jumped through all the hoops i.e. uninstalling Kies, cleaning up the registry, etc., etc. Remember when you launch Kies to right click the Kies icon and select "Run as Administrator". Before you connect your device power down your phone and remove the battery. Reinstall the battery and restart the phone and then plug in the USB cable. Sounds simple, I know, but it's easy to forget to restart your phone after all the frustration dealing with Kies. What a piece of crap.

Share This Page