1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Root Samsung Galaxy Attain 4G?


  1. Havocx23

    Havocx23 Well-Known Member

    hey guys so i found out the attain has a built in 4g wifi hotspot feature, its just hidden by metro pcs

    if you download an app called "Quick Settings" by Halfbit you can find the 4g mobile hotspot setting... it works with xbox360, ps3, laptops other phones and is totally free and does not require root... its fast as hell and im using it right now to post on this forum on my laptop...

    you can connect up to 5 devices and if you are in a strong 4g area its even better then home internet

    im still looking for a root however need to get rid of this bloatware
  2. Havocx23

    Havocx23 Well-Known Member

    My girlfriends phone is the same way, its not active and we dont know why lol we kept from turning that mofo on but if yours is on. You can go into the My Extras app and turn off its notifications. Just uncheck the boxes! it saved me battery life and kept from those annoying full screen ads for those stupid apps that i don't need or want.

    once again the root of this phone still has my support. someone at a local repair center swears that he can root my phone. I dont believe him, but maybe one of you motivated types can look into it I couldnt get shit outta the guy... Thier website is www.1repaircenter.com

    :cool:
  3. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    if someone could be so kind as to click the webchat link and join the channel :)

    id like ot get some basic info :) make sure to say my name, if im around it will alert me
  4. Tokenpoke

    Tokenpoke Well-Known Member


    That wouldn't work... that would be equivalent to installing su from market without root.

    The privilege has not been granted so you would waste your time.
  5. Tokenpoke

    Tokenpoke Well-Known Member


    If he could he would be able to produce a rooted example...
  6. WileyECoyote

    WileyECoyote Member

    Update: Many, hours into this now, it's consuming me. After desperately flip-flopping on different kernel source trees, recently saw a shed of light. Bad seemed to only get worst the more I attempted to "fix" my phone. New revamped Kernel seems to have the most promise and is booting with most hardware seemly intact. When I started I did not know Samsung had removed "chunks" of their proprietary source before posting the "open-source". Naively downloaded, compiled and flashed. This was a big problem because they had already hacked the kernel src so badly and then to gut major portions of hacks and leaving old hacks from previous phones stranded in the code.

    If you have not already messed with the Boot, Recovery or System partitions, i.e. if you only tried installing a new kernel then I would recommend to leave those intact (for now). I (think) I am close to having full fsr file system with 2.6.35.14 kernel. Might have been easier to just reformat the darn thing to EXT4, and I have not ruled that out but there is just that drive, ya know? Heck, I'm so excited about being able to automatically log into root bash shell with custom boot logo, busybox and such, that I don't even care that the phone doesn't actually do anything useful! It's just a matter of time.
  7. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    yea the fsr drivers are lefgt out of samsungs rfs phones, so you cant mount rfs partitioons, rather cool of them eh? :p

    anyways if youve got kernel source booting then thats certainly a step, mind stopping by the irc? we can prolly get root by using your phone :p at the very least get cwm started
  8. WileyECoyote

    WileyECoyote Member

    not familiar with irc? is channel? would love some help but did not start with cm, used oem source and patched to 35.14. Definitely looking at cm and hoping to build GB-r3 once kernel is stabilized. (Actually it's already built but have not attempted zygote.)

    There is more good news: j4fs.ko and fsr.ko are initializing. Just now got BML's, still need STL for 3 partitions.

    fsr_stl.ko had the same load errors as fsr.ko but now fsr.ko loads okay and fsr_stl locks-up, bummer. Just starting to check into this.
  9. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    if you click teh link in my sig (it only displays once per page) youll find teh chatroom where we sit in, we may not always be around but say one of our names and if we are we will reply.

    in the meantime, could you do this?

    adb shell dd if=/dev/block/stl10 of=/sdcard/factoryfs.rfs

    and upload that rfs file for us? i can use that to pre-root it, flash it on someone elses phone and grab a stock kernel.. from there on we own the phone ;). not even an ota will block root
  10. k0nane

    k0nane Well-Known Member Developer

    Let's get some people in the IRC channel, folks.
  11. skinlab

    skinlab Well-Known Member

    Man, I am so stoked that the big dogs are in on this cool little phone finally.
  12. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    if WileyECoyote will give us the factoryfs.rfs we can move onto phase 2, or if he is strapped for time etc, if he could provide the kernel he made then we can work from that :D
  13. skinlab

    skinlab Well-Known Member

    So Shabby, if I do the adb shelldd if=/dev/block/stl10 of=/sdcard/factoryfs.rfs command for you,will it be the same? And if so, where would i upload it to?
  14. k0nane

    k0nane Well-Known Member Developer

    It will not work without some kind of root access, which you do not have. So this is not for you.

    Now, if you need somewhere to upload files, you want Dropbox. (Click that and you get an extra 250mb space on signup.) It's awesome.
  15. skinlab

    skinlab Well-Known Member

    Thanks for the info k0nane. I have the 3 gig Dropbox. I should have thought of that.
  16. WileyECoyote

    WileyECoyote Member

    During my second semester of at the school of hard knock, I screwed up the factoryfs.rfs image. Attempting to recreate this now on device the /dev/block/stl10 partition is mounting. only the j4fs (which used to work) is not mounting. The factoryfs.rfs image that I am creating is not exactly the oem version. (and i am not entirely sure how much of the hardware subsystems are operable in the kernel - is still early going) but I am willing to share what I have!

    All I have now is a booting kernel zImage but the init.rc does not load zygote. Had to use several oem.ko's and change vermagic because generated versions either locked up (fsr_stl.ko) or were too large to be usable (rfs_fat.ko and rfs_glue.ko). The objects appear to have been compiled with full debug and are too bloated to fit within the 7.8'ish initramfs partition. Will update later this evening.
  17. WileyECoyote

    WileyECoyote Member

    update: major progress - Android Gingerbread CM installed on rfs, aka oem file system, be /dev/block/stl10 and reboots still gets root bash prompt, with bash reading config from /system/etc. Going to tweak init.rc to see if the Dalvik core will startup.
  18. johnnyl1111

    johnnyl1111 Well-Known Member

    still no root. i guess the devs met their match.
  19. k0nane

    k0nane Well-Known Member Developer

    Hardly - we're just waiting.
  20. ChiweN

    ChiweN Well-Known Member Contributor

    No. We have 2 great devs.. k0nane and shabby willing to root us.. they don't have the device though, therefore they are waiting on one of us to help them help us. I try to find the time but things are crazy with college finals right now.
  21. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

    ok well all iw as hoping for was an image we could use to preload root onto and flash via odin. since we arent getting that then i guess we need some brave souls in the irc channel ready to test some stuff.
  22. rootattainpls

    rootattainpls Member

    Im ready and willing to test. Just tell me what I need to do. Not sure how to get on the irc channel though
  23. OrKo

    OrKo Well-Known Member

    My girl has this phone so I'm in as well..
  24. Shabbypenguin

    Shabbypenguin Well-Known Member Developer

  25. Tokenpoke

    Tokenpoke Well-Known Member


    Shabs, irc comes in weird on mobile web browser... if there is anything I can do to help w/o PC I can help anytime gtalk Secondgenmonkey
Loading...

Share This Page