Telus Galaxy S2 (T989D) Ultimate Root and Optimization Guide with Steps


Last Updated: 2014-02-21 07:20:00
  1. freelancer24

    freelancer24 New Member

    Hey Guys,

    This is a great guide I stumbled upon! I received SGS2X from TELUS and got a SIM unlock from cellunlocker to use with Mobilicity and it worked fine - My question is will my phone/sim retain this unlock after a new ROM or a root?

    If not will i be able to unlock again with same code? TIA Guys and Happy New Year!

    Cheers!

    Advertisement
  2. Blue1k

    Blue1k Well-Known Member

    Yup. Sim unlocks are permanent.

    Glad my guide was of help. Cheers :)
  3. andruoid

    andruoid Well-Known Member

    I followed the instructions to a T ...and everything worked ;) I'm probably going to try Mr. X's ROM as suggested but before I do can you recommend a stable ASOP ROM? I miss the simple look of ASOP more that I thought! Thanks :D

    ***edit;
    BTW, in Step 12 when I flashed su-3.0.5-efgh-signed.zip I got the 'Install Aborted'. I rebooted anyway and found I was indeed rooted. Maybe it was trying to fake me out ;-)
  4. creesh

    creesh Member


    How long did it take for you until u got the unlock code ? i sent over a request since yesterday and today i received an email that they need more information about my phone ? what was the website you ordered the code ? Does Samsung Galaxy s2x work on Mobilicity ? i was there and asked them if my phone would work with that carrier and they said that i won't work because they are built in different frequencies ??? no clue what he meant but anyways...
  5. Blue1k

    Blue1k Well-Known Member

    I use mobileincanada.com for my unlocking needs. They definitely unlock the Telus S2. You only need to provide the IMEI number.

    LOL @ Mobilicity guy. The phone has AWS bands and will work on that network. They either lied to you to buy one of their phones or they had no clue.
  6. creesh

    creesh Member


    He was Chinese..no offence but it was hard to understand him what he meant but what i understood was that it does not work :D so the telus phone will work on mobilicity ?

    For the unlock code i will wait until tomorrow and if i dont get anything from cellunlockednow.com than i will try mobileincanada.com

    How long does it take to get a code from mobileincanada ?
  7. Blue1k

    Blue1k Well-Known Member

    Yes it works. The guy must not know that the Telus variant is exactly the same as the T-Mobile version. T-mobile and Mobilicity both use AWS bands The telus S2 and tmobile s2 works on Wind and Mobilicity.

    The only issue is selecting the network. Seems to be an issue with mobilicity. To help with this you can manually select which network you want by:

    dial *#*#2263#*#*, select "WCDMA Band Preference", and then select "WCDMA 1700" so that the phone looks by default in the 1700 band (AWS)


    Mobileincanada can take anywhere from 4hours to 24 hours. They have a current wait time on their site.

    Cheers!
    creesh likes this.
  8. creesh

    creesh Member

    Thanks mate :)
  9. slogged

    slogged New Member

    I had this error:

    E:Error in /sdcard/su-3.0.5-efgh-signed.zip
    (Status 0)
    Installation aborted.

    I resolved it with CWM by doing Advanced-->Fix Permissions. After doing that I was able to install without error.
    Blue1k likes this.
  10. Blue1k

    Blue1k Well-Known Member

    Thank you! I was wondering why sometimes there was issue after the odin flash. I will add this to my instructions.:D
  11. creesh

    creesh Member

    Hey guys,

    I was unable to unlock my phone..the guys from cellunlockednow.com were not able to and now i am waiting for the refund.
    I ordered a code now from mobileincanada.com and still waiting for the code

    Any ideas why it might be that it is giving them such a hard time to find my code ?
    Is there any other website where i can try ?
  12. Blue1k

    Blue1k Well-Known Member

    I had the same issue with cellularunlocker. Mobileincanada is great. I usually wait about half a day with them depending on how busy the server is.

    Haven't really tried any other sites as movileincanada always comes through for me.
  13. slogged

    slogged New Member

    Thanks for this, I made a small donation. Please keep updating this with what's possible on a rooted Telus S2 X!
  14. Blue1k

    Blue1k Well-Known Member


    Thanks so much! I'll update the thread this weekend with some newer roms and stuff I've tried.
  15. creesh

    creesh Member


    Guesss whatt?? mobileincanada.com just came back at me with the code..yuhuuuu:D
    i will try the code once i am done with work :)
  16. andruoid

    andruoid Well-Known Member

    NM, morning brain failure.
  17. andruoid

    andruoid Well-Known Member

    Just to test the returning to stock method. After a successful stock flash via Odin I got caught in a boot-loop. The 'S' logo at boot runs for a few seconds, then returns to the 'Samsung Galaxy SII T989D' then back to the 'S' logo again, etc, etc. Any ideas why?

    To add; I was able to reflash Mr. X's Telus ROM and have a working phone again so at least I don't have a brick.

    I followed your instructions below:

    Steps:

    1. To install the stock rom file you will need to first extract it. Use the password above
    2. Launch Odin. Press PDA and Select the stock recovery file (tar.md5 file) folder you extracted. Make sure re-partition is NOT selected (see the pic above).
    3. Restart your phone in download mode as before (see above how to do this) and wait for the yellow com
    4. Press Start and flash back the phone to original state
    Blue1k likes this.
  18. Blue1k

    Blue1k Well-Known Member

    I think it is because the rom is not over writing the Mr.x ciq free kernel. I'll look into this. That, or a full wipe is needed before the odin flash back to stock.

    Either way, I'll find a solution.
    Thanks for the feedback
    andruoid likes this.
  19. andruoid

    andruoid Well-Known Member

    I'll try a full wipe in CWM myself if you like, I should have thought of that as well! I'll report back sometime after dinner tonight :)
  20. andruoid

    andruoid Well-Known Member

    Beautiful. Thanks BlueK1 for the wipe suggestion. What I had to do to get stock recovery:

    1. Boot into CWM and wipe everything (I did, just to be sure):
    /cache
    /data
    /system
    /emmc
    &
    /dalvik

    2. on phone: power off from within CWM
    3. on computer: start Odin, click on and check PDA, load the MD5 file (don't hit Start yet)
    4. on phone: volume down + power on phone to get to the download screen, once at that screen, volume up to confirm. Plug in phone to computer.
    5. on computer: click Start in Odin
    6. on chair: sit back ...or in kitchen (preferred): grab a bevy of your choice and wait for the flashing to complete. :)
    7. (optional and recommended) re-root cause you'll miss certain apps that require it ;-)
    Oldschoolwax and Blue1k like this.
  21. Blue1k

    Blue1k Well-Known Member

    Thanks man! Glad it worked out. I'll add this to my guide.
    andruoid likes this.
  22. andruoid

    andruoid Well-Known Member

    Another quick note about the Stock ROM restore. If you intend on keeping the stock ROM delete the USB drivers and Samsung Kies, reboot your computer and reinstall Samsung Kies.

    Before I did the above Samsung Kies reported that I can not do firmware updates.

    Everything else seems good to go now. I myself will re-root now that I know everything to unroot is all good.
  23. troymc8

    troymc8 New Member

    I just wanted to say thank you Blue1k. I just bought the Samsung phone from Telus, and I will be rooting it this weekend!
    Thanks!
  24. ent007

    ent007 New Member

    Hey Blue1K, thanks! I just made a donation from Nick Bains.

    Cheers
  25. ent007

    ent007 New Member

    Hey all, is there any other apps that I should freeze that are bloatware?

Share This Page