The "Linux questions (and other stuff)" thread


Last Updated:

  1. MoodyBlues

    MoodyBlues - Crazy peacock person -

    VLC is my go-to multimedia app. It just works. I can throw virtually any file type at it and it just works. I like that. :)

    Advertisement
  2. saptech

    saptech Well-Known Member

    You're late to the VLC party. I've used it on all my computers from Windows, Linux, and Macs. Since I have had all 3 OSes, I like using the same software with all, VLC, Firefox, Thunderbird etc. They all are mostly open source.
  3. argedion

    argedion The TechnoFrog Moderator

    Actually I've been using VLC for several years now Started in OpenSuse 8 or 9
  4. nickdalzell

    nickdalzell Well-Known Member Contributor

    issue never comes up in terminal. sudo apt-get install works fine. must be a software center bug. it happened just after updating this morning...

    temporarily solved by changing permissions to software center. now i don't need root to use it.
  5. mikedt

    mikedt 你好 Guide

    Been trying Clementine today, I do like it so far. Thanks for that one Nick. :) Amarok worked for me, but it just seemed very bloated and had a lot of unecessary stuff that I didn't need.

    If it wouldn't play MP3s, but if did play Ogg Vorbis, could have been because it didn't include patented non-free codecs. I know with Ubuntu you usually have to install these additionally. I think it just involves ticking a box stating that you wish to download and use non-free patent encumbered codecs, like MP3.
  6. mikedt

    mikedt 你好 Guide

    "software center" are you referring to Synaptic? I usually run that from the Lancelot launcher on my systems, and immediately I have to enter the root password as it does require root. otherwise it just wont run at all. "sudo apt-get install" should always work whatever happens I think.
  7. Speed Daemon

    Speed Daemon Disabled

    Yep. When I did an upgrade from KDE3, it left things behind in the .ked directory, but used the .ked4 directory. When I did a clean install of KDE4, there was no .kde directory, only the .kde4 one. Hence my point.
  8. Speed Daemon

    Speed Daemon Disabled

    I even get to use GKrellM on Windows. Life is good...
  9. MoodyBlues

    MoodyBlues - Crazy peacock person -

    I can't remember how things were arranged in KDE3. All I remember about KDE3 was that I threw a hissy fit when KDE4 came out. It was buggy, bloated, and a huge disappointment from KDE3. Wow, that seems like a lifetime ago. I LOVE KDE4 now. They got the bugs out, they made it fast, functional, beautiful, and my oh-so-important feature, totally customizable.

    At any rate, I only have ~/.kde directories, both on my Kubuntu boxes and the Bodhi box I'm typing this on; no sign whatsoever of ~/.kde4 directories.
    Speed Daemon likes this.
  10. nickdalzell

    nickdalzell Well-Known Member Contributor

    That's just it. It no longer prompts me for the password post-update. It just sits there and then gives me the error I posted. Tried rebooting same thing. The muon software center does it, too, seems to be affecting root permissions in KDE only. I can launch either in a terminal with sudo and it will work though. Also changing the permissions of the program seems to have solved it, albeit in an unapproved fashion
  11. MoodyBlues

    MoodyBlues - Crazy peacock person -

    So AFTER you did what I said and logged back in with KDE it STILL didn't work? :confused:
  12. nickdalzell

    nickdalzell Well-Known Member Contributor

    KDE worked but anything requiring root password prompts did not. When I would normally get prompted to enter the password the prompt no longer appears, and then the application in question complains about missing root permissions and either exits or doesn't allow me to do anything. Terminal is unaffected. I can launch any offending app with sudo in a terminal or change its permissions and it works fine. Whatever program is displaying the password prompt no longer seems to function. It does however work perfectly fine in Unity. This bug has only started just after the post-update restart. I have a feeling that the software update broke some things.

    EDIT: seems to be a failure in Policy Kit, whatever that is, only a problem in KDE not in any other DE.
  13. xstefen

    xstefen Well-Known Member

    FYI, installed Kubuntu 12.10, did lots of software source updating and getting some apps. Getting used to KDE functionality but this is very nice, thanks for your recommendation. Got my full android build enviroment setup and other daily apps, all is well, thanks
  14. saptech

    saptech Well-Known Member

    Earlier I logged into KDE 4.10 under the wife's username, which is like the second account setup, mine being first. I think that makes me uid 500. Anyway for some reason there is no sound under her name. Playing mp3s or youtube does not have any sound.

    Sound does work on my account and this is the first time I noticed it not working on her's.

    I'm at work now and can get more info later this morning if need, but any ideas what could be going on with this? I can check to see if she's in the audio group.

    Thnx.
  15. Dngrsone

    Dngrsone Well-Known Member

    I must say, thank you Ubuntu, for telling me that which Vista can't seem to figure out; namely that my hard drive is failing and that is why I can't perform a system restore.

    I mean, seriously-- I spent two days working on this thing trying to figure out why Vista wouldn't boot up, and all it took was booting to Ubuntu Live! to learn that the drive was dying.

    Hell, the thing is only five years old... :rolleyes:
  16. Speed Daemon

    Speed Daemon Disabled

    That would be the first thing that I'd check, making sure that she has permissions to use the sound device(s) and that the sound device(s) in /dev have the corresponding ownership settings. If /dev/dsp is owned by "root:root" then setting an account to be a member of the "audio" or "sound" group isn't going to help any.

    If you chose an option that made your (presumably first) user account the one with administrator privileges, that might explain why your account can access the sound system, and your wife's can't, you misogynist! ;) j/k

    BTW, I've noticed that the UID numbers for meatware tend to start at 1000 these days. I guess they are growing the number of system groups!
  17. nickdalzell

    nickdalzell Well-Known Member Contributor

    FYI my Policy Kit issue seems to have fixed itself, whether or not it had to do with my changing permissions to the home folder or not I have no idea
  18. saptech

    saptech Well-Known Member

    Thanks for the reply. I'll have to check into this another time, since the grandkids have been spending the nights, I'm not able to get to the computer.

    I'll keep you all informed.
  19. Speed Daemon

    Speed Daemon Disabled

    :rofl: That might be the best unintentionally hilarious reply I've read all year! Have lots of fun with the grandkids! :D
  20. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    So, in the process of migrating my linux install to a VM, the permissions changed. Quite simply, I can't log into the system in question other than booting the vm from the iso image and chrooting after mounting the partitions.

    The OS is Archlinux.

    Steps that got me here:

    1. rsync backup of the computer (excluding certain things)
    2. Attempted to mount the drive I backed up to on VirtualBox. Didn't work at all
    3. Created a new VM in Hyper-V and added the VHD and the physical drive
    4. rsync restore of the backup to the VHD
    5. Booted with VirtualBox
    6. Reinstalled Grub, installed virtualbox guest additions (through pacman)
    7. adjusted fstab and regenerated the initramfs (mkinitcpio -p linux)
    8. exited chroot and poweroff.
    9. Start the VM up again and attempt to log in
    10. authentication failure and plain refusal to login as my user or root
    11. Boot into iso, mount partitions, chroot, ls -l

    ls -l shows all of the directories at / (except /dev /lost+found /proc and /sys) having rwxrwxrwx (777) which I assume is the problem.

    lost+found has 700
    the other three exceptions have 755
  21. MoodyBlues

    MoodyBlues - Crazy peacock person -

    I really can't help much because I've never run Linux in a VM. So I'll leave that aspect to someone else.

    Here's my / on the Kubuntu laptop I'm typing this on:

    Code (Text):
    1.  
    2. drwxr-xr-x   2 root root  4096 2012-11-06 19:52 bin
    3. drwxr-xr-x   3 root root  4096 2012-11-06 19:57 boot
    4. drwxr-xr-x   3 root root  4096 2011-10-07 07:55 build
    5. drwxr-xr-x   2 root root  4096 2011-09-15 19:45 cdrom
    6. -rw-r--r--   1 root root     0 2011-09-19 13:29 computer_HPdv7
    7. drwxrwxrwx   9 root root  4096 2013-02-08 12:12 data
    8. drwxr-xr-x  20 root root  4360 2013-02-27 16:58 dev
    9. drwxr-xr-x 197 root root 12288 2013-02-27 10:40 etc
    10. drwxr-xr-x   9 root root  4096 2012-10-19 19:30 home
    11. lrwxrwxrwx   1 root root    37 2012-11-06 19:57 initrd.img -> boot/initrd.img-2.6.38-16-generic-pae
    12. lrwxrwxrwx   1 root root    37 2011-12-04 21:32 initrd.img.old -> boot/initrd.img-2.6.38-13-generic-pae
    13. drwxr-xr-x  20 root root  4096 2012-11-06 19:55 lib
    14. drwx------   2 root root 16384 2011-09-15 19:36 lost+found
    15. drwxr-xr-x   2 root root  4096 2013-02-05 22:34 media
    16. drwxr-xr-x   6 root root  4096 2011-11-03 23:44 mnt
    17. drwxr-xr-x   4 root root  4096 2013-01-05 14:01 opt
    18. dr-xr-xr-x 185 root root     0 2013-02-27 10:31 proc
    19. drwx------  38 root root  4096 2013-02-07 14:34 root
    20. drwxr-xr-x   2 root root  4096 2012-11-06 19:52 sbin
    21. drwxr-xr-x   2 root root  4096 2011-03-21 01:26 selinux
    22. drwxr-xr-x   3 root root  4096 2011-09-18 00:41 srv
    23. drwxr-xr-x  13 root root     0 2013-02-27 10:31 sys
    24. drwxrwxrwt  17 root root  4096 2013-02-28 11:44 tmp
    25. drwxr-xr-x  12 root root  4096 2011-09-17 15:36 usr
    26. drwxr-xr-x  17 root root  4096 2012-10-19 19:30 var
    27. lrwxrwxrwx   1 root root    34 2012-11-06 19:57 vmlinuz -> boot/vmlinuz-2.6.38-16-generic-pae
    28. lrwxrwxrwx   1 root root    34 2011-12-04 21:32 vmlinuz.old -> boot/vmlinuz-2.6.38-13-generic-pae
    As you can see, nothing's 777 except /data (which is a partition I always install, and want to have set to 777) and /tmp. My /proc is 555, while yours is 755; my /dev and /sys are 755 like yours; my /lost+found is 700 like yours.

    Perhaps adjusting your permissions to match mine will help...or not. Like I said, I have absolutely no experience with running Linux in a VM.
  22. Dngrsone

    Dngrsone Well-Known Member

    Running Linux on a VM should be no different except the machine is slower and networking can be a little difficult.
  23. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    I'm actually going to try to retake the backup following this guide. When I originally took the backup, I had no idea what I was going to do with it, whether to restore to a VM or an actual PC
  24. saptech

    saptech Well-Known Member

    Welp, it seems the 3 yr. old grandson has played with the power button so much that it is not turning on anymore. My C2D system will not turn on when pressing the power button. It has two lights near the button, one for power & other for hard drive. One lights up normally but the other one looks dim when trying to boot. I think I can hear the hard drive power up but die out also.

    Any ideas/suggestions about this?

    Thnx.
  25. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Update: ended up using clonezilla to backup and restore. Got it running after a few necessary changes
    argedion likes this.

Share This Page