Root Unbrick Phone from LG Screen

Discussion in 'Android Devices' started by joneidy, Jun 27, 2011.

  1. joneidy

    joneidy Well-Known Member
    88

    Jan 15, 2011
    307
    376
    88
    Computer Technician; Currently Developing for Andr
    Methuen, MA

    Hahaha yeah I had to. But basically I didn't. I bricked my first Optimus a while ago and one day messing around with key combinations I found this trick. And so far its working for everyone else. Lol
     

    Advertisement

  2. Mikenly

    Mikenly Well-Known Member
    43

    May 22, 2011
    139
    34
    43
    Male
    Student
    Miami, Florida

    Haha scary stuff there and thanks for this. Now there's no way for noobs to really destroy their phone from the inside out without it being able to be fixed.
     
  3. jay239

    jay239 Active Member
    16

    May 8, 2011
    29
    1
    16
    I need help i think i bricked my phone :( when it starts up it says LG and then it says Fastboot mode started udc () or something like that what do i do???
     
  4. jay239

    jay239 Active Member
    16

    May 8, 2011
    29
    1
    16
    I downloaded that file and when i try to instal LGNPST it says failed to load Skin.dll?

    does anybody know what that means? please help?
     
  5. playnex

    playnex Member
    6

    Jul 21, 2011
    8
    2
    6
    im having the same issue. But i have VS740.dll file. What do i do with it?
     
  6. jay239

    jay239 Active Member
    16

    May 8, 2011
    29
    1
    16
    im not sure what in the world it means
     
  7. playnex

    playnex Member
    6

    Jul 21, 2011
    8
    2
    6
    Does anyone know how to get the dll in the box on lgnpst.exe. I got the bin. But when i click the folder to choose my dll file. Theres nothing in the box. What do i do?
     
  8. playnex

    playnex Member
    6

    Jul 21, 2011
    8
    2
    6
    Okay. i Deleted everything and i started from square 1 all over again. Now Lgnpst.exe regonizes the .dll file & the .bin file. But when i click start... It then says everything will be deleted, i click okay, Then it immediatley says Finished. Then it says Sub proccesing ERRor. What did i do wrong? Im going to delete everything again and see if it helps to do it again. But please...What am i doing wrong?

    okay, i did the whole process again, Nothing changed... sadly... still need help.
     
  9. avira

    avira New Member
    5

    Jul 21, 2011
    4
    0
    5
    I have the same problem
     
  10. rontron

    rontron Member
    16

    Jul 23, 2011
    11
    1
    16
    Dial *228 then press 5 to update your Preferred Roaming List and this should reset any changes that were made to the settings when it got bricked. See if that helps

    If your phone's MEID were changed to all zeros during the emergency recovery which you can check by going into Settings > About Phone > Status. Then you have to change your MEID back to it's original one by following this guide.
     
  11. realety

    realety New Member
    5

    Jan 2, 2011
    1
    0
    5
    When I push all the buttons and then plug in. The LGNPSt takes me to the phone book recovery screen. It doesnt give me the option to load the bin file. What am I doing wrong?
     
  12. MistaWinehouse

    5

    Jul 24, 2011
    9
    0
    5
    Will this work is flash_image was used and caused the problem?
    I had crossed the names during the command of:
    "flash_image recovery /sdcard/<CUSTOM RECOVERY IMG>"

    with a .zip file (the ROM file instead of the custom recovery file) and now it boots up with:
    astboot mode started
    udc_start()
    -- suspend --
    -- reset --
    -- portchange --
    fastbook; processing commands

    Will this process work for this issue?

    Thanks in advance!
     
  13. lgfreak13

    lgfreak13 New Member
    5

    Jul 25, 2011
    2
    0
    5
    the steps didnt work for me can someone help me please . my phone is still on s/w upgrade mode .
     
  14. joneidy

    joneidy Well-Known Member
    88

    Jan 15, 2011
    307
    376
    88
    Computer Technician; Currently Developing for Andr
    Methuen, MA
    I just sent you a pm. Take a look at it. LOL
     
  15. aovaici

    aovaici Well-Known Member
    16

    Jul 21, 2011
    52
    6
    16
    I do the register thing, but there is no DLL to select, I dont get it :(
     
  16. aovaici

    aovaici Well-Known Member
    16

    Jul 21, 2011
    52
    6
    16
    Hm, REFUSED to show up on my desktop, showed up first try on my laptop, go figure. Going to try and recover now :( Wish me luck.
     
  17. aovaici

    aovaici Well-Known Member
    16

    Jul 21, 2011
    52
    6
    16
    Finally, fixed it, wow, what a pain in the pass.
     
  18. aovaici

    aovaici Well-Known Member
    16

    Jul 21, 2011
    52
    6
    16
    Okay guys, I just did this whole deal so I thought I would try to help and retype everything a bit since it's a VERY pain in the ass process if you have to go through the whole ordeal, first, you DONT need to let the battery run down all the way...

    1) Popout the battery leaving one end of your power cord plugged into computer or charger and the other end ready to plugin to the phone.

    2) Holddown Vol Down + Back key + Camera + Power buttons, like mentioned above, and while holding those keys plugin the other end of the cord into the phone, the phone should boot into S/W Screen. Let go of the buttons and pop the battery back in.

    3) Restore Like mentioned in original post.

    4) Check for service.. if you are lucky, you are done. Otherwise continue.

    5) Go to Settings --> About Phone --> Check to see if your MEID is there.. Follow the guide posted above or the link below if your MEID is a bunch of zeros.

    http://androidforums.com/optimus-m-...-restore-service-if-youve-lost-your-meid.html

    6) Check for service, if done, they yay :D, otherwise you need to call metropcs on another phone and ask them to help you manually program the phone.

    7) Restart / check for service. If fail dial *228 then option 5 and you SHOULD be good to go. This is what I had to do, FINALLY got service :( If wanted, you CAN reroot :D I did.


    ***) If all else fails and you are still under warranty go to metropcs corporate store and claim "you called up *228 and try to update the roaming list and your phone randomly crashed after you got the message that updating of the roaming list failed" and they should replace your phone. They did it with me, but I got it fixed before needing it.
     
    asheehanjr, puyow18 and somedood81 like this.
  19. Allebb

    Allebb New Member
    6

    Jul 29, 2011
    3
    2
    6
    Hello! First post, long time reader :)


    for those that cant select the dll file:

    ~open cmd window (start menu and type cmd in search box) then right click and run as admin

    ~type in (or paste) regsvr32 "C:\LG Electronics\LGNPST\Model\MTP\MS690.dll" (if that is your path, if not, change it accordingly)

    ~open LGNPST, and your file should be in there.



    Hope this helps
     
    victor e and reddarin like this.
  20. drummerguy123

    drummerguy123 New Member
    5

    Jul 28, 2011
    2
    0
    5
    So...I have the lg phoenix and it does not have a camera button. Any idea what I should do??
     
  21. lonDetGirl2011

    15

    Jul 29, 2011
    13
    0
    15
    Michigan
    hi well everything is good till i try to use LGNPST, it says cant load skin dll. i have redownloaded twice now, same thing. what is it that i'm doing wrong.
     
  22. shamx

    shamx Active Member
    16

    Jul 5, 2011
    35
    5
    16
    Student

    The Phoenix is an att version, since it doesn't have a camera button the sequence must be another combination to get to the s/w mode. You should try the other physical buttons. Also not sure if this method is universal for the entire optimistic one lineup tho :/
     
  23. voiceoverguy70

    5

    Jul 31, 2011
    7
    0
    5
    i have tried this and my phone screen still stays frozen.
     
  24. drummerguy123

    drummerguy123 New Member
    5

    Jul 28, 2011
    2
    0
    5
    I think i figured out the button combination (up + back + power) but now i am having troubles unzipping the f.bin file. I have 7 zip but it won't unzip it into a .bin file....
     
  25. ysehak

    ysehak Member
    16

    Aug 4, 2011
    10
    1
    16
    LGNPST says i need a spc code and cdma workshop is saying my phone is not answering please help!!!
     
Tags:

Share This Page

Loading...