USB will charge phone when plugged in but will not recognize it as a deviceGeneral


Last Updated:

  1. meganelizabeth

    meganelizabeth New Member

    USB will charge phone when plugged into PC but will not recognize it as a device. I am guessing it is something wrong with my computer but I can't figure it out. I have done this before when I first got this phone and it worked. Plugged the USB in and it recognized it. But this time it will only charge it and will not give me the USB Connection option in the status bar. Downloaded Motorola Driver but after rebooting, that still didn't fix it. Please help!

    Advertisement
  2. Thom

    Thom Guides Guide

    Are you using the USB cable that came with your Bionic? If not try it.

    What USB port are you using? Try using a USB port on the back of your PC as a test. Try some of the other USB ports.

    When you plug in your Bionic you should get a sound from your PC and if it is enabled you will also get a sound from your Bionic.

    ... Thom
  3. Rush

    Rush {<>}~{<>}

    Hello and welcome to the forums. I'm assuming that your PC is running the most recent version of Java.

    Make sure you have the correct settings enabled on your device. Some device comes with "charge only" as the default settings, and usually need to be change to the correct settings for that purpose.
  4. Thom

    Thom Guides Guide

    He apparently doesn't have a data connection and as a result he doesn't have the USB connection menu available. When he does you are right ... he needs to select USB Mass storage.

    Java on the PC is required?

    ... Thom
  5. meganelizabeth

    meganelizabeth New Member

    Ok, tried the USB port in the back of the PC, same thing, will charge but won't give me the USB connection in status bar. And yes, I am using the USB that came with the phone.

    About to check JAVA and make sure that I have it.
    And, I have no clue how to check my settings to see if it is in "charge only". It had worked before and so I don't know how it would change itself to that setting when I don't even know how to find it!
  6. SirEagle

    SirEagle Well-Known Member

    Have you rebooted phone and pc?
  7. Thom

    Thom Guides Guide

    ... after you installed the drivers ... and, are you sure the (proper) drivers were installed?

    The type of connection is set on the Bionic side. When you are connected there is a notification called USB connection. If you select it there are a number of options. You need to set USB Mass Storage.

    You said earlier you did not have the notification in your notification area that indicates the data connection was never established.

    I have no idea what the Java reference was about.

    ... Thom
  8. Ravneet G

    Ravneet G New Member

    meganelizabeth, u should try this..
    go to your dialer and enter *#7284#
    a service menu wil open
    choose USB > a message will appear-USB selected.
    then reboot ur device. i hope it wil work..
  9. Thom

    Thom Guides Guide

    *#7284# ... on a Bionic?

    ... Thom
  10. Alex Wekell

    Alex Wekell Active Member

    Make sure you're using this cable:

    [​IMG]

    Motorola only wants to you to use their cables, and I've heard that you can't use other MicroUSB cables or that they don't work as well.

    Also have you installed these?
  11. sgschwend

    sgschwend Well-Known Member

    I received my second cable from VZ, bless their hearts but this cable too is not a data cable. I think part of the problem is the descriptions the phone support folks receive is not good enough for them to tell which is the correct Motorola data cable.

    So I called Moto, and a very nice person there walked me through a couple of checks and decided I needed a Moto cable; he is sending me one.
  12. SirEagle

    SirEagle Well-Known Member

    The only place I've had trouble with a cable is when it's plugged into a wall outlet. I use an old cable from my Razr2 V9(old non droid flip phone) on my PC, a generic cable at work with my laptops dock station and they both work fine, charge and can see both phone drives. However in a wall outlet I could not get the Bionic to charge correctly without the plug and usb cable that came with the phone. I do have some luck with a cable/plug (not usb) from Sprint.

Share This Page