[ZIP] 10.1 Visual Voicemail Fix | *9016 Fixed


Last Updated:

  1. g60madman

    g60madman Well-Known Member Developer

    README:
    Thanks to the assistance of littlebigtoe, I believe I have a Visual Voicemail fixed for all CM10.1 ROM's for Virgin Mobile HTC Evo V 4G phones! I have only tested this using Angry Bean 10.1 and it's working perfectly.

    TESTING
    If I could get some people to test on all flavors, be it CyanogenMod, AOKP, and all the other flavors of 10.1 and post back I would appreciate this.

    ABOUT:
    This zip is based off the MMS fix for 10.1 davidmargolin created with the help of wolfu. I included the VVM apk T.5.3.3.14 along with Virgin Mobile data files.

    ISSUES:
    I believe the 9016 text messages are fixed with the new zip I added.

    INSTAL:
    PLEASE FOLLOW COMPLETELY
    1. Download to SD card, reboot to recovery and install zip.

    2. Reboot and launch Voicemail App, and let it provision. You should get a text message from 9016 saying //ANDROID:provisioning successful

    3. Reboot to recovery and flash the zip again and reboot

    4. Back on desktop launch the voicemail app it should now be black which means the Virgin Mobile settings have taken effect
    [​IMG]

    5. At this point call yourself and leave a voicemail message. The 9016 text message should come in followed by the VVM a few seconds after.

    DOWNLOAD:
    Fix for 9016
    http://g60madman.vmobi.us/?dir=shooter/VVM
    MD5: f92195fbc896bbb723f7d1493f58ab31

    DONATIONS:
    Your donations are very much appreciated
    PayPal

    Advertisement
  2. g60madman

    g60madman Well-Known Member Developer

    VVM WORKING ROMS
    ∙ CM10.1 Angry Bean
    ∙ Dirty Unicorns 1.6.1
    ∙ CM10.1 Wild for the Night
  3. xstefen

    xstefen Well-Known Member

    Good work g60! I will definately test this today and report my findings. Thanks!
    g60madman likes this.
  4. punkmaxx

    punkmaxx Well-Known Member

    gonna test in a sec restoring my 10.1 ROM from MIUI v5 which i was playing with earlier

    Flashing....Booting....

    EDIT: Leaving a MEssage....

    EDIT: I get the TExt but no notification from the actual voicemail program... (when i call and leave a message)

    I DO GET a notification IF i send a message through the program, but only that way...

    e.g. If you called me I still gotta call and check to see if you left a message
  5. g60madman

    g60madman Well-Known Member Developer

    What happens if you follow the instructions off a clean ROM install? Also make sure you flashed the zip twice. The instructions are key :)
  6. remanifest

    remanifest Well-Known Member

    I'm running Dirty Unicorns 1.6.1

    Followed the explicit instructions in the OP - flashed once via recovery, rebooted and let the program provision. Rebooted to recovery again, flashed the zip once more. Program came up with a dark background. Called myself with wheresmycellphone.com and didn't answer. Voicemail was left by the service, and a few seconds later I got a visual voicemail notification.

    Thanks g60madman!!! This is awesome!
    g60madman likes this.
  7. punkmaxx

    punkmaxx Well-Known Member

    here is my logcat...

    [C] logcat vvm - Pastebin.com
    Gonna try a clean flash.....
    after a few reboots and a dalvik clear

    EDIT: no need for a clean ROM...

    HAd to reboot a few more times after restoring a Dirty ROM and flashing, no biggie..

    Confirm it works on WILD FOR THE NIGHT 3.23.13 VM build!!

    Thanks so much g60!!!
    TheBritton and g60madman like this.
  8. remanifest

    remanifest Well-Known Member

    Would you mind if I link Mazda to this thread so he can possibly include your fix in his ROM?
  9. g60madman

    g60madman Well-Known Member Developer

    By all means :D
    remanifest likes this.
  10. xstefen

    xstefen Well-Known Member

    I dont even like VVM persay, answer your damn phone! Lol. I miss the days of a single, simple persistent notification to click to listen :) But still great work. Flashed, provisioned, reflashed, working [on Dirty Unicorns 1.6.1]. Blocking 9016 messages now :)
  11. mrbenji

    mrbenji Well-Known Member

    Hmm... this is not working for me, it would appear. (Angry Bean 4.4.13) First time through I got the provisioning message, reflashed, reopened app... if what's supposed to be black is the main bg of the app screen (with blue title bar and program icon), then that's correct, too. Called and left VM, got the 9016 message, but no VVM notification.

    Uninstalled the app, reflashed the zip, and this time when I opened the app I didn't get the startup messages I was expecting to. Maybe I should have cleared data first? Guess I'll try that next... clearing program data, uninstalling, then stepping through the double flash.

    As it is, for the moment I'm still getting the 9016 messages but no notification.

    Edit: Ahh... I appear to not be able to uninstall my Voicemail app with the usual method, it's a system app. Ok, gonna Titanium nuke it.
  12. LakersDroid

    LakersDroid Well-Known Member

    Great work!! Easy to follow.

    I went with the instructions. After first flash and phone booted up, I got the provision successful message before I even opened the Voicemail app. I opened it anyway and it was white background with some welcoming popups and messages by Sprint. Then, I reboot into recovery and flash it again.Then after I went to the app and it's now black background, which means it should work! :)
  13. xstefen

    xstefen Well-Known Member

    Testing the sending a vm to activate@vvm.sprintpcs.com fix for messages. Let yall know if it works for us or not


    EDIT: FYI, 20 something minutes later, tested again and still recieving 9016 texts.
  14. mrbenji

    mrbenji Well-Known Member

    VVM still doesn't work for me. Forced uninstall using Titanium backup, flashed zip, opened app, got provisioning message. Re-flashed, verified bg color change. New voicemail produces 9016 message, but no VVM notification. Anything else I should try?
  15. g60madman

    g60madman Well-Known Member Developer

    What ROM are you on? Also are you using the new 555-555-5555 xml fix?
  16. mrbenji

    mrbenji Well-Known Member

    I'm on Angry Bean 4.4.13, using the version prior to the 555 fix. Should I retry with the latest zip?
  17. g60madman

    g60madman Well-Known Member Developer

    It should not make a difference, have you tried to install any VVM app prior to using the fixed version on your current ROM install?
  18. seanfodonnell

    seanfodonnell Well-Known Member

    I followed directions, got the black screen and notification's from vmail. The only thing is I can't listen to the messages though the app...
  19. mrbenji

    mrbenji Well-Known Member

    Retried with the latest zip... same result. Received 9016 messages, but voicemail app just says "You have no voicemail messages."

    (To answer your other question, I had not tried to install another VVM app.)
  20. g60madman

    g60madman Well-Known Member Developer

    What ROM are you on?

    I hate to say it but can you try and do a full wipe of all partitions accept SD and reload just the ROM. Then boot up, then reboot into recovery and install the VVM flash, provision, reboot install again. Then test to see if it's working. If everything is good install gapps and the rest of your stuff, if it breaks along the way we can see what the problems was.
  21. mrbenji

    mrbenji Well-Known Member

    Ok. Should be able to give that a try sometime tonight.
  22. seanfodonnell

    seanfodonnell Well-Known Member

    I'm on 4.3 build. Maybe I should just try your latest build... Will flash in the am
  23. tigerstv44

    tigerstv44 Well-Known Member

    As stated, works on DU 4.2.2. Following the instructions, get black screen after second flashing and receive vmail when call and leave message. Success.....
  24. seanfodonnell

    seanfodonnell Well-Known Member

    sorry I guess im slow.... I flashed the wrong rom.

    it works great!! madman your the f**King man!!
  25. illspoken

    illspoken New Member

    I'm on the latest Angry Bean build, and it took a good long while before the VVM actually showed up. Several hours...but it DID come through.

    EDIT: Oops...the latest build before today.

Share This Page