1. Are you ready for the Galaxy S20? Here is everything we know so far!

Corrupt EFS/missing nv_data files

Discussion in 'Android Devices' started by grrgoyl, Jul 8, 2013.

  1. grrgoyl

    grrgoyl Newbie
    Thread Starter

    I'm running Cyanogenmod 10.1.0-RC5-Hercules on a rooted phone with Jelly Bean 4.2.2 I got off eBay that way (in other words, I'm a newb when it comes to root).

    The problem started when I tried updating CM--I can't remember what I tried to update it to, it came through as a new update and I clicked it. Next thing I know, I'm stuck in a boot loop for a solid day. I figured out how to get out of that, but then had a problem with the keyboard not working, couldn't even get online because I couldn't enter the wifi password. I eventually got into recovery mode, where I tried things like wiping the cache partition, wiping the davlik partition, fixing permissions, anything. The only thing that worked was reinstalling an older version of CM.

    Fine. This fixed it mostly, except I lost my mobile network and data connection. Long story short, I've been poking around and following tutorials, and the bottom line is I think I've corrupted my EFS. The folder is there, but missing the nv_data files. I've looked around a little more and there doesn't seem to be much hope for me now. I've seen the suggestion to flash Odin, and feel I could manage it, but I'd like to stay rooted if possible (but a fully functional phone is preferable if this is my only option). Does anyone have any suggestions for a newb? I'm so frustrated at this point, and I'll probably never, ever update CM again if I can get my phone back to working smoothly and perfectly like it was.

    Thanks in advance
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Atma

    Atma Extreme Android User

    Hi grrgoyl :wavey:

    I moved your thread to the All Things Root forum for you.:)

    Try dialing *#06#. I think that's the code to dial for your IMEI number to show up. If it does you're ok. nv_data files on this phone are hidden. I don't think anyone has ever found them so its ok if they don't show up.

    Usually to get out of a bootloop you can got to recovery and do a factory reset. As far as your data, check your apn settings and see if they are correct. Once I updated CM 10.1 and my apn settings were gone. I did a clean install of CM instead of update and that fixed it. You can find apn settings here if you need them.

    I'm going to assume you didn't make a backup in recovery before you started flashing roms? If not, I think the best thing would be to start over. Use Odin, install the stock Jellybean rom, follow the guide to reroot. Now go to recovery and make a backup. If you ever have problems again, you can just restore that backup if you have to.

    One other option you might try first is to flash this stock rooted rom.
     
    grrgoyl likes this.
  3. grrgoyl

    grrgoyl Newbie
    Thread Starter


    Thank you so much, Atma, for your suggestions. I've spent all morning at this site, GalaxyS2root.com, which I highly recommend for all noobs to rooting. Has all kinds of tutorials with super easy step-by-step processes complete with photos to guide you through. I used Odin to reflash back to Jellybean T-Mobile stock which fixed the network problem (and I was prepared to live with stock but I HATED the cartoony UI after CM's sleek look), then re-rooted and reinstalled CM 10.1 M3. My phone is beautiful and functional again, and I feel much more confident now working with root.

    (Oh, the boot loop turned out to be the easiest thing to fix (for anyone who needs it). Every site I found said to hold down volume up (or down) plus home plus power, which did nothing. It was actually volume up AND down plus power.)

    I LOVE MY PHONE AGAIN! Thanks :)
     
    Atma likes this.
  4. Atma

    Atma Extreme Android User


    Glad you got it going. :)
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...