1. Check out our companion app, Forums for Android! Download from Google Play

General Disabling CMAS alert sounds

Discussion in 'Android Devices' started by barcsmom, Feb 22, 2013.

  1. barcsmom

    barcsmom New Member
    Thread Starter

    Feb 22, 2013
    Hello all. I am a new user of the Huawei Ascend Y (I think it's what I have..H866C) from straight talk. Anyway, I seriously need to figure out how to disable the alarming sound that comes from my phone when one of those CMAS alerts comes through. Even the test messages have that alarming, loud sound like the test of the emergency broadcast system. I always have my phone on silent/vibrate and it still makes the sound which is very disruptive at my workplace. Help :thinking:


  2. Hello barcsmom. Welcome to Android Forums. :)

    Which carrier are you with? There is an opt out feature with Alltel (Article - Support - Alltel Wireless .. near the bottom).

    I'm sure whichever carrier you are with, you can search out the faq on CMAS Alerts and find out how to disable that feature. :)
  3. vsutton

    vsutton New Member

    Jun 19, 2013
    I have tried everything to dissable this cmas alerts. I am tired of once a month having to explain to my co-workers that "no its not a fire alarm ,,, its my phone". There is nothing about cmas alert or dissabling them in my phone. I called straight talk and ended up speaking with the manager who let me know he does not know what a cmas alert is and has never heard of it. I then told me that this is not a service that straight talk offers,,,,yet every month it goes off on my phone>!!!. He told me that once i figure out how to dissable it to call them back and let them know how I did it. seriously. straight talk has been a complete nightmare and if anyone can help me i would appreciate it.
  4. mich314

    mich314 New Member

    Jul 12, 2013
    I have a Huawei from Cricket. I finally found it in my message settings. Here's what I did:
    Click on Message icon
    Click the touch button with the four lines on it (lower left below the screen)
    Click Settings
    Scroll down to Emergency Alert
    Click on Receive Alerts
    Deselect all the options (Presidential is mandatory and cannot be deselected)

    I don't know if it's the same on other Huawei phones, but hopefully that helps!! I know it was frustrating and took a while to find, but well worth it. I had my alerts go off in the library, yoga class, and a family dinner! Not to mention they scared the crap out of me at home multiple times!

Share This Page