1. Are you ready for the Galaxy S20? Here is everything we know so far!

[International] help fone saying not rooted

Discussion in 'Android Devices' started by syrus77, Dec 23, 2013.

  1. syrus77

    syrus77 Lurker
    Thread Starter

    I rooted my galaxy s4 a few months back and the other day I tried to in into my super user app and I told me I didn't have the su binary so I installed root check and it told me that my fone was no longer rooted but I an still able to download apps that u can only do when u have root access so does anyone know what's going on. PS I don't have cwm or any recovery backups installed so any help would be very welcome. Thanks

    1. Download the Forums for Android™ app!


  2. ironass

    ironass Extreme Android User

    Hello and welcome to Android Forums syrus77! :)

    Thank you for your post. However, there are currently 18 different models of the Samsung Galaxy S4 and over 1,000 different stock Samsung firmware versions. Not all issues affect all models or firmware releases and your answers to the following 3 questions may help in the forum's answers to your specific query.

    1. Could you post your Model number...

    To locate your model number, go to...

    Settings > More > About device > Model number

    This will give you the model of Samsung Galaxy S4 that you have.

    2. Your current Firmware version, (not baseband)...

    To locate your current firmware version, go to the dial pad and type in...


    This will give you your, "Version", details in full, usually 3 lines of information which may all be relevant.

    3. Also helpful would be your carrier, (service provider), and if you are rooted and running a custom ROM.

    Thanks. The above, helps us to help you. :)

    (Tip: You can go to the green bar at the top of this forum and click on, "User CP", which will take you to your User Control Panel and then select, "Edit your details", under the heading, "Your profile", on the left hand side. Here you can fill in your model and firmware under, "Current devices", in, "Additional Information". This ensures that your device details are shown under your user name on the left, in every post you make. You can update this as often as you like and will help other users immediately identify your current phone and firmware details.)
  3. Reddevilman

    Reddevilman Lurker

    Today i updated supesu and got the same message no su binary installed supersu can not install it,also tried root checker and says im not rooted any help would be much appreciated

    model number GT I9505

    firmware version AP; I9505XXUDMH8
    CP; I9505XXUDMH8
  4. ironass

    ironass Extreme Android User

    Hello and welcome to Androd Forums Reddevilman! :)

    Have you updated BusyBox binary as well?
  5. Hawker

    Hawker Android Expert

    As long as you still have recovery working, try flashing SuperSU from here

    Also, if you are on PhilZ recovery, you can get it to auto-root on reboot if root not detected
  6. ironass

    ironass Extreme Android User

    That would have been my Plan B... honest! ;)

    You Took The Words Right Out Of My Mouth

    (This starts with my favourite chat up line... as opposed to Hawker's, which is, "'Ere, you don't sweat much for a fat 'un". :girlhit:)
  7. Hawker

    Hawker Android Expert

    That's my 3rd favourite actually.

    The ones that always works for me are:
    "hey love do you want to go back to my place for a pizza and a f**k?"
    "why, don't you like pizza?"

    and of course:
    "hey love, wanna come back to mine?"
    "no i'm with my friend"
    "thats ok, my face seats 2"
  8. Reddevilman

    Reddevilman Lurker

    hi and thanks for the your help.busybox was updated also yesterday im not sure about recovery as I bought the phone from my brother who emigrated to australia aweek ago and the phone was rooted and I cant get a hold of him.
  9. ironass

    ironass Extreme Android User

    Right children... back to school, play time is over. Reddevilman needs some more help.

    If you boot into Recovery Mode.... turn phone off and then hold the UP volume button and the Power Button together until you see the Samsung logo and some small blue writing in the top left hand corner of the screen and then release both buttons immediately and the screen should boot into a screen similar to image #1, here, if PhilZ recovery is installed. Then you can try Hawker's suggestion.
  10. Reddevilman

    Reddevilman Lurker

    Hi went in to recovery and dont see phils recovery
  11. Sydney99

    Sydney99 Android Expert

    When you open busy box, does it state that busy box is installed. A couple of times on updating in the past I've had to go into busy box and manually install it
  12. Reddevilman

    Reddevilman Lurker

    Yes busy box is installed and i have tried manually installng it also,the phone has been switching its self off and on quite alot recently and is under waranty.and prob be best too unroot have you any idea where i can get the stock firmware for my model its locked to 02 uk
  13. ironass

    ironass Extreme Android User

    If you want to flash the stock firmware that you mentioned earlier, you will need to download...

    Model: GT-I9505
    Country: United Kingdom
    Version: Android 4.2.2
    Changelist: 1220396
    Build date: Wed, 21 Aug 2013 02:04:32 +0000
    Product Code: BTU
    PDA: I9505XXUDMH8

    and flash it via Odin by following the instructions in the link #1.5 of 23 Galaxy S4 models - know yours?

    Personally, unless any of my colleagues have any better suggestions, I would re-root your phone and install PhilZ recovery by following the instructions in posts #1 - #4 of the Rooting Galaxy S4 - Dummies Guide.
  14. Sydney99

    Sydney99 Android Expert

    Agree with ironass, just try reflashing. Have you used rom manager recently, my phone went a bit loopy and issues with fc and booting, which I think were related to trying to fiddle with rom manager, all back to normal on re flashing and have since stopped using rom manager
  15. Reddevilman

    Reddevilman Lurker

    I have not used rom manager,should.i unroot before i root again
  16. ironass

    ironass Extreme Android User

    There should be no need to un-root before re-rooting however, you may need to wipe cache partition and dalvik cache, under Advanced, in the newly installed PhilZ recovery, after booting, if you experience any problems.

    Alternatively, if you are a purist like me, you could flash the stock Samsung firmware, Android 4.2.2, mentioned above, after a Factory Data Reset and then proceed to root this firmware using the Dummies Guide. After that, you can then install a custom ROM of your own choice.
  17. Reddevilman

    Reddevilman Lurker

    odin wont let me uncheck repartition or check auto reboot or f.reset time
  18. ironass

    ironass Extreme Android User



    Ensure that you are running Odin with Administrator rights. #2.2

    2. Make sure you have Kies installed but NOT running. #2.2

    3. Try a different version of Odin. #1.4
  19. Reddevilman

    Reddevilman Lurker

    ok i downloaded another version of odin this time repartition is unchecked uto reboot is checked but cant check f reset time
  20. ironass

    ironass Extreme Android User

    Are you opening Odin with Administrator rights?
    Reddevilman likes this.
  21. Reddevilman

    Reddevilman Lurker

    Got it sorted ironass very greatful for your help

Samsung Galaxy S4 Forum

The Samsung Galaxy S4 release date was April 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 2GB RAM, Exynos 5410 Octa processor, and 2600mAh battery.

April 2013
Release Date
Similar Threads - International help fone
  1. kumaranil13k
  2. sargodhianhawk
  3. montecarlo1987
  4. halfbeing
  5. Caro D
  6. Pochoco
  7. Robert Richards01
  8. xra7en
  9. Garaera
  10. SamsunnyD

Share This Page