1. Are you ready for the Galaxy S20? Here is everything we know so far!

mounting /system rw problems

Discussion in 'Android Lounge' started by bamaduc, Dec 30, 2011.

  1. bamaduc

    bamaduc Member
    Thread Starter

    Hello everyone here's the story. I have a rooted Transform Ultra, running a Rom by interdpth(Star-ScRom), cwm installed. Ok when interdpth released star-scrom I was never able to flash it by using the batch file. I had to manually push the rom via adb every time(different versions). After toying around with it I found out the batch I found out it was getting hung up on mounting the system with rw permissions. If I'm in adb and I _adb remount_ I get operation failed. If I _adb shell_ _su_ _remount. Rw /system_ it tells me it enables r/w but then I get pe:rmission denied when I try to push/pull from the system. _ adb shell -o remount,rw -t ext4 /path here /system_(can't remember that command off the top of my head, but whenever I enter that code correctly) I get permission denied. I have been pouring over forums for weeks but cannot figure this out. Anyone that can help me out with this would be greatly appreciated. Thanks for reading and apologies it is so long.

    Mods, I realize this will probably get moved the the transform ultra-all things root forum, but I did ask around a bit with no luck. If it does get moved its no biggie, just feel this is more of a general android/adb question/problem.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. T.M.M.L

    T.M.M.L Android Enthusiast

    Greetings bamaduc,

    Not familiar with your device, but I wonder, did you check to see that S.U.(Super User) got installed.
     
  3. jerofld

    jerofld Fixing stuff is not easy

    I'm no coding wizard, but I didn't think Linux liked back slashes ( \ ). Is that maybe your problem? Have you tried those commands using forward slashes ( / )?
     
  4. bamaduc

    bamaduc Member
    Thread Starter

    Thank you both for the quick replies. Yes su is installed, and you are correct jerofld, linux does use foward slashes I'm just a dumb@ss and typed them wrong in the post, ill correct them now, thanks for the catch.
     
  5. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    I have seen and helped fix this problem twice before, on other phones.

    For reasons never discovered, the remount fails just as you describe and the explicit mount needs the low level path, not the logical one.

    I recall the fix, finding the low level path, was protracted. I will have to look it up in my post history. (Not going to be quick with my volume, sorry.)

    Meanwhile, please try this work around - install EStrongs File Explorer, menu, settings on that, enable root explorer and /system read/write. EStrongs always amazes me at things it can get by.

    If that works, consider Fix Permissions, free in the Market.
     
  6. bamaduc

    bamaduc Member
    Thread Starter

    EarlyMon, thanks for reply. apologize its taken so long to get back(family bull, had to go outta town) i tried EStrongs File Explorer and continued digging but unforunately the problem is still here. i have started looking through ur posts to try and find how this was fixed, but i think it will take me roughly a year due to your almost 16,000 posts. :) anyway i appreciate your input and hope you had a good Christmas/New Years.
     
    EarlyMon likes this.
  7. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Let's see what I can find. ;) :)
     
  8. bamaduc

    bamaduc Member
    Thread Starter

    ok thanks a million. i did finda thread about ro.secure=0 causing a similar problem. so i went into
    Code (Text):
    1. adb shell
    2. getprop ro.secure
    3. 0
    I checked the build.prop file from Interdpths Star-Scrom and ro.secure value was 1. this is weird because that was the same build.prop file that i pushed when i installed star-scrom. so i pushed the build.prop file again and now ro.secures values stays 1. although still having my mounting issue.
    Code (Text):
    1. adb remount
    2. remount failed: operation not permitted
    3.  
    4. adb.exe shell mount -o remount,rw -t ext4 /dev/block/mmcblk0p15 /system
    5. mount: operation not permitted
     
  9. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Please do an adb shell to get into the phone.

    If presented with a user prompt ($) please enter su to be root.

    Then please just issue the command, mount, and post back the line for /system - thanks! :)

    Point is to verify your fs type and any other mount options set by default.

    PS - if you weren't root by default going in, ok to retry your mount after you are.
     
  10. bamaduc

    bamaduc Member
    Thread Starter

    Ok the line is /system ext4 rw,relatime,barrier=1, data=ordered 0 0
     
  11. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    OK. So your option clause needs to look like this:

    -o rw,relatime,remount

    I think you can skip the other two clauses but if it fails, go ahead and include them. (barrier=1,data=ordered)

    By the way - you're saying that you are already read-write on /system - maybe there is another problem??

    And to make read-only when done, substitute ro for rw.

    BTW - is BusyBox up to date?
     
  12. bamaduc

    bamaduc Member
    Thread Starter

    I actually just updated busybox yesterday. And how should I input the option clause?
    Mount -o rw,relatime, remount?
     
  13. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Yes, without the space on remount, of course, and adding the other two parameters as suggested if that fails.

    Hope we get you out of these woods soon, I know you feel the same!
     
  14. kadimi

    kadimi Android Enthusiast

    Mounting with mount :

    Code (Text):
    1. # mount -o rw,remount /system                                    
    2. mount: Permission denied
    After installing Busybox
    Code (Text):
    1. # busybox  mount -o rw,remount /system
    2. # # No error
    3.  
    Edit: It donsn't work anymore, I don't know what I did to make it work in the first place ((
     
  15. kush_4848

    kush_4848 Lurker

    I am facing same issue on Android 7.0, any help would be appreciated. I am trying to remount system partition on USER build binaries, below are the commands i have tried already

    C:\Users\kushal>adb shell
    xxx:/ $ su
    xxx:/ # toybox mount -o rw,remount /system
    mount: '/dev/block/dm-0'->'/system': Operation not permitted
    xxx:/ # mount -o rw,remount /system
    mount: '/dev/block/dm-0'->'/system': Operation not permitted
     

    Attached Files:

Loading...

Share This Page

Loading...