1. Are you ready for the Galaxy S20? Here is everything we know so far!

S3 wifi issue

Discussion in 'Android Help' started by Clive99, Feb 7, 2016.

  1. Clive99

    Clive99 Lurker
    Thread Starter

    Galaxy s3 issue

    My s3 is not able to pick up the 5ghz ssid, however my s4 can see the 5ghz and connect. I taught my s3 did not support 5ghz but when I review the s3 specs on gsm arena it says that the s3 supports abgn...

    The reason why I want my s3 to connect to the 5ghz ssid is because the phone got very laggy....slow in general so I decided to factory reset the phone, after resetting the phone I'm having wifi issues but before resetting all was well.... went on may forum ppl saying to disable wifi power save.. did that but no results...others say disable auto switch network ....still no results...that other was to have the s3 connect to a 5ghz wifi.. but it's unable to see a 5ghz ssid.

    Anyone can assist with this issue?

     


  2. Best Answer:
    Post #4 by svim, Feb 7, 2016 (1 points)

    1. Download the Forums for Android™ app!


      Download

       
  3. svim

    svim Extreme Android User

    Do you have separate SSID names for your 2.4 and 5 GHz networks? If they're both the same maybe your S3 can't differentiate between the two.
     
  4. Clive99

    Clive99 Lurker
    Thread Starter

    Yes both the 2.4 and 5 ghz having the same ssid.. I had however disable the 2.4ghz from the ap and this is how i know the s3 is not seeing thE 5ghz.
    My ap is a tp-link tl-wdr3600
     
  5. svim

    svim Extreme Android User

    Ahhh, so your home WiFi is a 5 GHz only-no 2.4 GHz network. Have you played around any with the various security and other settings on your TP-Link router? If you don't want to mess up the current settings on your S4 and other devices connecting to your Wi-Fi maybe try setting up a 5 GHz Guest network and tweaking the settings for that.
    http://www.tp-link.com/Resources/document/TL-WDR3600_V1_user_guide.pdf

    Also, you might want to install something like 'Wifi Analyzer'. It's a nice utility to get info on local WiFi networks. Also, in the Settings menu you can selectively include/exclude channels for 2.4 and 5 GHz networks:
    https://play.google.com/store/apps/details?id=com.farproc.wifi.analyzer&hl=en
     
  6. Clive99

    Clive99 Lurker
    Thread Starter

    Thanks for your replies "svim"
    However as u are aware my AP is dual band and I have a bit of IT knowledge so before I post up here I did quite a bit of troubleshooting with my AP.. I tried running the AP with only the 5ghz radio on and My s4 works just fine but the s3 is still to find the ssid.. as u suggested changing the channels, did that well.. channel is on auto by default so I manually selected other channels but still the s3 is unable to find it... however the s3 would connect to the 2.4ghz when it's enable but the connection would just drop and at times it would say authentication error, to connect I will does have to forget network and reenter the credintials sometimes that will work and other times will not, other times it would only add to the ap when I use wps.. so as u can see I try quite a bit :) however like I mention earlier this issue with the s3 only stared to happen after I did a manafacture reset, before that all was well, the AP settings was the same for the last couple of years and because the s3 is acting shitty I went and mess with the settings.

    I am thinking that the wifi card defective some what..not sure, why I say so is because I would be just in front of the AP 5ft and the link signal is only 5Mbps compare to 150Mbps for my s4.

    To download a 6MB file from the play store it took half an hour..

    Also I'm using ping tool, it's kinda Kool and gives some decent info.

    Your taughts?
     
  7. svim

    svim Extreme Android User

    So things started to get really messed up only after a Factory Reset. Have you wiped the system cache partition since that point?
    https://www.androidpit.com/forum/608583/how-to-clear-the-system-cache-for-the-samsung-galaxy-s3

    Also, have your booted your S3 into Safe Mode and checked if your WiFi connectivity is still messed up? I guess I'm running out of ideas but just on the remote chance there might be something you had installed over the years that's causing a problem. Not sure how this correlates to things being OK before the Reset and not afterwards but if your WiFi is working in Safe Mode than at least it's a place to troubleshoot from.

    And even though I can't imagine why a Factory Reset would have anything at all to do with this but maybe re-seating the connector for the WiFi antenna to the motherboard might help. The white antenna wire is visible in steps 6 and 7 here:
    https://www.androidpit.com/forum/608583/how-to-clear-the-system-cache-for-the-samsung-galaxy-s3
    and the connector's location is showing in step 20 here:
    https://www.ifixit.com/Guide/Samsung+Galaxy+S+III+Front+Panel+Assembly+Replacement/12697
     
  8. saltire

    saltire Android Expert

    Another easy check first - on the phone have you checked that Settings > Wi-Fi > Advanced > Wi-Fi Freq Band hasn't been set or reset to 2.4 only? Also, I don't know how complicated your set-up is or how many devices you have connected, but I'd maybe also try a setup with a separate ssid and password for each band. We have a S3 in the family and it connects to 5Ghz no problem.
     
  9. Richard Park

    Richard Park Member

    I didn't know these were still being used..
    lol...
    I wonder if you will get a M OS update for that device.
     
  10. saltire

    saltire Android Expert

    OT - but my previous phones go to my better half when I upgrade and the S3 is still a good phone, she loves it. And as all my devices are rooted with custom recoveries anyway there's no problem getting a choice of 6.x roms [emoji6] .
     
  11. Clive99

    Clive99 Lurker
    Thread Starter

    "Saltire"
    There is no band selection option under wifi advance.
     
Loading...

Share This Page

Loading...