Help USB connection to PC does not work.


The title pretty much says it all.
I am using Windows 7 on my PC. I have tried re-installing the Kyes software. When I do I get a "Universal Serial Bus (USB) Controller : No driver found" error while it installs the drivers. This also happened the first time I installed, while the phone would connect to the PC.
I am using the phone for development so have had USB debugging on most of the time.
I read somewhere that possibly the drivers on the phone may be damaged? I wanted to try re-flashing the ROM to the latest version in the hopes it might fix the problem, but without a USB connection I cannot actually do this...
There doesn't seem to be a full factory reset, only the data factory reset that will only delete my data and not reinstall the drivers.

Any ideas?!


Thread starter
Okay I fixed it. For anybody else who has this problem:
The fact that the install claims that it couldn't find a USB driver DOESN'T matter.
In my case it was my phone that was messed up. After about 2 hours of Googling I couldn't not find anywhere that explicitly said HOW to do a factory reset, but a few people saying they had done one. I had to guess the button combo, and it turns out to be booting the phone by holding down Volume Down + Home and then holding down the power button as well.
The screen changed to read "Downloading, don't turn off the phone" or something similar, with a what appeared to be a progress bar. I was worried when what I thought was a progress bar hadn't progressed after about 15 minutes, then my phone rebooted itself and since then has been working correctly.
Would be kind of nice if this kind of stuff was in a sticky somewhere...

Okay maybe it isn't fixed yet...
If I boot the phone connected to the PC the "connected" logos will show up in the task bar, but I can't actually see the phone from the computer, and the logos remain even if I disconnect the USB. So I guess I'm still asking:
Any ideas?


Thread starter
For posterity:

Okay, well I solved my problem by doing a factory data reset (via Settings->Privacy->Factory Data reset). Something got corrupted I guess. The proper hardware reset (via booting while holding down home and vol-down) didn't fix the problem, but the data reset did.


I think I have the same problem too. A quick fix when this happens is to reboot to recovery mode (do nothing there) and then reboot. No factory reset is required.
I am using Windows 7 64-bit with Kies v1.5.3.10103.100

I am not able to connect my Galaxy i5801 to my PC. It gives MTP USB driver error and CDC Abstract Control Model driver error.

Please help


Well-Known Member
I had that from brand new, I also did the factory re-set as I was totally stuck. It also worked.
Looks like a common problem?

I have recently purchased an Apollo I5801 and I have spent ages trying to sync contacts via Kies. Had success this morning on both my Vista SP2 and XP SP3 machines, using Kies version downloaded from the Samsung website. The phone will only connect if the SD card is unmounted for me. If you mount the SD card the MTP driver isn't found and it kills the connection. Good luck folks.


1. Dial *#7284#. This should open app called PhoneUtil (there are other ways to get to it)

2. In USB section, swith it to Modem, then switch it back to PDA

3. Exit, and USB should work.

mabe this helps :)

That post solved my problem of the phone not detecting a usb connection to my PC. I was pulling my hair out for 2 hours trying to fix it, but that PhoneUtil fix worked perfectly. Thanks alot, bratick!


Thank you very much for this fix to the galaxy s usb to pc connection problem. I followed the three steps indicated and everything worked perfectly!!!!

Thanks again.