Easy guide to update to Galaxo or GAOSP!


Last Updated: 2013-01-29 03:10:09
  1. qwerty100

    qwerty100 Well-Known Member


    I had loads of problems with this, and managed to fix the driver thing by tweeking the inf files that go with the USB driver code seems my DeviceInstanceId for my galaxy did not match that in the downloaded recovery drivers.

    Check your instance ID matches what the driver has in it...?

    Advertisement
  2. sgx100

    sgx100 Well-Known Member

    You are on a stock Samsung ROM now. So your phone is un rooted.
    You have to install recovery. Without that you can not install gapps/galaxo or do any kind of nandroid backup.


    What you can do now is to again do an Odin with a different set of ROM.
    This ROM JC6 has recovery 6.1 integrated so you dont have to manually install recovery.

    After that you can install gapps or galaxo 1.6.3.4 through Recovery Menu.

    Refer to the post by informale here and read the part which says :

    ' -JC6 firmware with removed CSC and integrated Recovery 6.1 + [mirrors] '
  3. qwerty100

    qwerty100 Well-Known Member

  4. croftyboy8

    croftyboy8 Well-Known Member

    so once i have followed the odin process with this i wont need to mess about with the 15 second firmware business?

    sorry for sounding slow, im new to this and all you guys keep saying it can be done!
  5. sgx100

    sgx100 Well-Known Member

    Yes mate. Though I havent tried this yet but I should say this would work.
    Why dont you try it ... Lastly it can always be done..Just a bit of perseverance
  6. croftyboy8

    croftyboy8 Well-Known Member

    no no no no!

    the galaxy updater just says there was a problem and shuts down!

    can someone please help me!?

    ive tried everything i can think of!
  7. bisanu

    bisanu Well-Known Member

    hi fellas. i am on galaxo 1.6.3.3. and now i want to change to GAOSP. first thing i have to do is to update old recovery 4.6.3 to 6.4. i get stuck at this screen. what should i do? what is the error i get?
    [​IMG]

    one more q. can i update recovery any way easier like while i am in recovery just choose extract zip and than select recovery. and will my new recovery mess up with apps i have on the phone.
  8. sgx100

    sgx100 Well-Known Member


    Dude why are you fiddling with galaxy updater
    You need to flash the phone again with odin using the link I had posted in my previous post. When you do that things will be okay and you can install/update galaxy updater from the market.
  9. sgx100

    sgx100 Well-Known Member

    I think you messed up the commands
    The thing should be : fastboot flash recovery recovery.img and not
    fastboot flash recovery recovery-6.4.img

    Recovery does not mess up with system apps
    Once you install recovery you can install galaxy updater from the market which will automatically install latest recovery versions
  10. bisanu

    bisanu Well-Known Member

    but the .img in the fodler of sdk is 6.4 not recovery.img
  11. Lelouch

    Lelouch Well-Known Member

    Just rename Recovery_6.4.img to Recovery.img. And it should work, easy as that. :p
    Btw, did you copy RECTOOLS.tar.gz to your internal SD card before flashing the Recovery?

    EDIT: Where did you copy your's Recovery_6.4.img? It should be in SDK/Tools.
  12. bisanu

    bisanu Well-Known Member

    on your suggestion i downloaded free galaxyupdater and download recovery. thanks :)
  13. Lelouch

    Lelouch Well-Known Member

    :confused: :confused: :confused:
    Whose suggestion? Mine or someone elses?


    :confused: And??? :confused:
    Did it work or not?
  14. bisanu

    bisanu Well-Known Member

    on your suggestion, via pm. :) yes, works like a charm, thanks for support
  15. DaSchmarotzer

    DaSchmarotzer Blame it on me VIP Member

    I edited the Guide to redirect people toward the application Drakaz made. I didn't remove it, it seems like quite a few people didn't want me to do that. :D
  16. sgx100

    sgx100 Well-Known Member


    HaHa :p
  17. croftyboy8

    croftyboy8 Well-Known Member

    Mate, i installed the latest 1.6 firmware as directed.

    ive tried to follow the guide about rooting the phone ( really stuck)

    my point was, when i try galaxy updater, it just crashes after i try to flash recovery.

    im going to bin my phone before my head pops!
  18. sgx100

    sgx100 Well-Known Member

    Just stick to the guide. Forget about galaxy updater for now.
    Galaxy Updater is only when you have a rooted and working phone

    If possible try on a different computer. Start fresh and stick to the basics
    Also which operating system are you using ?
  19. croftyboy8

    croftyboy8 Well-Known Member

    im using windows xp home.. my computer recognises my phone in device manager.
    what next?

    should i remove all the files from my phone and start again?

    ive gotta feeling you guys can help me!
  20. sgx100

    sgx100 Well-Known Member

    I would suggest you start on a different computer with XP/7 32 Bit

    Else remove all traces of PC Studio/KIES ( If you have installed )
    Remove all drivers for adb interface from device manager
    Remove any Samsung stuff for control panel

    And Start Fresh...

    Also Pinning some guides
    go through them once

    Update Samsung Galaxy GT-I7500 to Android 1.6-Step by Step
  21. chronodekar

    chronodekar Well-Known Member

    <BIG SIGH>

    Thanks for keeping it up !!

    -chronodekar
  22. Davi

    Davi Active Member

    when I boot in recovery it says this:

    The archive: rectools.tar.gz was not found on /sd card/

    This small recovery allow you to upload the rectool.tar.gz. archive on/ sdcard/
    using adb
    when the upload was done, reboot again in recovery mode

    I dont really understand what to do here, ive checked the sd card and the file is there
    thanks :)
  23. weasel

    weasel Well-Known Member

    You did put it on the internal sd card, right ?
  24. Davi

    Davi Active Member

    Yes I havent even got the external in the phone :S
  25. Lelouch

    Lelouch Well-Known Member

    Now you have to flash the recovery, that is the step after you put RECTOOLS on your phone (internal SD). Lokk in the guide for that.
    Okay now for a fun part, Ialso had SD folder on the internal SD card so I also put the file there and did unzip there.

    OK, you can also copy/paste file via explorer. Just mount the SD card.
    But the easy way for this is via GalaxyUpdater app by Drakaz. Noob friendly. :p
    Free version gives you option of installing the Recovery only, but donated version Recovery + ROM's (GALAXO or GAOSP nightly) of your choice. You don't need to bust your head with adb ever again.

Share This Page