[Guide] How to root the Wildfire S with S-ON


Last Updated: 2014-11-24 18:08:22
  1. lostmemoriiz

    lostmemoriiz Member

    I followed all the steps and got it ***unlocked***, rooted but it doesnt seem like programs recognizes my phone as a rooted phone. Whenever I open one of those root-needed programs, it asks to enable it on superuser. I had to download superuser manually and nothing asks if I want to enable anything. Help please :(

    Advertisement
  2. 6thinsomniac

    6thinsomniac Active Member

    Look, ideally, once you've downloaded Superuser, stuff such as Link2SD or root-required programs will need permission from Superuser...not all the programs...have you any root-required programs?
  3. lostmemoriiz

    lostmemoriiz Member

    I'm trying to use link2sd but it said I'm either not rooted or I didnt grant permission from superuser. But nothing asked for permission @__@ Is something supposed to pop up or is there something I'm supposed to do on superuser settings or something? /:
  4. Caro332

    Caro332 Well-Known Member

    Yes a pop-up is supposed to come and ask for permission. Sometimes the method given in the guide doesn't work. THere is a second way of rooting it. Just look at the previous posts (not too far back, probably the previous page). Someone was not able to root with the guide given and so Cafekampuchia gave an alternative method.
  5. 6thinsomniac

    6thinsomniac Active Member

    Caro, could you please help me with my problem too? it's post #523...

    Even flashing the Dust kernel is no good....I hate it!!!!!
  6. Caro332

    Caro332 Well-Known Member

    6thinsomniac, not sure why it's not working for you....
    Have you taken a nandroid backup of your stock rom? If so I suggest you revert to your stock rom, and try flashing the new rom you want....Maybe that would work
  7. 6thinsomniac

    6thinsomniac Active Member

    My phone sucks. Big time! I can't even OC to 768Mhz...this is mind-boggling!
    I'm going to stick to HenseMod7 till someone comes up with some solution.
    And if someone does come up with a solution, please let me know. PLEASE!
  8. Caro332

    Caro332 Well-Known Member

    I have been using CM 7 from the beginning and have been really happy with it so I never really tried any other different roms...Therefore, cannot really help. But if you look in the Wildfire S - All things root, disciplexone has posted quite a few threads, all Sense ROMS and I think he's put a guide on all of them on how to flash them. He says that if you follow the instructions properly, it should work perfectly.
    Maybe you could check it out.
    6thinsomniac likes this.
  9. pc007

    pc007 New Member

    I now have the following on my Wildfire S - PG76120
    Android version: 2.3.5
    Software number: 2.17.781.2

    *** UNLOCKED ***
    MARVEL PVT SHIP S-ON RL
    HBOOT-1.09.0099
    MICROP-0451
    RADIO-7.56.39.09M
    Feb 8 2012,18:29:31

    I just want root access so that I can remove a bunch of the HTC bundled applications, but can't seem to get it by running either htcsupertoolv3 or using Wildfire S Manager.

    Any ideas on how to just get root access?
  10. 6thinsomniac

    6thinsomniac Active Member

    Have you installed superuser??
  11. lostmemoriiz

    lostmemoriiz Member

    It still doesn't work :bawling: whatever app I download that requires root says that they don't recognize my phone as a rooted phone and I don't have the bu bin, busybox.. I repeated step 4 using the supertool and again it said my phone was successfully rooted using the first alternative (typing 1 enter, 3 enter, reboot). I didn't do step 5, can that be the problem? I tried step 5A tho but when I typed in the command in the command prompt, it said it doesn't recognize the command as a internal or external command, operable program, or batch file. Please helppp ):
  12. Caro332

    Caro332 Well-Known Member

    Have a loot at the different method in post No 517 (same page)
    CafeKampuchia likes this.
  13. Lotoy

    Lotoy New Member

    Hi everybody,

    I'm new to Android Forums and a new user of WFS. I'm trying to root my phone but i still don't know if my phone is a A510a,b or e (it's GSM ;D). Tried to bootloading and that is what appears:

    MARVEL PVT SHIP S-ON RH
    HBOOT-1.03.0000
    MICROP-0451
    RADIO-7.50.36.16M
    Jun 2 2011, 16:17:50

    After doing some research, i find that that difference between models is gsm radio frequency. As the manual of my phone informs that the phone suports a frequency 850-1900MHZ, i'm guessing my model is an A510a right? If so, this guide works for it? In which step should i begin?

    Waiting for reply. Regards!
  14. lostmemoriiz

    lostmemoriiz Member

    The link doesn't work ):
  15. 293261352

    293261352 Member

    How exactly do I back up my stock rom after rooting?
    Is HTC sense 2.1 and Andriod 2.3.3 two separate roms?
    Please list the details of how to back up all the original stock rom on HTC Wildfire S...
  16. 6thinsomniac

    6thinsomniac Active Member

    Sense 2.1 and Android 2.3.3 are different things, but can be together. You could have Sense 2.1 with Android 2.3.3 or android 2.3.5...Sense belongs to HTC, while Android is Google-owned. :)
    CafeKampuchia likes this.
  17. CafeKampuchia

    CafeKampuchia Well-Known Member

    Please check out step 5 of the guide to install the custom recovery and do a backup from recovery.
    293261352 likes this.
  18. CafeKampuchia

    CafeKampuchia Well-Known Member

  19. CafeKampuchia

    CafeKampuchia Well-Known Member

    Try the way of the ancients [​IMG]:
    http://androidforums.com/wildfire-s-all-things-root/399076-guide-how-root-wildfire-s.html

    All you need is step 2. Come back and run Step 5 of this guide after that.

    Cheers!
  20. CafeKampuchia

    CafeKampuchia Well-Known Member

    Welcome to Android Forums :hello:

    If you are an Australia/New Zealand user it's an A510b (Marvel) and this rooting guide will work for your phone. Just don't flash the ROM for an A510e (step 2) or it may flash a new radio and mess up your frequencies.
  21. CafeKampuchia

    CafeKampuchia Well-Known Member

    First, when installing any ROM or backing up a nandroid, make sure you do a factory reset, wipe the cache partition and delete dalvik cache.

    If that doesn't work, get the right RUU for your phone and run it while your phone is booted in bootloader and connected via USB in fastboot USB mode.
    6thinsomniac likes this.
  22. 6thinsomniac

    6thinsomniac Active Member

    Okay, as you said I've created a new thread http://androidforums.com/wildfire-s...27-wfs-cant-over-clock-stuck-boot-screen.html

    I've done all the RUU stuff and have S-On unlocked on my phone...that's how I've been able to flash CM7 and HenseMod...I used hTC Asia India RUU...if the 2 mentioned ROMs work fine, then why don't other ROMs go past the boot screen....?
  23. slimchance

    slimchance Well-Known Member

    Running the RUU for my carrier (vodafone UK), it will not flash telling me:

    'Your ROM version is not the latest version. Please upgrade to 2.14.161.1 to apply this RUU to be able to unlock the bootloader'

    I've tried this process at least 3 times!

    But when I go to software updates on my phone and check for updates it tells me my phone's software is up to date. I upgraded to 2.3.5 a couple of weeks ago, but my ROM version is only 2.6.35.10.

    I've also tried saving rom_01.zip and rom_02.zip and renaming rom_01.zip to PG76IMG.zip and transferring it to my sd card and attempting to install from there only to get the error message 'Main version is older'

    Wildfire S 'Marvel'
    PG7610000
    Android Version 2.3.5
    Software number: 2.26.161.1
    Kernel version 2.6.35.10
    Build number 2.26.161.1
  24. digitalsarma

    digitalsarma New Member

    First of all - thank you CafeKampuchia, great tutorial, worked perfectly!


    had the same problem, could not up update RUU, so i just continued with instructions to unlock bootloader and it worked fine..try without updating RUU then
    slimchance and CafeKampuchia like this.
  25. CafeKampuchia

    CafeKampuchia Well-Known Member

    Thanks for the compliment and for taking care of his question. It's true that these newer RUUs come with an unlockable bootloader so it's possible to fast-forward to step 3C. I'll update the guide soon!

Share This Page