[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
Last Updated: 2012-10-28 02:18:14
  1. krisdr

    krisdr Active Member

    Stupid me. I put zip after PB31IMG. Now my problem is getting myphone to boot back up. It did not reboot fully. So I am going to try again to run PB31IMG. I saw that sometimes the phone does not fully reboot. Has anyone had a problem of it not every rebooting fully? I am a little nervous, I would be lost without it.

    Advertisement
  2. dhs2011

    dhs2011 Member

    my problem is that it says no image when i use bootloader. are these two issues along the same line? i do not get a status bar either! thanks
  3. scotty85

    scotty85 Guides Guide

    not that i have seen. so far the 2nd time has worked for everyone.

    your phone isnt finding the file. check the first post for notes on flashing files in hboot.

    brief recap:
    1)sd card must be FAT32(not plain FAT or something else)

    2)file must be correctly named(PB31IMG.zip on phone-check with file manager)

    :)
    iowabowtech and krisdr like this.
  4. dhs2011

    dhs2011 Member

    have both one and two matched but still no luck. how frustrating! so do i need to start over somewhere?

    thanks
  5. krisdr

    krisdr Active Member

    Do you recommend 3 or forever?
  6. scotty85

    scotty85 Guides Guide

    as long as you used the PB31IMG we provided in the first post,you dont have them matched. those 2 things are the only reasons PB31IMG is not found.

    another error thats been made,is putting PB31IMG onto the internal memory instead of the sd card :eek:

    again:
    1)not FAT32
    2)not named PB31IMG on phone
    3)not on root of SD card
    4)wrong file used

    *only reasons not found

    you can use an app like "quickboot",you can use the "boot to clockwork recovery for manual management" option in ROM manager, or you can enter thru hboot(turn phone off, then power/vol down. once in hboot use volume rocker and power button to select recovery)
    iowabowtech and krisdr like this.
  7. scotty85

    scotty85 Guides Guide

    once on 2.2,run unrevoked 3.32. if it fails to give you s-off,flash the "forever" .zip in recovery :)
    iowabowtech and krisdr like this.
  8. dhs2011

    dhs2011 Member

  9. scotty85

    scotty85 Guides Guide

    no prollem. didnt mean to sound short,but that issue has been discused alot of times in the thread. there are only a couple things to go wrong,but they can be tricky to diagnose.

    sometimes a good nights sleep is just the ticket :p
    iowabowtech likes this.
  10. iowabowtech

    iowabowtech root@android:/ #

    Sometimes, for whatever reason, the fat32 formatting just flat out doesn't take. I've had people format the card 3 times and on the 4th try, it picks up the file. Should be able to just right click on the drive after formatting and check the file type but sometimes it just don't cut it. If ALL else fails, try formatting again. For whatever unexplainable reason, certain sd cards are just fickle in this phone. It's been that way since day one.
    scotty85 likes this.
  11. krisdr

    krisdr Active Member

    I am s-off! Thank you all for your help and patience!
    scotty85 likes this.
  12. Neverdrift12

    Neverdrift12 Member

    Me wants root too still, well hopefully
  13. dhs2011

    dhs2011 Member

  14. scotty85

    scotty85 Guides Guide

    your quite welcome. glad you got it :)
    if you had the prollem after running unrevoked,maybe try re-downloading it? make sure its md5 sum matches
    iowabowtech likes this.
  15. Neverdrift12

    Neverdrift12 Member

    Am I suppose to have that zip7 program to make the downloads download right?
  16. scotty85

    scotty85 Guides Guide

    No... 7 zip is a utility to unzip,or extract, zipped files.
    iowabowtech likes this.
  17. Neverdrift12

    Neverdrift12 Member

    Ok going to redownloD everything and try it again tommorow
  18. cowgoesrowr

    cowgoesrowr New Member

    Hi all,

    I are noob, please halp!

    -plug in your phone,and assuming you installed the drivers correctly,unrevoked 3.22 will start. let it do its thing. it will reboot a couple of times. when its finished,it may leave you on a blank screen. if this is the case,pull the battery and reboot.

    So I have successfully completed all the steps before this one. Installing the drivers, making sure my phone is on debugging, charge only, etc and that unrevoked is using the correct recovery image.

    I plug in my phone and unrevoked says it's doing it's thing... it installs, reboots my phone, and then says Rooting.. but after a while, I get "Error: failed to get root. Is your firmware too new?"

    I have tried changing my phone to mount as disk drive, as some other forums have suggested. I have tried deleting some applications on my phone that might have caused the problem (task killer, Zysploit), I have basically tried every suggestion on other forums, but I keep getting the same error message.

    Can anyone help?? Much appreciated!
  19. gkinsella2

    gkinsella2 Member

    GREAT FIND lovejess!!! This worked perfectly! I tried searching for this something like this last week, but my Googling skills apparently are not as sharp as yours. :eek: Anyway, I'm s-on rooted for now, bloatware gone, apps backed up. Scotty and everyone else, thanks again for all of this work! If I can figure out the how the code translates into Mac Terminal, I'll post back.
    scotty85 likes this.
  20. Daniel612

    Daniel612 New Member

    Hey i just wanna say thank you soooooooooooooooo much!!!!!!!!! im new to the incredible since my droid X broke, its been a pain trying to root the INC until i found this!!! thanks soo much now i have root access. Im going to donate on saturday!
    scotty85 likes this.
  21. krisdr

    krisdr Active Member

    I am so new to this but for all you who are too the instructions are dead on. If you are having troubles first go to "search this thread" and put in a key word to search your problem. There is bound to be an answer or two already in the thread. That is when all the pieces fell into place for me.

    For a couple of problems I had I will address here for any noob that has the same.

    When you put the mini-adb_inc on your c drive root... do not put in a file and then open it and then put on your c drive. Put the file unzipped on it. And then unzip.

    Also when putting PB31IMG on your sd card, you may have to play with the name. Although it might not say .zip, your phone may read it with the .zip. Try to play with the name if it does not work. You might have to play with it and add it.

    I have to do several steps, several times.

    Don't get discouraged because it does work. These guys are great and they know what they are doing. I am so blessed to have found ya'll.
    scotty85 likes this.
  22. royalstar

    royalstar Member

    My phone was Incridible s710d I upgrade OTA to version 2.3.4 and Hboot 1.04 and Room version 3.06.1401.3
    [​IMG]

    Please Help me how to root my device.
  23. scotty85

    scotty85 Guides Guide

    well,if you read the first post,you will see that this thread is NOT for the inc 2 ;)

    be forwarned,however,that closest RUU i can find to yours is 3.06.1401.0,so you may want to make a backup of your system,boot,and recovery images with adb,or at least make a nandroid backup of your stock system in recovery in case you ever need it.

    option #1 for you is to follow the link on the first post to downgrade to .97 hboot so you can run revolutionary.

    option#2 would be to purchase or borrow an xtc clip to turn the radio secure flag off. i cant say for sure it will work with 1.04 hboot,but it worked on mine with .98. clips are expensive to buy for 1 time use,but if you search craiglist or the forums youll usually be able to find someone fairly close that could use the clip to unlock your phone. ive seen folks charge anywhere from free to US $30ish

    #1 is reversable. #2 is forever. you cannot turn s-on after using the clip.

    hope that helps :)
    iowabowtech likes this.
  24. BamaDave

    BamaDave Member

    Thank you for these instructions. I was able to accomplish everything here and then downloaded CyanogenMod 7.1. Looks like I have plenty of storage space now in that 150MB data partition that was filling up constantly! *fingers crossed*

    The only flub has been the loss of most of my contacts.
    scotty85 likes this.
  25. incredible x4

    incredible x4 Well-Known Member

    Awesome guide. Thanks for the instructions. Unrevoked scared the crap out of me when I ran it. As soon as it opened it started the root process before I could select the recovery file. The root process ran just fine and my phone is currently doing a nandroid. Superuser installed and is working. I tested it with a screenshot app. I guess Unrevoked started running because I had the recovery file in the same folder as the unrevoked .exe file.

    For the moment I am going to stay s-on. I will probably fix this in the next few weeks when I have more time. I also think I am going to leave CWM alone too. My phone is amoled so the version that is flashed with Unrevoked runs just fine. Unless there are other reasons to upgrade?

    Once again great guide. I'm off to get Titanium and debloat my phone a little.
Thread Status:
Not open for further replies.

Share This Page