[How To] Root 2.3.4/downgrade and Get S-off


Thread Status:
Not open for further replies.
Last Updated: 2012-10-28 02:18:14
  1. pak96dds

    pak96dds Member

    I had the same message until i realized the phone had changed to disc drive instead of charge only. Had to change it. But now when i type su after the $ I get permission denied
    Do I start adb over?

    Advertisement
  2. joeshea24

    joeshea24 New Member

    I would confirm that you are using Unrevoked 3.22, you are describing the message that you get when using Unrevoked 3.32...maybe.
  3. scotty85

    scotty85 Guides Guide


    Have you successfully run unrevoked 3.22 and gotten superuser working and granting permissions to things?

    If so,then wake your phone up before typing adb shell. When you type Su superuse will pop up on the screen and ask for permissions. You'll have to allow permissions before the $ will change to a #.

    Of the phone is aslleep,you may never be aware of the popup requesting permissions. Not allowing permissions results in the permission denied error :)
    iowabowtech and dhs2011 like this.
  4. dhs2011

    dhs2011 Member

    scotty85, thank you for all of your help with rooting the dinc for my wife. I had to rerun adb and it worked fine. a long week but well worth it. kudos to you and everyone behind this thread.
    scotty85 likes this.
  5. scotty85

    scotty85 Guides Guide

    awsome! glad it worked out for you. :cool:
    iowabowtech likes this.
  6. Stretch44

    Stretch44 New Member

    I followed the steps and successfully gained root. However, after I rebooted I get a message that the System UIDs are inconsistent. I've tried doing a factory reset and still get the message. Also, when I reboot the phone is stuck in boot loop. When I boot into Hboot it says:

    Searching SD Card
    PB31DIAG.zip
    No image
    PB31DIAG.nbh
    No Image
    PB31IMG.zip

    Main version is older
    Update Fail

    Eventually I get the phone to boot up. I usually have to let it sit for awhile turn off.
  7. sdrawkcab25

    sdrawkcab25 Guides Guide


    Take the PB31IMG.zip file off the root of your sd card.

    You need to alter the misc.img file before you can load it.
    iowabowtech likes this.
  8. Stretch44

    Stretch44 New Member

    I took PB31IMG off the sd card. It's still stuck in bootloop. When I go into Hboot it shows several errors very quickly then the menu. Trying reboot, recovery, or factory data reset just puts me back in bootloop again.
  9. sdrawkcab25

    sdrawkcab25 Guides Guide


    The errors are normal, they always show up, unless you have a usable PB31IMG.zip file on your sd card. The one you had is for 2.2

    You need to get a hold of the PB31IMG.zip file for gingerbread(2.3.4) and place that on the root of your sd card.
    iowabowtech and scotty85 like this.
  10. scotty85

    scotty85 Guides Guide

    If you can't find the pb31img for the current firmwAre, the .exe file is linked a few posts back. You can run it by placing your phone in fastboot,then start the .exe
    iowabowtech likes this.
  11. Stretch44

    Stretch44 New Member

    Thanks, it seems to boot up okay now. I put the gingerbread zip in the card. What do I do about the System UIDs? I've cleared my data, done a factory reset, and reformatted my SD card, but I still get this message when I start the phone.
  12. Stretch44

    Stretch44 New Member

    I was finally able to do a factory reset through CWM and the System UIDs message is gone. Never had this much trouble rooting a phone, thank god it's just a phone to play around with and not my primary. Now on to downgrading to Froyo and turning S-off. Thanks again for all your help guys!
    scotty85 likes this.
  13. brockmanah

    brockmanah New Member

    I have to say this has got to be one of the most amazing posts I've seen in forums like this - though I may be a bit of a n00b. All of the complexity removed in one big post. I rooted my Droid post 2.3.4 and S-off with Unrevoked all in one shot.

    Now my question: Just after doing this I got a System Update push from the powers that be. Need I fear this will undue all my work? Am I supposed to use the superadmin feature to disable this sort of thing now?

    Thanks!!
    scotty85 likes this.
  14. scotty85

    scotty85 Guides Guide

    Glad you found it useful :)

    As for your question,if you're now rooted and running clockwork recovery,the update will not actually work. Your best bet to avoid constantly seeing it is to flash a custom rom.
    iowabowtech likes this.
  15. brockmanah

    brockmanah New Member

    OK - maybe this is a huge topic of itself but can you suggest a mod? Would CyanogenMod be OK? Thanks!
  16. railroadryan

    railroadryan Member

    ok i have a.d.h.d. like crazy my inc died and my company got me a replacement. i havent rooted a droid inc in over a year.. droid 2 droid x droid 3 plenty of times.. can some pleas poinr me to a detailed step by step to root a droid inc running gb
  17. scotty85

    scotty85 Guides Guide

    Yes... It is s huge topic of itself. I personally run cyanogenmod,but there are many good choices,including rooted stock rims :)
    iowabowtech likes this.
  18. scotty85

    scotty85 Guides Guide

    Past! First post ;)
    railroadryan likes this.
  19. railroadryan

    railroadryan Member

    lol i jumped to the last page thinking tha was the old way i done it last year lol.. thank you sir
    scotty85 likes this.
  20. scotty85

    scotty85 Guides Guide

    no prollem :) just holler if you have any questions :)
    iowabowtech likes this.
  21. railroadryan

    railroadryan Member

    that wasnt too bad at all.. im still used to all the moto stuff i work with for the wife and kids...

    btw how do i stop the ota from popping up since i went back to 2.2.... any rom recomdations? i ran cm7 for ever looking for somthing different
  22. nbdust14

    nbdust14 New Member

    every time I downloaded the zergRush.zip file i dont get the same md5 did i download the wrong one?
  23. scotty85

    scotty85 Guides Guide

    Sorry,no they have prolly updated it(see bottom
    Of 2nd post ;))
    iowabowtech likes this.
  24. gkinsella2

    gkinsella2 Member

    So, everything I've found about running ADB on Mac has been over a year old in the threads and assumes you have the full SDK downloaded. I've been assuming that's not needed for these instructions given the mini-adb package replaced that process. Is my assumption correct, or am I making an ASS out of U and ME? :D

    What I did learn is that you need to put './' in front of your commands in the Mac Terminal when running the command from the directory they are in. For instance, "adb devices" would be ./adb devices. Alternatively, you can drag the file from your Finder window and drop it into the Terminal command line so that you don't have to type out the entire path if not on a root directory (handy little trick!). I'm still having an issue with the "adb" command not being found in the directory, so not sure what's up with that...still trying to figure that part out though.

    Thought I'd share this info for the few Mac users that have popped up on here. Here's a link I found that was helpful:

    Using adb and terminal on a mac
    scotty85 and sdrawkcab25 like this.
  25. DroidInJax

    DroidInJax Well-Known Member

    Thanks so much for this thread!! I bought my Incredible on the 1st day they were sold and have finally rooted it! I got tired of the "low space" issues and was getting bored with the stock Sense. Now I've loaded Cyanogenmod 7.1 and LOVE IT! It's like having a new phone....That runs faster too!!
Thread Status:
Not open for further replies.

Share This Page