[TUT] How to force install apps to SD card without ROOT!!!Tips


  1. babus

    babus Active Member

    Hi Praky,

    Thanks a lot! Did everything successfully then I was having 30MB of free internal memory. Then I tried to install G+ and though it was installed on SD, my phone memory reduced to 26 MB. Is their any reason for this? Is it possible to move Maps, Market and G+ to SD? Or is there a way to remove these apps and install from the scratch? Whenever these apps are upgrading themselves they are growing in size successively. Like Maps now in my phone memory is about 11MB of size though the recent Maps app is about only 6MB in the android market. Also I tried to install Market 3.0 and now it's about size of 7 MB in my phone memory. :( I'm seeing no other apps are upgrading like this, eg FB. I wish if they can be removed and installed from the scratch. :cool:

    Also it'd be more helpful if someone tells me how to stop the automatic upgrade of Maps. It's totally annoying while I'm in roaming.

    I'm having Froyo and unrooted.
  2. praky

    praky Well-Known Member

    Googling before asking would help.
    If you have read the entire thread, that would have also helped.
    Not trying to be rude here.

    To stop automatic updates, go to market and uncheck automatic updates for a particular app. The market app can't be stopped from updating.
  3. rsaurabh2003

    rsaurabh2003 Well-Known Member

    I followed the TUT exactly , but i'm getting an error at the second command.


    response command "adb devices" the response is "List of devices is attached."
    As response on the command "adb shell " it comes back with the error:
    Error: adb shell not found

    What is going wrong.


    Thanks in advance.
  4. praky

    praky Well-Known Member

    I think USB drivers are not installed. Did you get a prompt?
    Is kies installed on your system?

    If you are still unsuccessful, this might help.
    http://theunlockr.com/2009/10/06/how-to-set-up-adb-usb-drivers-for-android-devices/

    You know what, try this before you try the above link-
    I have a gut feeling about this- SAMSUNG USB drivers from samfirmware.com
    Post the result.
    rsaurabh2003 likes this.
  5. babus

    babus Active Member

    Even a kid will know to turn off the automatic update if that option is available! There is no turn off auto upgrade option available for Maps though the other apps are having. I ended up asking here after a lot of googling and asking in other forums with no good results.

    How do you turn off auto updating? - Google Mobile Help

    How ever, Thanks for trying to help! :)
  6. aceuserr

    aceuserr Member

    hi
    ive downloaded the latest version on the sdk and have extracted and opened the file. when i run the android sdk and avd manager i cannot find the usb file or the revision 5 file. I don't have kies installed on my computer.
  7. rsaurabh2003

    rsaurabh2003 Well-Known Member

    Bingo...... worked.......
    But I can't move Maps...... Which is eating 10Mb internal memory......:confused:
  8. praky

    praky Well-Known Member

    Dude, if even a kid will know... how can't you...?
    I ahev never allowed maps to update in my phone.
    Go to market.
    Go to google maps.
    There it is first option on the app page itself.. "allow automatic updating"

    here is a screenshot
  9. chismay

    chismay Well-Known Member

    when you update to 2.3 this setting stays applied yay!!!!
  10. chismay

    chismay Well-Known Member

    ok look, go to android market, find google maps, open the page, see under download theres a check box saying "enable auto-update" deselect that and it wont update,

    please dont correct praki when he is obviously right and you are obviously wrong,

    can you find it?!

    [​IMG]

    Uploaded with ImageShack.us
    praky likes this.
  11. nosferatu_12

    nosferatu_12 Member

    Thanks a lot for the tutorial!
    I
  12. sid's_ace

    sid's_ace Member

    sorry i forgot to thank u.... thnx very much praky... u r a god sent... :):):):D:D:D:rolleyes::rolleyes::rolleyes:
  13. COOLGUY_150

    COOLGUY_150 New Member

    getting stuck at the begning
    cannot find the usb option though i have uninstalled kies and samsung driver also there isnt revision 5 but revisiion 6 available
    what do i do
    guys help please
  14. praky

    praky Well-Known Member


    The android sdk might have changed. And no need to uninstall kies.
    You can download the usb drivers from some post above. and install sdk and give it a try.
  15. COOLGUY_150

    COOLGUY_150 New Member

    thanks for replying pranky
    done as u told me
    i installed the samsung usb drivers from the above post and then installed revision 6.did the remaining steps
    But when i type pm setInstallLocation 2 in command promt i get a error saying access denied..
    wat do i do??? is it done????
  16. kushal619

    kushal619 New Member

    Hey pracky I followed de steps bt got stucked...my pc does not prompts 4 driverss wen I connect my phone...help
  17. nosferatu_12

    nosferatu_12 Member

    I belive is not asking you for drivers beacause you already got them (probably from Kies)
  18. kushal619

    kushal619 New Member

    Thanxx a lot,its done.......:D
  19. xPassion

    xPassion Member

    hmmm.. I just flash my galaxy ace to CodeROM v2x-2b and I did all the steps and when it comes to the end the setinstalllocation 2 it just cant find it. It shows /sbin/sh: pm: not found. Is there any solution?
  20. praky

    praky Well-Known Member

    dude, custom roms are pre rooted. No need for this method on them.
  21. xPassion

    xPassion Member

    I see.. But I dont know how to use their a2sd. I prefer this method.
  22. theCrazyGod

    theCrazyGod New Member

    Worked fantstically !

    Initially I had issues with loading Google USB drivers with 'code 10' error . [I had Kies installed on my PC]. Re-installed Samsunfg drivers using 'install driver' option from Kies menu. When reconnected device, PC recognised it and loaded samsung drivers. Rest was simple.
  23. theCrazyGod

    theCrazyGod New Member

    btw, I had to re-update my facebook profile login after this. FB showed me logged in earlier; but went into loop forever. Clearing data and re-login did work fine.
  24. umeshvardam

    umeshvardam New Member

    Thanks
  25. k-Otic

    k-Otic New Member

    Hey guys! I did everything the post says, I even got all the $ signs when I was supposed to but when I restarted my Ace and tried to see if I could move apps from the phone memory I was not able to. I even deleted one of the apps that was on the phone memory and tried reinstalling and it went to the phone memory again so m guessing it did not work. M kinda lost right now cuz I haven't been able to do it even tho I've tried like 5 times now.... Help :'(

Share This Page