Want the full 2.1 look on 2.01 - you're in luck!


Last Updated: 2011-01-01 23:15:20
  1. AZDroid

    AZDroid Well-Known Member

    Nope it doesn't

    Advertisement
  2. AzJazz

    AzJazz Well-Known Member

    I see a number of "Problem loading widget" displays on some of the pages. Are these widgets available for downloading?
  3. PerCompLLC

    PerCompLLC Well-Known Member

    Awesome! Very nice.
  4. Legacystar

    Legacystar Well-Known Member

    how do i do this?
  5. meekrab

    meekrab Well-Known Member

    Just trash those and replace them on the homescreen. Ideally, you should delete them off of the original homescreen as well so that you don't have two instances of the same widget.
  6. KoukiFC3S

    KoukiFC3S Well-Known Member

    It's working good for me, albeit a little slow.
  7. DaygosDankest

    DaygosDankest Well-Known Member

    I don't really like it, home ++ for me
  8. Legacystar

    Legacystar Well-Known Member

    seems to pick up after a bit
  9. superdesi

    superdesi Well-Known Member

    hmmm no live wallpapers......FC on my like crazy! and it froze and was being super unresponsive.....I'll wait for OTA thank you very much

    Lagging response with my droid in general since its been acting kinda funky recently. I might need a hard reset but im too scared to take the jump
  10. mrthundercleese

    mrthundercleese Well-Known Member

    Giving this a shot. The first impression after a reboot wasn't very good. It was super slow. I opened SmartMonitor and the CPU useage was pegged in the high 90%. Not sure what it was doing. It's calmed down now though and is much more responsive. I'll give it a bit before I bail back to home++.
  11. Hegemony

    Hegemony Well-Known Member

    It's pretty solid on mine. Only one force close. I'll use it for a while and see. Makes me want an official 2.1 update all the more. Wish we'd get some info on that... maybe Google will mention 2.1 updates at the Nexus One launch event.

    Edit: Okay, I don't think this is going to work. The 2.1 Launcher is using waaaaaaay too much memory. My first clue was that taskiller showed only a few apps running in the background. This is an issue because part of the fun of Android is being able to leave an app and jump back into it where you left off because it is running in the background.

    Running this 2.1 launcher, almost everything is getting killed by the system right away due to low memory. I checked, and the 2.1 Launcher is using 57MB (peak of 76MB) of memory with no widgets running. Launcher+ (a regular home replacement) is using only 27MB (peak of 34MB) with a ton of widgets running. Not gonna fly.

    It's very cool that someone managed to port the 2.1 version of Home. But it needs more work. Hopefully we'll all just get a 2.1 OTA sooner rather than later and this won't matter.
  12. RobStemen

    RobStemen Well-Known Member

    Here's how to do it:

    Step 1: Root your phone (instructions here: AllDroid.org - View topic - How to Root your Droid<<<ONLY)
    Step 2: Install Droid-root-helper from croatolus freak (I think I misspelled that, but instructions are here: AllDroid.org - View topic - App to install busybox,flash_image v7 (updated 12/23))
    Step 3: Apply busybox, flash_image, and SP recovery 0.15.0 (instructions in helper app)
    Step 4: Get MTBrowser.zip from here: [link removed]
    Step 5: Boot into recovery (button in root helper app, or just turn off and turn back on while holding the x key)
    Step 6: Do a basic nandroid backup (in SP recovery, [volume up/down to navigate, camera key to click] go to "backup/restore" and click "simple nandroid backup")
    Step 7: Mount your phone (in SP recovery, go to "mount options" and click "enable USB mass storage")
    Step 8: Copy the recently made backup to your computer (in the SD card, there'll be a subfolder "nandroid" go into it and there should be a folder titled with a string of letters and numbers, just copy-paste this into a directory you can remember on your computer)
    Step 9: Get the Android SDK from here: Android SDK | Android Developers (for simplicity's sake, I unzipped it into C:\android, but feel free to unzip it however you like, so long as you can remember it, and substitute your directory of choice where I type C:\android)
    Step 10: Unzip the MTBrowser.zip (again, for simplicity I unzipped it into C:\android as 2 separate files, with no subfolder, but the same things apply as step 9)
    Step 11: Unmount the USB storage (same way you mounted, except this time it says "disable USB mass storage"
    Step 12: Open the command shell (I only know Windows XP, so ask someone else for help if your system is different [XP users, open your "Start" menu, click run, type "cmd" in the dialog box and press enter, a black box with some white text should appear])\
    Step 13: Reboot your phone
    Step 14: Make sure USB debugging is on (go to settings>applications>development> and check the USB debugging box)
    Step 15: (The fun part ;) ) I'm just gonna type everything I typed word for word, just insert the directories like you did in place of my directories (C:/android)

    >cd C:\android\tools
    >adb shell
    $ su
    (from here on out, the system will repeat everything you type, don't worry about it unless the word "error" arises)
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    # rm /system/app/Browser.odex
    (close and reopen the command shell)

    >cd C:\android\tools
    >adb push C:\android\libmtwebcore.so /sdcard
    (blah kb/s transferred blah kb in blah seconds)
    >adb push C:\android\Browser.apk /sdcard
    >adb shell
    $ su
    # mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    # cat /sdcard/Browser.apk > /system/app/Browser.apk
    # cat /sdcard/libmtwebcore.so > /system/lib/libmtwebcore.so
    # reboot

    This worked for me, I hope it worked for you! Enjoy your pinching and your zooming!
  13. RobStemen

    RobStemen Well-Known Member

    UPDATE: Unlike, sayyyy Dolphin Browser, this pinch and zoom feels very smooth, quick and, best of all, natural. Just thought that I should let y'all know that.
  14. square

    square Well-Known Member

    wow...i'll just stick with tapping. :)
  15. Juneau

    Juneau Well-Known Member

    Mine was slow when I first loaded it. I uninstalled Home++ and set all of my pages back up and it seems to have calmed down for me as well. I did not check CPU usage but since you state what your was it seems as if mine did the same. I have been running it for a few hours now and it seems smooth and stable. I have a few widgets on the screens and many shortcuts.

    If people are having issues at first they should give it a few minutes and it seems to smooth out.
  16. meekrab

    meekrab Well-Known Member

    Excellent writeup, looks like you covered everything start to finish. I'll try this out later.
  17. RobStemen

    RobStemen Well-Known Member

    That's what I thought too, at first, and it does seem like alot of work, but it's really not. It just takes a little time, and in the end, it'll be worth it. Besides, don't you want to brag to your iPhone toting friends like I do ;) :p
  18. teschoen

    teschoen Well-Known Member

    Not keen on losing landscape mode... I use that in the car dock....
  19. AZDroid

    AZDroid Well-Known Member

    Well, I gave it a few hours but still kept getting way too many force closes, even after deleting my other homescreen app. It was a nice peek at what's coming though.
  20. superAndroid

    superAndroid Member

    Awsome! Works great!
  21. JYo

    JYo Active Member

    Will this automatically be sent to my Droid when the official version comes out? I'm new, and am willing to wait (really want more screens, but home ++, panda, etc. gave me troubles). Don't mean to sound dumb, just really have no idea, and I know you folks have answers :)
    Thanks
  22. celios

    celios Well-Known Member

    I've got a Milestone and actually use Dolphin in preference to the default browser... The reason? Dolphin actually wraps columns of text to fit the screen, unlike the default Milestone browser.
  23. RobStemen

    RobStemen Well-Known Member

    And that's your preference, and I am okay with that. When I used Dolphin, I didn't much like it. It felt just weird to me, but if you like it, hey, that's cool too. I don't judge.
  24. DanSan

    DanSan Well-Known Member

    used it for about 10 minutes.. deleted it.

Share This Page