Can't turn on Wif-Fi

paddyb

Newbie
I can no longer turn on Wi-Fi on my SGS 3. The icon either just stays grey or sometimes goes a dark shade of green for a while before turning grey again, but it still doesn't connect.

This began after using this app to restore my passwords:

https://play.google.com/store/apps/details?id=com.ryanamaral.wifi.passwords&hl=en

I've deleted the app, done a factory reset, cleared cache, tried WiFi manager apps, but nothing works.

I haven't changed the firmware, I'm on EE with the following 4.3 firmware:

Baseband: I9300BVUGNB2
Build: JSS15J.I930XXUGNB5

I hope somebody can help, phone is nearly useless to me without WiFi.
 

hatredg0d

Well-Known Member
If the problem survived a factory reset that is not a good sign. It does sound like a hardware problem even though you just started using that strange app.

Sadly the same thing happened to me on my first android phone the optimus. However I treated that phone poorly, both the SD card and wifi stopped after it got completely submerged in a puddle. It was not the first time and I did not even shut it off to dry. The phone and battery were also bent so bad the back cover no longer fit. It was a good excuse for me to get a upgrade.
 
Top