1. Are you ready for the Galaxy S20? Here is everything we know so far!

Error downloading, there is insufficient space on the device

Discussion in 'Android Apps & Games' started by darcwolf, Sep 17, 2011.

  1. darcwolf

    darcwolf Newbie
    Thread Starter

    I just bought a new android yesterday, the samsung infuse. I seem to be having problems with larger programs.

    The phone storage has 1.86gb and 1.57gb free, and the sd card has 12.95gb free.

    Whenever I try to download a larger app, (Third blade) it tells me I dont have enough space, and I clearly have more than enough.

    things Ive tried are turning off the phone, removing the battery and putting it back in.

    Running advanced app killer and stopping pretty much everything in the background.

    Ive tried going in and clearing cache from running programs.

    At this point I have no clue what to do. Anyone run into this and figured out how to fix it?
     


  2. Dirty330

    Dirty330 Newbie

    I have the same issues. I am curious as to the fix for this.
     
  3. darcwolf

    darcwolf Newbie
    Thread Starter

    After spending a few hours researching this I found out a couple things

    1. The samsung infuse has a 30mb partition for downloads which causes any apps that are over 30 megs to fail.

    2. This only seems to happen if you update your marketplace


    I went and uninstalled the newest update for the marketplace and now I can download anything. Give it a shot, hopefully it works for you.
     
    joelunch and EvershineDan like this.
  4. ler

    ler Lurker

    I'm having the same exact issue. Everything was fine last week though. How do I uninstall the newest update?
     
  5. Knitewulf

    Knitewulf Android Enthusiast

    The market is incredibly buggy (3.0.27). Also all newer Android phones seem to be having this problem all I can tell you is to wait for a fix.
     
  6. chanchan05

    chanchan05 The Doctor

    I managed to fix my "not enough space" issue by clearing the data from the market app and rebooting.
     
    joelunch likes this.
  7. EvershineDan

    EvershineDan Lurker

    I just uninstalled latest app market update too.
    It fixed the issue.
     
    joelunch likes this.
  8. CavemanJesus

    CavemanJesus Lurker

    I'm having trouble figuring out how to delete the newest update.
     
  9. MsMyste

    MsMyste Lurker

    settings>applications>manage applications>market>uninstall updates
     
    pipbro and joelunch like this.
  10. Madwand

    Madwand Newbie

    Uninstalled latest app market update, this does NOT fix the problem. Still can't update Paradise Island.
     
  11. Uninstalled Market updates. This DID fix the problem: the constantly nagging 'not enough space' icon in the notification bar is gone. And I could finally update a handful apps that had refused to for lack of space.
     
    joelunch likes this.
  12. xcnmhq

    xcnmhq Lurker

    The phone storage has 1.86gb and 1.57gb free, and the sd card has 12.95gb free.
    [​IMG]
    [​IMG]
     
  13. xFrozen

    xFrozen Lurker

    After days and days of trying various solutions that all failed, I finally found something that works! An app called MarketFix!
     
    pg1989pg, DBNissan, danonh and 2 others like this.
  14. How are you going to download and install an app like MarketFix if you don't have enough space to download...?

    You've got to create space first. I.e. you will need to uninstall apps. Unused, pre-installed, HUGE, apps (if not to say hated apps...)
     
  15. dukemeiser

    dukemeiser Lurker

    Actually this did work for me also. I was having trouble with a specific app (Google+) after a Titanium restore on Cyanogenmod. MarketFix did download and install (even though Google+ app refused). After I ran MarketFix, Google+ downloaded and installed like normal!
     
  16. RobPGru

    RobPGru Lurker

    Thank You xFrozen. That worked great.
     
  17. SmoknKynd

    SmoknKynd Lurker

    Thanks Frozen. Worked for me as well using BobzHome ROM with Link2SD.
     
  18. pbowman4

    pbowman4 Lurker

    What is ROOT access and how do you do this??
     
  19. danonh

    danonh Lurker

    Another success story using MarketFix! Thank you xFrozen!!!!!!
     
  20. danonh

    danonh Lurker

    It appears that I might have spoken too soon. The problem has returned. Using Caulkin's v2.8.1 ROM with EL29 modem...
     
  21. TheMacs

    TheMacs Lurker

    Have the same issue. Had it previously too. Plenty of space, but BIG apps (this time - Angry Birds Seasons , an update no less) seem to be a problem.

    Have a SGS2ET4G, so the new market/old market didn't help - have no new market update to uninstall.

    Last time, I was switching ROMs anyway, so I just re-installed apps fresh, installing the hogs first. Took a while (have way too many apps), but no problems.

    This has occured with a a few medium sized apps as well. Clearing the dalvik cache did work on these for me. Of course YMMV.

    Hope this helps some, and hope a better fix is on the way.
     
  22. DarrylGittins

    DarrylGittins Newbie

    I still have this problem. Is there still no resolution?
     
  23. jerofld

    jerofld Fixing stuff is not easy

    Have any of you who have posted recently tried deleting the Market's data?

    Settings > Applications > Manage Applications > All tab > Market > Clear Data.

    Clearing the cache alone may not fix it. Clearing the Dalvik cache isn't the same as clearing the Market's data. After I flash a new ROM, or update the phone, I always have to clear data on the Market at least once.
     
  24. ultramanjones

    ultramanjones Lurker

    I finally fixed this issue:
    I have LG Optimus V rooted (no mod) with ROM Manager (an app I got from the market) for recovery.
    I cleared the data and cache for the Market
    I cleared the dalvik cache
    I fixed permissions
    I rebooted

    First I went to
    Settings > Applications > Manage Applications > All tab > Market > Clear Data.

    I cleared the cache and the data. THEN I immediately cleared the dalvik cache as follows:

    I booted into recovery by first turning off the phone, then holding down the up volume button, power button, and home buttons simultaneously. Using the up/down volume buttons and the camera button, I then selected advanced and then chose to clear the dalvik cache. This took a couple of minutes.

    Then I chose the fix permissions option as well, just for good measure. It took awhile, looked all frozen, but after a few minutes it worked. ( I don't think this step is necessary by the way, but I'm including it because that is what I did)

    I navigated back to the home screen inside recovery (pressed the back button) and powered off. When I turned the phone back on it took a lot longer to boot by the way (was worried for a second there)

    That fixed it! I was finally able to download what I wanted on the Market. (SMS Pro)

    Hope this helps someone.

    This issue really helped to screw up my communications while I was traveling over the last 2 weeks. I've been looking for a fix the whole time!

    Cheers!
     
  25. AleksMG

    AleksMG Lurker

    I had the same problem with my desire, but I've solved it in the easiest way ever!! GO TO MARKET, download CACHE FIXER. THAT WILL HELP !! with that app you can chance the cache to 200MB, download whatever you want, and after a reboot you cache is normal again !! :)
     
Loading...
Similar Threads - Error downloading insufficient
  1. Bahria Town Rawalpindi
    Replies:
    13
    Views:
    216
  2. SteveD_Rdg
    Replies:
    0
    Views:
    250
  3. Christopher Clayton
    Replies:
    0
    Views:
    121
  4. Waldek
    Replies:
    0
    Views:
    166
  5. Danz47
    Replies:
    0
    Views:
    653
  6. HeadScratcher
    Replies:
    6
    Views:
    933
  7. CharlesLewis
    Replies:
    11
    Views:
    657
  8. akamilishi
    Replies:
    5
    Views:
    530
  9. RewindJAA
    Replies:
    0
    Views:
    1,819

Share This Page

Loading...