1. Download our Official Android App: Forums for Android!

Apps Mysterious things

Discussion in 'Android Development' started by robothito, Mar 12, 2016.

  1. robothito

    robothito Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    26
    3
    16
    Male
    Hello

    I dont know, I like Android but one thing that bugs me are the mysterious things that happen once in a while.. (specially with gradle.. who said it is a great thing..? :()
    Anyway this time I build a new application and instead of a blank activity I started with an empty activity.

    Again there appears the message "some rendering was not possible" but this usually dissapear when I reload the activity. But I got the awful message "2 gradle process running"

    Anyway I ignore that and tried to run the app as usual (an empty "hello world" app-nothing special ) and it took forever.. (meaning it never run) .. so I tried to kill the gradle processses and now it failed! :thinking:

    WHY! I mean so far I have been having no problems running even more complicated apps. It usually run like fast.
    So I went to the menu and choose Run-> Stop

    and then it finally run!!!

    what the....???!!! It runs when I stopped?? what does this all mean?

    Can someone tell me what is going on? Help please
     

    Advertisement

  2. LV426

    LV426 I say we take off and nuke this place from orbit
    Recognized Developer
    Rank:
     #12
    Points:
    1,988
    Posts:
    9,176
    Joined:
    Oct 16, 2015

    Oct 16, 2015
    9,176
    13,681
    1,988
    Male
    Software developer
    South West of England
    Honestly mate if you ever went through Java jar compatibility hell you would appreciate the magic provided by dependency management tools like maven or gradle.

    I think you should start by resolving your rendering issues. When you say you 'reload' the activity, what exactly are you doing?
     
    El Presidente likes this.
  3. robothito

    robothito Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    26
    3
    16
    Male
    I suppose that one day i will appreciate it.
    By reload I mean I click the reload button on the design window.

    Yesterday it was a bad bad day. I tried to run android studio on my windows pc. Bad idea I spent the whole day. and I couldnt do anything. Error after error. gradle running forever (I suppose it doesnt help that I had chrome open in like 20 tabs I guess). One error not finding the base class

    Cant not resolve symbol AppCompatActivity

    and then suddenly finding it. Another error nor finding "R". (which in my mac it always find- correction, now suddenly my mac cant find it either :( )
    Finally I havent installed genimotion there so even when all errors were corrected (sometimes without knowing why) coudlnt run a single emulator. Always find something like "not being compatible". Finish the day in frustration with 0 work done... sigh

    Right now opening the mac to see if it works here... wish me luck

    I guess my frustration comes that I cant rely whether android studio is going to work fine or not depending on the day.

    Theory? I am already studying a lot. learning android. All in my head....
     
    #3 robothito, Mar 26, 2016
    Last edited: Mar 26, 2016
  4. robothito

    robothito Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    26
    3
    16
    Male
    Ok. here are the problems I find now

    - R could not be found on the java file.

    I ignored this and run the app (a "hello world app") on genimotion.
    I got the awful gradle 2 process running. and it never run

    So I press RUN-.Stop and I killed the gradle processes

    Now I got rendering problems "The following classes could not be instantiated android.support.v7.app.WindowDecorActionBar

    However now it is running on the emulator...

    can someone explain to me why it only runs when I "stopped" the running??

    EDIT: Confirmed. I had to stop working in my mac. went to do some other thing. came back, still got one gradle process running and got error from genymotion
    Then stop the running and it run!!

    (as far as I remember this thing only happen with "Empty Activity" not with "Blank Activity"- will confirm that later)
     
    #4 robothito, Mar 26, 2016
    Last edited: Mar 26, 2016
  5. robothito

    robothito Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    26
    Joined:
    Feb 2, 2016

    Feb 2, 2016
    26
    3
    16
    Male
    Well strange as it sounds, now the problems seem to be gone...
    what I did was, now I create all my projects with Ice Cream Sandwich... with it gradle is a little faster and now it runs ok.
    sigh...
     

Share This Page

Loading...