1. Download our Official Android App: Forums for Android!

Support Need a little help!

Discussion in 'Android Devices' started by soutrhernraider, Jun 2, 2011.

  1. soutrhernraider

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    6
    0
    5
    Guys im tryin to update to 2.1 but the updater only goes as far as the prepare stage and then i get a message saying there was a problem so lets try again! This has happened 5 times! whats wrong?? :thinking::thinking:
     

    Advertisement

  2. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    If you are using the PC Companion to update, then I would highly suggest downloading SEUS from the Sony website.

    I was never able to upgrade to 2.1 using PC Companion and had to install SEUS to upgrade.

    Sony Ericsson - Support - Softwaredownloads - Detailed - Updateservice - Xperia? X10

    One more thing you can do is restart the phone if you haven't. Definitely try a different USB port. I was able to update to 2.1 on one port, then a week later, I needed to plug into another port for a small update after that.

    Make sure you are logged into Windows with an Administrator account....or in Windows 7 right click on the SEUS app after you installed it and chose to Run As Administrator.

    I am sure you'll get it.
     
    soutrhernraider likes this.
  3. soutrhernraider

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    6
    0
    5
    still nothing my friend!! thanks for your help anyway!!
     
  4. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    What does it do? Does it quit while downloading the file from Sony or does it get past that and quit at the install somewhere?

    For me the problem was downloading. But that was probably because my cell provider and Sony had just released 2.1 and there was a mad rush whee everyone was downloading it.

    Does the phone go to Flash mode? Turn phone off....hold back button while plugging phone into USB port. And the Green light shows...but the phone appears off?

    You might want to first remove any software installed on the phone and do a repair on the phone first using SEUS and see if it will let you do that.

    All else fails I am sure you could just root it and install 2.1 the other way.

    You could follow this guide and download any version you want - http://androidforums.com/x10-all-things-root/272949-flashtool-guide-how-n00bies.html
     
  5. soutrhernraider

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    6
    0
    5
    even the rooting process didnt work! this is insane!
     
  6. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    If you can't update or do anything...you might want to try and reflash using that link:

    http://androidforums.com/x10-all-things-root/272949-flashtool-guide-how-n00bies.html

    You download the X10 flasher, download the x10a or x10i depending on what you have and flash the phone with 2.1 fresh. If it fails, exactly what step does it fail at?

    Make sure you are using the Sony x10 USB cable that came with the phone.

    Anyone else have any other suggestions?
     
  7. soutrhernraider

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    6
    0
    5
    Hey my freind! Thanks for your help but nothing worked! The flash tool said "preparing files for flashing" then the green light went off and the phone restarted! UGH!!!
     
  8. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Use a different USB port on the computer.....Right click the x10Flash program and chose to Run As Administrator.

    a. Unplug your USB cable from PC (unplug the USB cable on the PC, not the phone)
    b. Power off your phone (wait a couple seconds after it is off)
    c. Press back button and keep your finger on button (keep that back button held down)
    d. Plug USB cable to PC (while still holding back, plug it into the PC)
    e. Check if the green LED appear

    Then follow the onscreen steps.

    If it is possible, maybe try this in a different computer. Are you running something strange?

    YouTube - ‪Upgrading a Sony Ericsson Xperia X10 from 1.6 to Android 2.1 (Eclair) on a Rogers X10a‬‏

    Watch from 1:35 - 2:00 min....The guy in the video is doing it the old way with no graphical interface. But that is another way to do it.

    Open the x10 Flash program, remove battery, plug in USB and hold back button....while holding back and it is plugged in, insert the battery.
     
  9. soutrhernraider

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    6
    0
    5
    Dude thanks for all of your help! Gave it a few more tries and nothing happens! After the green flash light comes on,the phone restarts and the program shuts down(SEUS,PC Companion,and the x10 Flash Tool)
     
  10. beau420

    beau420 Android Expert
    Rank:
    None
    Points:
    143
    Posts:
    1,104
    Joined:
    Nov 10, 2010

    Nov 10, 2010
    1,104
    173
    143
    Computer Guy
    Ottawa
    Are you sure your back button is working?

    Your phone should never turn back on.

    For me, after I turn my phone off (hold down power button till it vibrates once, and chose Turn Off), it stays off until I turn it on.

    If my phone is off, and I plug it into my computer while holding the back button. I get a solid green light for a few seconds, then it says Sony Ericsson, then it shows the battery icon on the screen showing it is charging, but the phone hasn't started up.

    Is that the same for you?

    What version of Windows and you on a laptop or desktop and if you have?

    Even if I do the same steps above when I plug the phone into a USB charger, it does the same thing...doesn't start the phone, just shows the battery icon on the screen. It needs to be in that mode for the phone to continue.

    Does your phone have an SD card in it? Don't think that should matter....but...who knows.
     
  11. soutrhernraider

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    6
    Joined:
    Apr 30, 2010

    Apr 30, 2010
    6
    0
    5
    The back button works! After about 30 seconds the phone restarts! Im still running Vista! Ill try it on another machine later or hell ill take it to an AT&T store!! LOL! Thankls for yopur help my friend! IF there are anymore suggestions please let me know
     

Share This Page

Loading...