1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

USB question for Galaxy 2S SkyrocketSupport


  1. Brunomics

    Brunomics New Member

    Hello all, I recently just came over to Android on AT&T and ended up purchasing the Galaxy S2 Skyrocket from them. It's a fantastic phone but with one issue that I can't seem to figure out and need some help on. The issue goes like this:

    When I connect the phone to my PC it is only charging the phone. On the Skyrocket it does not even recognize that it is connected to the PC and only charges as well as the pc. I have no clue what to do in order for the PC and phone to recognize that they are connected via usb in order to start moving files. If anyone can help me out here I'd greatly appreciate it because I'm all out of ideas on what to do.

    Advertisement
    :
  2. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    Welcome to the forums, Brunomics.

    It sounds like you do not have USB debugging enabled:

    -Enable usb debugging from Menu > Settings > Applications
    -return to home screen
    -plug usb cable in
    -pull down status bar
    -press
    mdanderson, wkbattis and Brunomics like this.
  3. chilipalm

    chilipalm Member

    hmmm I never had to enable USB debugging to connect USB storage. The option was always there in the notification pull down bar.
  4. Brunomics

    Brunomics New Member

    Thanks! I did what you said and after I pulled down the Status Bar I did not have the connect usb storage option. My list is as follows - Wi-fi/Bluetooth/GPS/Flight Mode/Screen Rotation.

    I also installed Kies but that hasn't helped recognize the phone connection also.

    It's almost as if the phone doesn't recognize the PC.
  5. Frisco

    Frisco =Luceat Lux Vestra= VIP Member

    I'd try all the simple things first, such as rebooting the PC and then the phone. Uninstalling Kies and reinstalling, etc.

    Also, I'd go into application manager and clear out data and caches on just about everything that does not have the data and cache buttons greyed out.

    I'd even go into the recovery menu and clear cache from there, etc.

    Then I'd try again.
  6. Mr. Ed

    Mr. Ed Well-Known Member

    Many users have had to manually download the drivers. I will try and find the link from my personal computer

    (at work right now)
  7. gmoney5588

    gmoney5588 Well-Known Member

    is there a way to have it automatically enable it? i think ogs2 was able to do it
  8. Mr. Ed

    Mr. Ed Well-Known Member

    yes, it is in the menu settings just like it was on the ogs2. I don't have my phone with me otherwise I would direct you to the exact location.


    These drivers have helped many who were not connecting.

    T-Mobile_t989_GSII_ADB_Drivers.zip
    satyaramisetty likes this.
  9. FlatWoodsM

    FlatWoodsM Member

    ya i had to DL a driver to my computer.
  10. efantom

    efantom New Member

    Which one? +1

    I'm having the same troubles, please help.
  11. efantom

    efantom New Member

    Finally got it working. Here is the link to the driver that worked for me:

    Samsung_Mobile_Driver_V1.3.800.zip

    If that link stops working search for:

    Samsung_Mobile_USB_Driver_V1.3.800.0

    The other thing I learned is that some of the usb cables are for "charging only". That is what I was trying to use. I apparently ripped that sticker off of the cable when I got it. Use the usb cable that came with the phone.

    Once I had this driver installed on my computer, this is the process I use to get it to show up on my Windows 7 Proffesional 64 Bit:

    Plug in usb cable to phone but not to the PC,

    Home Screen --> Settings --> Wireless and Network --> USB Utilities
    Then click "Connect Storage to PC"
    POP Up says: Connect USB cable to use mass storage.
    Plug in other end of USB cable,
    Pop Up says: USB connected,
    Click "Connect USB Storage"

    You should have some "Removable Storage Device" show up on your computer now.

    I hope this works for someone else too. I'm new to all this, this is my first smartphone. I have to admit it seems like Android makes things very over complicated. Every simple tasks seems to take hours searching the net to figure out how to do it. Customization is great and all but have mercy.
    wkbattis and jamiecakes like this.
  12. Thiat302

    Thiat302 Active Member

    I don't have to do any of that- i plug mine into my comp. and a screen pops up asking if I want to go into USB storage mode and boom- its connected-
  13. ya, for a laptop and Windows 7 32bit system I have it works like that too. Just the 64 bit giving me trouble
  14. davidgoerndt66

    davidgoerndt66 Well-Known Member

    I tried this for the first time yesterday, I wanted some images off my laptop for new wallpaper. I simply hooked up the phone via the usb cable provided, the computer recognized a new device, however, the driver failed to load which didn't seem to make any difference as my computer saw both the sim card and SD card. Transferred the images I needed and unplugged with no problems.
  15. noworrychicken

    noworrychicken New Member

    First of all, to all you dinkhouses that replyed to this thread and don't actually have a Skyrocket (I know your jealous) thanks, but no thanks as you were no help at all.
    Folks that do have a Skyrocket listen up as this is the true route you will need to take to get the connectivity you seek.
    First, take a look at the the supplied usb cable that came with your device. You will notice a sticker attached to that cable that states: Charging only cable. Pretty much that is the entire problem, what a joke and shame on Sumsung for supplying a cable that will not connect and states nothing about it in the manual. Obviously, that cable is for charging and not connectivity. With that being said I purchased an additional charging cable for the ATT store, which should be the standard after market cable sold by ATT. This cable did not have the same dreaded sticker attached and when I plugged in...success.
    Not so fast, there is a process that you must follow in order to connect as followes: settings, wireless and network, usb utilities, than tap connect storage to PC followed by connect USB storage. At this point you will be connected and you will see both the internal storage and SD card. In addition, and in order to disconnect you will have to tap disconnect storage from PC on the phone before attempting to remove the device from your computer.
    Just so you are aware this works on both a Mac and a PC and no drivers are required. I did have to pony up about $30 for the aftermarket cable/charger. If you have a cable of your own that might wark as well, but I prefferred to have a charger at work as well as at home so no really biggy.
    Galxaxy S2 Skyrocket reins supreme on to the next.
  16. Mr. Ed

    Mr. Ed Well-Known Member

    Interesting indeed. My supplied cable worked fine....just had to install the drivers.
  17. noworrychicken

    noworrychicken New Member

    Folks that own a skyrocket and listen to mr. Ed instead of paying for the actual cable that works, be prepared to deal with a virus. I did what the posts claim. Download drivers and you'll be good to go. Not true, just ended up with a virus. Thank goodness i have some skills and so the virus was a none issue, but still, come on you people who post info that is false and even worse uploads a virus to users machines. We come here for help and that is what we expect to find. Administrator, you should download said drivers and the delete any posts that claim drivers are the solution after you rid your machine of the virus.
    Pony up the cash for the proper cable and you will have the connectivity you seek. One last thing, you should let Samsung know that this is total crap. I am sure the cost of the cable is no different than the one they suppied.
  18. Mr. Ed

    Mr. Ed Well-Known Member

    Please pm me regarding viral posts so that I can have them removed
  19. WickR1

    WickR1 Active Member

    I had this same issue. I just restarted my phone, plugged in the USB cable and the USB notification worked again. I didn't mess with any settings.
  20. Midiman

    Midiman Well-Known Member

    This is, essentially the right approach with a few modifications. The other guy who said USB Debugging had to be enabled is misinformed. You should not need any drivers if you are running Windows 7. If you do, for some reason, most of the time unzipping the "Samsung" drivers file reveals a driver for T-Mobile. This is fine, they work for the AT&T Skyrocket. You will probably need these if you're running XP. I haven't tried it on my last remaining XP machine. You should not need to plug the USB cable into the phone first, without plugging it into the PC. My cable has always been plugged into the PC first and it works fine as long as you follow the directions on the screen.

    Home Screen --> Settings --> Wireless and Network --> USB Utilities
    Then click "Connect Storage to PC"
    POP Up says: Connect USB cable to use mass storage.
    Plug in the USB cable, (my cable has always been plugged into the PC first)
    Pop Up says: USB connected,
    Click "Connect USB Storage"

    You should have some "Removable Storage Device" show up on your computer now.

    Anything in bold in the original quote was added by me.
  21. Midiman

    Midiman Well-Known Member

    I got the "driver failed to load or install" error as well on a 64-bit Win7 machine. It worked fine anyway as long as I followed the proper procedure outlined above.
  22. Midiman

    Midiman Well-Known Member

  23. Midiman

    Midiman Well-Known Member

    Are you absolutely sure about this? I bought my Skyrocket and an extra AT&T Zero Charger cable on the same day because my collection of over 1000 audio/video/computer cables doesn't have a single MicroUSB. I knew the 3' cables would be insufficient but needed at least two until I could order better, longer ones which I did as soon as I got home. The picture of that aftermarket accessory on AT&T's website shows the black plastic tag with "Charge only Cable" printed on it. I guess the only way to know for sure now, is to go back to the AT&T store and pull one of their cables out of the box. I tossed the box for the cable right at the store and threw the cable in the box with the Skyrocket. It's particularly important for me to know which is which because of testing I am doing on the "100% battery stuck" issue. Can anyone else confirm that the cable that came in the OEM box with the phone has this sticker?? The one marked "Charge only Cable, 14L, Made in China" DEFINITELY does NOT work for USB data connections. I don't understand how you can make a MicroUSB cable that doesn't adhere to MicroUSB standards. That's "learning disabled"!! Can't say the "R" word here.

    You can find pictures of the cable I'm referring to on page 3 of this thread:

    http://androidforums.com/samsung-ga...-has-battery-meter-issue-i-e-stuck-100-a.html

    Link to accessory page on AT&T's site:

    http://www.wireless.att.com/cell-ph...k&q_sku=sku5390262#fbid=27aQfOX4o8n?tabModule

    except the link doesn't work, you have to click the "Compatible Accessories" tab.

    Confusion solved, I think. The black tag, "Charge only cable" has the male, type-A (large) connector marked AT&T on one side. This is the aftermarket cable and should NOT have been included with your phone. The one that came with your phone should be fine for USB data connections. noworrychicken has his cables bass-ackwards. Futher evidence, the microusb connector is very different in terms of shape and size. It's still interesting to note this cable is the only one of three I have tested that never results in the "100% battery stuck" indicator issue that is widely reported.
  24. Mr. Ed

    Mr. Ed Well-Known Member

    that makes more sense ... all 5 of our skyrockets came with cables that worked fine and had no markings
Loading...

Share This Page